Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Paper Tape
Posts: 1
Registered: ‎07-23-2010
Location: MI, US
0 Kudos

Intel X18-m (160Gb) failure in X301

I tried to replace the stock (64Gb) SSD in my x301 with a new intel X-18-m G2. The drive works flawlessly in any other computer (desktops) I have tried but fails in the x301: error 2100: HDD0 initialization error (3)

I made sure both BIOS and firmware (for the SSD) are up to date and that BIOS was set for compatibilty mode for the drive. Any help would be gretly appreciated!



Blue Screen Again
Posts: 2
Registered: ‎08-24-2010
Location: Sweden
0 Kudos

Re: Intel X18-m (160Gb) failure in X301

sam error for me with a new 120gb ssd

Blue Screen Again
Posts: 20
Registered: ‎01-05-2009
Location: Cambridge, Massachusetts, USA
0 Kudos

Re: Intel X18-m (160Gb) failure in X301

I also could not get the Intel 18 series SSD to work; any news on this front? anyone from Lenovo, perhaps?





Punch Card
Posts: 11
Registered: ‎03-10-2011
Location: UK
0 Kudos

Re: Intel X18-m (160Gb) failure in X301

I just put the same drive in my X301 this morning and it's working fine. I left the sata setting on AHCI. I did run diskpart first and cleaned the drive and created a primary partition. After that I used the recovery disks to reinstall. Everything thing went smoothly and I'm getting a 7.8 on the WEI score!