Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

1 Posts

07-22-2021

Singapore

2 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎07-22-2021
  • Location: Singapore
  • Views: 5
  • Message 21 of 66

Re:X1 C8: HDMI not working after BIOS 1.19 update

2021-07-22, 2:04 AM

I'm facing the same issue following the BIOS update, I tried using different HDMI cables with no success. Hopefully we can get a fix soon! 

Reply
Options

1 Posts

07-22-2021

Netherlands

3 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎07-22-2021
  • Location: Netherlands
  • Views: 5
  • Message 22 of 66

Re:X1 C8: HDMI not working after BIOS 1.19 update

2021-07-22, 12:02 PM

I had the same issue with my X1 Carbon 8th Gen. Connecting to external monitor via Lenovo docking station.

 

I rolled back to 1.18 and this fixed my issue immediately.

Reply
Options

3 Posts

07-21-2021

Taiwan,China

7 Signins

80 Page Views

  • Posts: 3
  • Registered: ‎07-21-2021
  • Location: Taiwan,China
  • Views: 80
  • Message 23 of 66

Re:X1 C8: HDMI not working after BIOS 1.19 update

2021-07-22, 12:05 PM

yes, me too, I also rollback to 1.18 to fixed this issue temporarily.

Reply
Options

28 Posts

07-22-2021

Pakistan

11 Signins

205 Page Views

  • Posts: 28
  • Registered: ‎07-22-2021
  • Location: Pakistan
  • Views: 205
  • Message 24 of 66

ThinkPad X1 Yoga Gen 5 - HDMI Issue

2021-07-22, 16:08 PM

Dear Members,

 

We have recently procured X1 Yoga Gen 5 approximately 2 months back. We have suddenly faced an issue with HDMI Problem. We are running Windows 10 Enterprise Edition. External Monitors is connected via HDMI it was working fine suddenly there is no output on display. We have tried reinstalling the graphics driver but there is no output.

We have changed the cables, Monitors, checked the cables on other monitors its works well. We had contacted local support here we were informed and given demonstrations by performing installation of Windows 10 Professional and it started working after driver update. Is it due to OS? As per understanding Professional or Enterprise Editions doesn't have architecture differences only feature differences, Please correct me if I am wrong. Local support informed that Windows Pro is recommended and the HDMI issue is due to OS. 

 

As of today, we are not able to fix this issue . Anyone of our community members has encountered same issue please help us .

 

Regards 

 

 

Moderator comment: Moved to the proper forum. (NateS)

Reply
Options

1 Posts

07-22-2021

Canada

2 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎07-22-2021
  • Location: Canada
  • Views: 5
  • Message 25 of 66

Re:X1 C8: HDMI not working after BIOS 1.19 update

2021-07-22, 16:19 PM

I had the same issue on 7/20/2021. I tried several things to fix it but no luck, until I read your post. Many thanks for sharing the solution, it worked for me.

Reply
Options

7 Posts

07-23-2021

Cambodia

13 Signins

110 Page Views

  • Posts: 7
  • Registered: ‎07-23-2021
  • Location: Cambodia
  • Views: 110
  • Message 26 of 66

Re:Issues with 1.19 Firmware on X1 Carbon 8th gen 20UA

2021-07-23, 5:29 AM

Exactly the same issues here!

 

These are the symptoms I observe:

- external monitor receives no signal when attached directly to laptop HDMI port

- external monitor receives no signal when attached via an external dock (Dell DA300) to the laptop via USB-C Thunderbolt (neither HDMI to dock nor DisplayPort to dock work).

 

In both scenarios the monitor recognises that it is attached to the computer because it is not going into power save mode - but it receives no signal.

 

Conversely, using a different external port replicator (HP 3005pr) that connects via USB-A works fine - both with HDMI and with DisplayPort cables. This port replicator uses DisplayLink Software.

 

...on a related note: where do I find instruction how to roll back the BIOS to 1.18?

 

Thanks!

 

Reply
Options

7 Posts

07-23-2021

Cambodia

13 Signins

110 Page Views

  • Posts: 7
  • Registered: ‎07-23-2021
  • Location: Cambodia
  • Views: 110
  • Message 27 of 66

Re:X1 C8: HDMI not working after BIOS 1.19 update

2021-07-23, 5:40 AM

Same issue here - in addition, going into the BIOS at startup shuts the computer down after about 1-2 minutes in the BIOS 1.19...

Reply
Options

4 Posts

07-20-2021

Kuwait

4 Signins

15 Page Views

  • Posts: 4
  • Registered: ‎07-20-2021
  • Location: Kuwait
  • Views: 15
  • Message 28 of 66

Re:Issues with 1.19 Firmware on X1 Carbon 8th gen 20UA

2021-07-23, 5:49 AM

They recalled 1.19 now, 1.18 is available for download. You need to deselect the option "firmware rollback prevention" under security section in BIOS before installing.

Reactivate the same after install, it's a security feature.

Hope it helps.

Reply
Answer
Options

11606 Posts

09-04-2014

Slovakia

33045 Signins

1235575 Page Views

  • Posts: 11606
  • Registered: ‎09-04-2014
  • Location: Slovakia
  • Views: 1235575
  • Message 29 of 66

Re: Issues with BIOS 1.19 on X1 Carbon 8th gen and X1 Yoga 5th gen

2021-07-23, 12:05 PM

Hello All,

Engineers have been looking into the issue reported, thank you all for your constructive input, and expect to be releasing a new BIOS version, to fix the issue experienced as a result of installing 1.19, soon once it has been properly packaged and completed the verification process. I don't at this time have an ETA but usually would expect to see the update within two weeks.

 

Andy

 

English Community Administrator
Lenovo eServices

Please remember to come back and mark the post that you feel solved your question as the solution, it earns the member + points 
Did you find a post helpfull? You can thank the member by awarding them a Thumbs Up
 

Please don't ask me questions by Personal Message; questions belong in the forums.


Using Browser Search to find your answers in Lenovo and Moto Community

0 person found this solution to be helpful.

This helped me too

Reply
Options

3 Posts

07-23-2021

United States of America

3 Signins

35 Page Views

  • Posts: 3
  • Registered: ‎07-23-2021
  • Location: United States of America
  • Views: 35
  • Message 30 of 66

Thinkpad X1 Carbon 8th Gen - No longer supports external display

2021-07-23, 13:45 PM

 

I had been using my Thinkpad with a display via the Thunderbolt cable to a Thunderbolt 3 Dock Gen 2 with HDMI out. This setup had been working well, but all of a sudden in the past 48 hours I cannot get any displays to be recognized by the laptop. I tried using HDMI directly from the laptop out to two different displays and neither works. The computer does not recognize the displays. I also tried a USB to displayport cable. Again, nothing.

 

I believe there may have been a BIOS update from the Lenovo Vantage that kicked this off.

 

Anyone else having this issue? Any suggestion of solutions?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All