Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center

Keyboard causes beeps / dings

0 Kudos
Click ►
Started ‎08-03-2011 by
Modified ‎08-03-2011 by


Just got my X220 (i7, 4gb, 300hdd) a few days ago; and I notice a beep noise after hitting a certain combination of keys. The beep occurs every time I hit a 3-key combination consisting of any key + the key above + the key to the left.

For example the beep occurs, when I write "fre" or "vfd" or "loi".


But it also occurs when typing "ouh" or "oun" or "oum". The weird thing is: it only beeps when I type the 3 letters quickly. If I type slowly, no beep noise is made.


After the beep, nothing else happens. I can continue writing and no error message or anything else comes up.


It is a normal with ThinkPads, you can turn off Keyboard Beeps in the BIOS menu.


  1. Press  F1  at the ThinkPad POST screen.
  2. Highlight  Config  using the arrow keys, and press Enter.
  3. Highlight  Alarms  using the arrow keys, and press Enter.
  4. Highlight  Keyboard Beep , and press  F5  to change the value to  [Disabled] .
  5. Press  F10  to Save and Exit.
  6. Choose  Yes  to save your changes.


Here is an alternative solution:


The ThinkPad keyboard has 2-key rollover, and will jam on certain 3-key combinations.

For technical information, see the Wikipedia article.