Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

3 Posts

05-06-2009

Arlington, Massachusetts, USA

6 Signins

32 Page Views

  • Posts: 3
  • Registered: ‎05-06-2009
  • Location: Arlington, Massachusetts, USA
  • Views: 32
  • Message 1 of 4

Lenovo X200 refuses to go to sleep

2009-05-06, 19:30 PM
Hi,

 

I am having problems with my Lenovo X200 refusing to go to sleep. When I hit Fn-F4 or choose sleep from the menu, the screen goes black, the computer fan/harddisk noise goes down just as if it is going to sleep, it beeps and the moon lights up. But then immediately (within a second) the computer beeps again and powers up. The behaviour is the same regardless of whether the computer runs on AC or battery. Interestingly, however, when my Internet connection is wireless instead of via cable, sleep mode seems to work.

 

More details follow below. Sorry for the somewhat lengthy post, but I want to try and give all details that seem to be relevant. The concrete problem is exactly as described above, however, so if the extra information is not needed, feel free to skip the rest of this post.

 

I have a Lenovo X200 7454CTO running Vista Business 64. The problem with sleep mode actually originated from other problems with Access Connections, so I'll start from there.

 

I bought the computer last October and had not updated any Lenovo software since. However, the last months Access Connections had started to hang when I wanted it to switch between cable and wireless connections. Specifically, when unplugging the cable because I needed to go somewhere else in the apartment, it was not possible to get the wireless connection started instead. One solution that always worked was to log out and log in again, but in the end that became annoying. So yesterday I decided to fix the problem.

 

I updated first the system with Windows update, then Intel ProSET Wireless, and finally Lenovo Access Connections (following suggestions in posts in the Lenovo forum). The instructions at the Lenovo page said that (reasonably) updated versions of Lenovo Hotkey Driver and Power Management Driver were needed as well for Access Connections, and since my versions seemed kind of old I updated them.

 

After some problems, I finally got Access Connections to work again more or less as it should. Meaning: it is very slow at times, and sometimes it even almost hangs (having Vista issue a warning that the program does not seem to respond), but in the end it works. When I unplug the network cable, it thinks for a while, but then figures out on its own that the wireless card should be switched on and establishes a wireless connection. Similarly, when I plug in the network card again, the computer turns off the wireless card after a while and switches to the cable connection (although this can take 30 seconds, say, under which time Access Connections and/or Wireless Connection Status do not respond). Also, I can do the switch manually if I like, provided that I have some patience to wait until the programs respond.

 

So far, so good. That is not the problem of this post.

 

The problem of this post is that after the updates described above, sleep mode refuses to work! I spent quite a few hours last night trying to figure out why. Among other things, I updated the Lenovo Power Manager, and then tried to uninstall and reinstall both the Power Management Driver and the Power Manager multiple times. To no avail. I also spent lots of time searching in the Lenovo forum posts, but I have not found any solutions there to my problem

 

Today, I have continued researching the issue. By now, I am fairly positive that sleep mode works when my Internet connection is wireless and does not work when I have a cable connection. I have tried to vary all other settings, and the type of connection seems to be the decisive factors whether sleep mode works or not. I have no idea why this is so.

 

In a way, this might seem to be a minor issue, but I see no sensible reason why sleep mode should *not* work. It is annoying that you cannot keep the laptop on your desk but let it sleep and not disturb you when you do not need it.

 

Any suggestion how to fix this problem would be very much appreciated.

 

Reply
Answer
Options

15 Posts

03-22-2009

Cambridge, England

671 Signins

2210 Page Views

  • Posts: 15
  • Registered: ‎03-22-2009
  • Location: Cambridge, England
  • Views: 2210

Re: Lenovo X200 refuses to go to sleep

2009-05-06, 21:33 PM
In Device Manager, open the properties of your wired ethernet adapter. Click tab "Advanced".  In the "Property" box, scroll down to find "Wake on Settings" and select it.  In the "Value" drop-down, select "Wake on Magic Packet".  Click OK.
Message Edited by rdhw on 05-06-2009 10:34 PM
Reply

Replies(3)
Answer
Options

15 Posts

03-22-2009

Cambridge, England

671 Signins

2210 Page Views

  • Posts: 15
  • Registered: ‎03-22-2009
  • Location: Cambridge, England
  • Views: 2210
  • Message 2 of 4

Re: Lenovo X200 refuses to go to sleep

2009-05-06, 21:33 PM
In Device Manager, open the properties of your wired ethernet adapter. Click tab "Advanced".  In the "Property" box, scroll down to find "Wake on Settings" and select it.  In the "Value" drop-down, select "Wake on Magic Packet".  Click OK.
Message Edited by rdhw on 05-06-2009 10:34 PM

0 person found this solution to be helpful.

This helped me too

Reply
Options

4 Posts

09-21-2008

Hong Kong S.A.R of China

8 Signins

113 Page Views

  • Posts: 4
  • Registered: ‎09-21-2008
  • Location: Hong Kong S.A.R of China
  • Views: 113
  • Message 3 of 4

Re: Lenovo X200 refuses to go to sleep

2009-05-11, 14:02 PM

I am also experiencing the same thing. Win7 RC 7100 64bit.

 

This also happened when I updated the bios to 2.06.

 

I tried rdhw solution but that didn't work, even after a restart. 

 

Does anybody have a solution?

 

 

UPDATE: Finally found the culprit. It was my smart card reader having the checkbox - allow this device to wake the computer ticked.

In Device Manager, go to network card or any device, go to properties and select the power management tab. Uncheck "Allow this device to wake the computer" 

 

 

 

Message Edited by ninjatool on 05-11-2009 09:58 AM
Message Edited by ninjatool on 05-18-2009 12:50 PM
Reply
Options

3 Posts

05-06-2009

Arlington, Massachusetts, USA

6 Signins

32 Page Views

  • Posts: 3
  • Registered: ‎05-06-2009
  • Location: Arlington, Massachusetts, USA
  • Views: 32
  • Message 4 of 4

Re: Lenovo X200 refuses to go to sleep

2009-05-11, 14:20 PM

Sorry for being a bit slow in responding. Adapting the settings for my wired ethernet adapter as rdhw suggested solved the problem. (But since I am not using any wake-on features, I simply opted to turn them off instead.)

 

Interestingly, I had previously looked at these settings in the BIOS and turned them off there (forgot to mention this), but it appears the Device Manager settings were overriding the BIOS settings.

 

So, I still find Access Connections to be slow (it will take maybe half a minute or so to figure out what is happening when I switch between wireless and wired connections), and also getting the X200 to go to sleep takes more time than it used to do (it used to go to sleep momentarily when I, say, closed the lid, whereas now it will need to think for 10-15 seconds first), but at least everything works reasonably well now.

 

Which is nice, and I don't want to break anything that I don't have the time to fix, so I think I will leave it at this for the time being. Thanks so much for the help (and for the prompt reply)!

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms