Showing results for 
Search instead for 
Did you mean: 
Blue Screen Again
Posts: 4
Registered: ‎12-31-2015
Location: HR
Views: 786
Message 1 of 2

Lenovo x1 Carbon 1st gen no power

x1 wont start. Only green LED next to charging port. Any help???


1. Tried another power adapter

2. Reset from bottom side

3. Disconnect everything, only dc jack, lcd and keyboard connected but no luck

Paper Tape
Posts: 2
Registered: ‎06-28-2017
Location: US
Views: 694
Message 2 of 2

Re: Lenovo x1 Carbon 1st gen no power

I have the same issue with my first gen X1 Carbon, tried the following with no success


1) reset button, did nothing

2) Held power button for 30 seconds, did nothing (worth noting that when I hit the power button - led around it does come on)

3) removed battery and cmos battery and tried to power from AC adapter - did nothing


Looking for any other tricks or tips to try. I belive there is an issue where if not shut down properly and battery drains the thing just bricks. Appreciate any help.

Check out current deals!

Shop current deals

Top Kudoed Authors