cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
hongooi
Fanfold Paper
Posts: 7
Registered: ‎06-26-2019
Location: AU
Views: 628
Message 1 of 7

Low fps with X1 Extreme and 4K external monitor

Wondering if anyone has come across this problem before.

 

I have a brand-new X1 Extreme (bought in March) and a 4-year-old Dell 27" 4K monitor. In the last few days, I've had really low fps when using the monitor, while the built-in display works fine. This is all at the Windows desktop, ie not games or anything that should be super-demanding.

 

Some more details:

  1. Laptop is running Windows 10 Pro 1903, fully updated, and there are no problems in Device Manager
  2. The resolution is 4K, 60Hz refresh rate, connected to a Thunderbolt port via a DisplayPort-USBC cable
  3. I had the same problem when I tried connecting with HDMI (which only gets me a nominal 30Hz refresh rate because the monitor only supports an older HDMI spec, but the actual fps I get is way less than that — maybe 10-15fps)
  4. Switching between TBolt ports doesn't help
  5. Switching to a different monitor also doesn't help, suggesting the problem is with Windows and/or the laptop
  6. Interestingly, if I duplicate the display on both laptop and monitor, then the problem goes away. It comes back when I set Windows to display on only the monitor.

The monitor was mostly working fine before this. I say mostly, because it's had problems for years relating to waking up from sleep; I'll often have to unplug it from the wall and plug it back in again for Windows to see it. But once it was running, it was okay.

 

zxmar05
Punch Card
Posts: 44
Registered: ‎05-30-2011
Location: DE
Views: 617
Message 2 of 7

Re: Low fps with X1 Extreme and 4K external monitor

Can you test with a different monitor? A different cable? USB-C cables are a mess: there are Thunderbolt cables, USB 3.1 cables, even USB 2.0 cables...

hongooi
Fanfold Paper
Posts: 7
Registered: ‎06-26-2019
Location: AU
Views: 613
Message 3 of 7

Re: Low fps with X1 Extreme and 4K external monitor

Yeah, I've tried with a different cable, with a different port (HDMI) and also with a different monitor.
hongooi
Fanfold Paper
Posts: 7
Registered: ‎06-26-2019
Location: AU
Views: 599
Message 4 of 7

Re: Low fps with X1 Extreme and 4K external monitor

If I go into Settings -> System -> Display and change the layout to either "extend displays" or "duplicate displays" then the performance is fine. It's only if I set it to use only the monitor that it goes wack.

 

Edit: Also tried setting the monitor resolution to 1080p (**bleep**, it's ugly) to check that it wasn't a connection bandwidth issue. The problem persists.

aaxenger
What's DOS?
Posts: 2
Registered: ‎06-26-2019
Location: GB
Views: 549
Message 5 of 7

Re: Low fps with X1 Extreme and 4K external monitor

Did you update the BIOS around the time this started?

hongooi
Fanfold Paper
Posts: 7
Registered: ‎06-26-2019
Location: AU
Views: 532
Message 6 of 7

Re: Low fps with X1 Extreme and 4K external monitor

Not that I recall. I don't think I've done a manual BIOS update in the last 10 years, and there's nothing in the Lenovo Vantage or Windows Update history.

hongooi
Fanfold Paper
Posts: 7
Registered: ‎06-26-2019
Location: AU
Views: 519
Message 7 of 7

Re: Low fps with X1 Extreme and 4K external monitor

And speaking of the devil, a BIOS update showed up in Vantage today. Installing it seems to have fixed the problem.

Check out current deals!


Shop current deals

Top Kudoed Authors