Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
What's DOS?
Posts: 1
Registered: ‎09-03-2008
Location: Harrisburg, PA
0 Kudos

Missing Secure "R" Drive and Cannot Delete Programs

Hey guys,
How are you? I am having some trouble with my Lenovo X60 thinkpad, it seems to be behaving oddly, I was wondering if anyone could assist me? First last week I noticed that the built in "secure drive" that IBM puts as a partition on the HD is missing. I cannot find it any where. When I tried to restore to a previous point NONE of the restore points will work? Finnally, I just noticed that when I tried to remove some programs through "Add/Remove" programs when I click on the item the "remove" button isn't there?? All of this seems very odd, could they be related?? Thank you for your help! Take care!