cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
GLaDOSPulse
SCSI Port
Posts: 144
Registered: ‎01-19-2013
Location: United Kingdom
Views: 1,386
Message 1 of 8

My X230's screen suddenly went fuzzy

Hello,

 

I am very very disappointed with the life of my X230, my screen went fuzzy when I was just setting it up for college. I plugged in my external writer, and as it was installing Microsoft Student it went pink and white. 

 

I don't know what to do, I searched up everywhere for a solution but this concerns my trust for Lenovo's reliability. I'm either sending it back or demanding a refund to replace the X230 with something else. 

 

Can anyone at least help me here? It's kind of urgent as it's the only machine I now use for college and I have no other option.

______________________________________________________
Owner of: ThinkPad SL510, X131e, X230 (not fond of)
Other systems: MSI GT640, Sony Vaio PCG 709K, Dell Latitude D430,
sunil23
Punch Card
Posts: 36
Registered: ‎01-28-2013
Location: Perth
Views: 1,341
Message 2 of 8

Re: My X230's screen suddenly went fuzzy

Call them up and explain the problem to them. If the laptop is still covered by warranty they should be able to repair it free of charge. You can also demand a refund or a replacement computer, which i did. Previosuly, i owned an edge e530 which was causing me continual problems. They replaced the laptop with a x230 free of charge, though this was after a lot of back and forth emails. However, i have nothing negatvie to say about that experience. In summary, you do have two options available to you, repair or replacement Smiley Happy

lead_org Microsoft MVP Contributor
Microsoft MVP Contributor
Posts: 21,009
Registered: ‎12-19-2008
Location: Australia, Melbourne
Views: 1,330
Message 3 of 8

Re: My X230's screen suddenly went fuzzy

http://www.flickr.com/photos/lead_org/9976710774/

like the picture aboce?
Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
GLaDOSPulse
SCSI Port
Posts: 144
Registered: ‎01-19-2013
Location: United Kingdom
Views: 1,295
Message 4 of 8

Re: My X230's screen suddenly went fuzzy

I have a picture to show the issue.

 

Pic

 

 

______________________________________________________
Owner of: ThinkPad SL510, X131e, X230 (not fond of)
Other systems: MSI GT640, Sony Vaio PCG 709K, Dell Latitude D430,
lead_org Microsoft MVP Contributor
Microsoft MVP Contributor
Posts: 21,009
Registered: ‎12-19-2008
Location: Australia, Melbourne
Views: 1,282
Message 5 of 8

Re: My X230's screen suddenly went fuzzy

This looks like a LCD issue, got warranty?
Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
GLaDOSPulse
SCSI Port
Posts: 144
Registered: ‎01-19-2013
Location: United Kingdom
Views: 1,225
Message 6 of 8

Re: My X230's screen suddenly went fuzzy

I've received the X230 back, working as it should.

Was the display faulty?

 

 

If this happens again after 90 days I may as well get a refund, I can't open the machine up and see what the issue was and I kinda think it would've been a badly designed LCD casing.

______________________________________________________
Owner of: ThinkPad SL510, X131e, X230 (not fond of)
Other systems: MSI GT640, Sony Vaio PCG 709K, Dell Latitude D430,
Highlighted
x220note
Paper Tape
Posts: 1
Registered: ‎11-27-2012
Location: United States
Views: 1,143
Message 7 of 8

Re: My X230's screen suddenly went fuzzy

 

@lead_org wrote:
http://www.flickr.com/photos/lead_org/9976710774/

like the picture aboce?

At times, my x230 screen looks like the photograph you attached. Only, mine affects the entire screen. Is there a solution for this issue? Thanks for your input. 

GLaDOSPulse
SCSI Port
Posts: 144
Registered: ‎01-19-2013
Location: United Kingdom
Views: 998
Message 8 of 8

Re: My X230's screen suddenly went fuzzy


@x220note wrote:

 

@lead_org wrote:
http://www.flickr.com/photos/lead_org/9976710774/

like the picture aboce?

At times, my x230 screen looks like the photograph you attached. Only, mine affects the entire screen. Is there a solution for this issue? Thanks for your input. 


Call Lenovo and request a new case, it wouldn't be a faulty ribbon cable if it looks like that. More like some failure somewhere in the motherboard. Try connecting it up to an external monitor and see if it happens there too.

______________________________________________________
Owner of: ThinkPad SL510, X131e, X230 (not fond of)
Other systems: MSI GT640, Sony Vaio PCG 709K, Dell Latitude D430,

Check out current deals!


Shop current deals

Top Kudoed Authors