English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

5 Posts

06-12-2017

US

28 Signins

145 Page Views

  • Posts: 5
  • Registered: ‎06-12-2017
  • Location: US
  • Views: 145
  • Message 1 of 2

New X1 Carbon, touchpad and trackpoint not working at all

2017-06-23, 2:08 AM

So, during the windows installer, no mouse. I couldn't see the pointer, neither the touchpad or trackpoint worked. I managed through using the keyboard, then once I got to the desktop I installed the "Synaptics ThinkPad UltraNav Driver for Windows 10 (64-bit) - ThinkPad" driver and rebooted. Still not working. I installed the thinkvantage system update, it detects no updates. I installed the service bridge. No updates.

 

I then made a linux live USB that I use to install manjaro on all my laptops, yes everything worked out of the box on my previous x1 carbon. Touchpad doesn't work, xorg doesn't even recognize any touchpad present.

 

Anyone else have this? Any solutions?

 

This is actually my 2nd X1 carbon; the first works well but the mouse buttons are loose so Lenovo promised waived restocking and shipping with the purchase of a new order of equal or greater value; I ordered another one with plans to return the first one, because I really needed to keep it for work while I waited for the new one.

 

The new one is actually flawless in terms of build, mouse buttons are solid, the CMOS battery is not loose and producing a rattling noise as it is in the first one, and the bottom cover doesn't have the clicking noise that so many are afflicted with. Really I'm willing to try anything to fix the touchpad.

Reply
Options

1985 Posts

02-28-2012

EC

1789 Signins

32153 Page Views

  • Posts: 1985
  • Registered: ‎02-28-2012
  • Location: EC
  • Views: 32153
  • Message 2 of 2

Re: New X1 Carbon, touchpad and trackpoint not working at all

2017-06-30, 17:59 PM

Hi.

 

Just in case here it is a pointer to the Support site of the X1 Carbon.

https://support.lenovo.com/us/en/solutions/x1-carbon-help

 

I guess you have the 5th Gen, can you validate that?

 

What about the driver listed on the support site of the 5th Gen ? It seems to have some Synaptics driver and even some firmware update for it. Have you tried installing those ?

 

If you don't have the 5th Gen please specify the model to find the correct support site.

 

Regards












Martín Itúrbide
OS2World.com NewsMaster
Self-proclaimed Trackpoint Fan Club President
"Don't Panic" 
Wil Wheaton
Remember: Your Friend Wil Declares....
Please click "Kudos" for Ego Boost !!


 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save