English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

3 Posts

04-12-2018

US

9 Signins

91 Page Views

  • Posts: 3
  • Registered: ‎04-12-2018
  • Location: US
  • Views: 91
  • Message 1 of 4

New x1c going to sleep on lock screen after just a few seconds when plugged in

2018-04-25, 17:47 PM

We're bringing some X1c 6th generation latops online for our business. I'm not sure this is limited to this model, but I've most recently seen it on this system.

 

What happens:

 

When plugged in, and the system is locked through Windows-l, it goes to sleep after just a few second (maybe 15)

 

What we have and what I've done:

 

Windows 10 1709 pro fully updated through windows and system update

System unattended sleep is set to 0 for battery and plugged in

Screen saver timeout is set to 10 minutes

System sleep when plugged in  is off

 

The only way I've been able to work around this is to also set the screen never to go to sleep when plugged in. Any other time amount, and when locked it goes to sleep after a few seconds.

 

Any ideas?

 

Thanks!

Reply
Options

8 Posts

04-06-2018

CA

13 Signins

267 Page Views

  • Posts: 8
  • Registered: ‎04-06-2018
  • Location: CA
  • Views: 267
  • Message 2 of 4

Re: New x1c going to sleep on lock screen after just a few seconds when plugged in

2018-09-20, 12:42 PM

Same problem !!!

Reply
Options

2 Posts

02-06-2019

DK

5 Signins

51 Page Views

  • Posts: 2
  • Registered: ‎02-06-2019
  • Location: DK
  • Views: 51
  • Message 3 of 4

Re: New x1c going to sleep on lock screen after just a few seconds when plugged in

2019-08-15, 8:54 AM

I have the same problem. Has anyone found a solution?

Reply
Options

2 Posts

02-06-2019

DK

5 Signins

51 Page Views

  • Posts: 2
  • Registered: ‎02-06-2019
  • Location: DK
  • Views: 51
  • Message 4 of 4

Re: New x1c going to sleep on lock screen after just a few seconds when plugged in

2019-08-15, 12:55 PM

Ok, the solution has been found. 

 

1) Open Regedit

2) Set HKey_Local_Machine\System\CurrentControlSet\Control\Power\CsEnabled = 0

3) Set HKEY_Local_Machine\System\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\8EC4B3A5-6868-48c2-BE75-4F3044BE88A7\Attributes = 2

4) Reboot

5) Go into Power Options -> Advanced Settings -> Display -> Console lock display off timeout. Change this to more minutes. I set it to 30 minutes.

 

Done. Enjoy. This did the trick on my Thinkpad X1 Carbon but is not vendor specific, so it will work on many brands and models.

 

References:

https://www.reddit.com/r/Surface/comments/686dja/how_to_enable_high_performance_power_option_on/

https://superuser.com/questions/1166090/windows-10-lock-screen-always-puts-monitor-to-sleep-after-60-seconds

https://www.ghacks.net/2018/06/02/configure-the-lockscreen-display-timeout-on-windows/

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save