English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

2 Posts

04-19-2008

Amsterdam

11 Signins

86 Page Views

  • Posts: 2
  • Registered: ‎04-19-2008
  • Location: Amsterdam
  • Views: 86
  • Message 1 of 4

Problems installing audio drivers

2008-04-19, 10:11 AM

Hi,

I have a x61 notebook, and after reinstalling Win XP (pro, SP3) I can't get the audio to work. I have tried to install the drivers from Lenovos web site (7ka113ww.exe) but get an error message saying: "The HDA Audio bus driver is required and not found".

In device manager I have two uninstalled devices, one PCI Device and on Unknown device. Where can I download the HDA Audio bus driver?

Some threads (e.g.http://forum.notebookreview.com/showthread.php?t=195883) says that I shall install Universal Audio Architecture (UAA) High Definition Audio class driver (Q888111) for Windows XP, but I only find this for SP 1 or 2, not for SP3 as I have. If I try to install the one for SP2, I get another error message saying "the service pack version is newer then the update you are applying". Anyone know where I can find the correct drivers?

Edit: I sent an email to Microsoft to obtain the 888111 hotfix, but got a response back saying that this hotfix is included in Windows XP SP3, so I should already have it on my machine.

 

Thanks, TJ



Message Edited by TJ on 04-21-2008 04:58 AM
Reply
Options

14 Posts

04-21-2008

Sioux Center, IA

13 Signins

338 Page Views

  • Posts: 14
  • Registered: ‎04-21-2008
  • Location: Sioux Center, IA
  • Views: 338
  • Message 2 of 4

Re: Problems installing audio drivers

2008-04-21, 16:01 PM
You'd likely have to install the UAA driver before you but on SP3.

If it's already included in SP3 then find the .inf file, or whatever file, name and point the unknown device in the device manager to that.

But yes... it seems as if there are problems with high-definition audio and SP3; maybe try this:

http://boredsysadm.blogspot.com/2008/03/windows-xp-sp3-and-microsoft-hd-audio.html
 
Moderator Note; converted to clickable link


Message Edited by andyP on 04-21-2008 07:32 PM
Reply
Options

2 Posts

04-19-2008

Amsterdam

11 Signins

86 Page Views

  • Posts: 2
  • Registered: ‎04-19-2008
  • Location: Amsterdam
  • Views: 86
  • Message 3 of 4

Re: Problems installing audio drivers

2008-04-22, 18:00 PM
Thanks a lot Amiracle! The url you posted had the perfect solution, after editing registry I was able to install the hotfix and install the drivers, and my sound card is now working perfectly!

Great stuff! :)

TJ
Reply
Options

32 Posts

04-22-2008

US and A

77 Signins

1051 Page Views

  • Posts: 32
  • Registered: ‎04-22-2008
  • Location: US and A
  • Views: 1051
  • Message 4 of 4

Re: Problems installing audio drivers

2008-04-22, 19:12 PM
I'm glad my article was helpfull to you :)
Bored SysAdmin Blog
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save