English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

3 Posts

01-23-2015

London Ontario

7 Signins

52 Page Views

  • Posts: 3
  • Registered: ‎01-23-2015
  • Location: London Ontario
  • Views: 52
  • Message 1 of 6

Samsung 840 evo with x220 gives me the common 2100 error

2015-01-23, 18:53 PM

Hello Lenovo Forums. As I am glad to see this forum, I wish I was doing something else with my time then writing about my problems with the Thinkpad X220 and my Samsung 840 Evo 256gb SSD drive.

 

Let me give you a rundown of my past 4 months...

 

October 2014.

  • Purchased Thinkpad X120E. 1.5ghz processor and low memory made it horrible. Thankfully i bought it cheap.
  • Put in 8gb and bought the Samsung 840 Evo 256gb SSD drive to help it. It made the laptop much more responsive but it still sucked...so I sold it. I kept the SSD drive for my 'future' thinkpad.
  • I did the firmware update on the SSD as it required it. It currently has the most recent firmware
  • When I bought the SSD drive, I plopped it in, installed windows then openSUSE and enjoyed it for a bit. Never gave me an issue at all.

January 2015

  • Purchased an off-lease X220 with the 2.6ghz processor. Has a 320gig 7200rpm drive in it. Put in 16GB of memory and love it.
  • After playing with it for a bit, I did the most recent BIOS upgrade (1.39) and prepared it for the SSD install.
  • I put in the Samsung 840 evo. Turning on the laptop it sits at thinkpad logo a lot longer then usual. After a bit it goes to the Error 2100.
  • I went into the BIOS, HDD is not detected at all.
  • I kept trying to boot/restart but no go. I always see that Error 2100. I can tell when it won't boot because the thinkpad logo sits for a long time and it seems that the HDD light is always on.
  • I tried to boot with and without UEFI...no go.
  • I tried to boot with SATA as AHCI or compatibility, no go
  • I put the Samsung drive into a dock and attached it to a laptop. Disk management see's the drive. I can format it and all.
  • I put the SSD drive then into a friend’s computer tower. I formatted the drive using the Samsung software. 
  • I tried to put it back into my laptop last night, no go. Drive is not being read.
  • My friends desktop detects the drive in his BIOS just fine...

 

So I'm lost.

 

I believe this is an issue between the BIOS and the SSD/firmware.

I looked at some of the updates for SSD's and the thinkpad BIOS, they identify a small part of the model number of the samsung drive but it is not the same.

 

I have no idea what to do. I bought this nice drive and can't use it in my small beast of a thinkpad.

 

 

I've searched these forums and I'm pretty pissed off that such an issue exists. Error 2100 seem's common and especially with SSD drives in the thinkpads.

 

Any suggestions before I sell this drive, lose money on it and buy something that this laptop will read?

 

 

-rant

Solved! See the solution
Reply
Options

3812 Posts

12-02-2007

US

9028 Signins

188478 Page Views

  • Posts: 3812
  • Registered: ‎12-02-2007
  • Location: US
  • Views: 188478
  • Message 2 of 6

Re: Samsung 840 evo with x220 gives me the common 2100 error

2015-01-26, 9:08 AM

Hello,

 

I have not had any issues using a 500GB Samsung 840 (original model, not EVO or PRO) SSD or a 256GB Samsung 840 PRO SSD in my X220.  Perhaps there's an issue with the SSD not lining up exactly inside the X220's internal drive bay?  Are you using the drive caddy and rubber rails from the original HDD to install the SSD into the X220? 

 

Regards,

 

Aryeh Goretsky

 



I am a volunteer and neither a Lenovo nor a Microsoft employee.

L380 YogaP72 (20MB-*)P50 (20EN-*)S230u (3347-4HU)T23 (2648-LU7)T42 (2378-R4U)T43p (2678-H7U)T61p (6459-CTO)W510 (4318-CTO)W530 (2441-4R3)W530 (2441-4R3)X100e (3508-CTO)X120e (0596-CTO)X220 (4286-CTO)X250 (20CM-*)Yoga 370

  Communities:   English    Deutsche    Español    Português    Русскоязычное    Česká    Slovenská    Українська   Język Polski    Moto English


Need an answer, fast? Try using Browser Search to find it in the Lenovo and Moto Community
Reply
Options

4345 Posts

07-24-2013

CH

12999 Signins

377298 Page Views

  • Posts: 4345
  • Registered: ‎07-24-2013
  • Location: CH
  • Views: 377298
  • Message 3 of 6

Re: Samsung 840 evo with x220 gives me the common 2100 error

2015-01-26, 9:42 AM

wrote:

Error 2100 seem's common and especially with SSD drives in the thinkpads.


I don't agree with that, I've lost count which of all my Thinkpads had SSDs, must be around 30 or so. Never had an issue, even with 2nd hand battered models.

 

As posted by goretsky above, make sure the SSD is properly attached to the caddy and rails and that the drive is well connected to the motherboard connector.


Using Search to find your answers in Lenovo and Moto Community
Reply
Options

3 Posts

01-23-2015

London Ontario

7 Signins

52 Page Views

  • Posts: 3
  • Registered: ‎01-23-2015
  • Location: London Ontario
  • Views: 52
  • Message 4 of 6

Re: Samsung 840 evo with x220 gives me the common 2100 error

2015-01-26, 23:41 PM

wrote:

Hello,

 

I have not had any issues using a 500GB Samsung 840 (original model, not EVO or PRO) SSD or a 256GB Samsung 840 PRO SSD in my X220.  Perhaps there's an issue with the SSD not lining up exactly inside the X220's internal drive bay?  Are you using the drive caddy and rubber rails from the original HDD to install the SSD into the X220? 

 

Regards,

 

Aryeh Goretsky

 


Thank you for the reply.

 

No there is no issue with it lining up. I'm far from novice and only got this x220 because I use it for my review work for my CCNP certifictation.

I went out last night and bought:

 

Crucial MX100. Compared both the samsung and crucial. Installed the Crucial drive and it works perfectly. Installed xubuntu back on and I was back in business.

The issue is compatability, between that specific drive and the thinkpad bios. I've already reviewed what Lenovo has for their support and there are no other firmware upgrades to complete on both the drive or the laptop unfortunately.

 

Yes it's being installed properly with the caddy and such.

 

 

To give Samsung one last chance, I also with some hesitation purchased the Samsung Pro 850 drive.  The Bios detects both the 850 Pro and the Crucial drive without issues. 

 

So now I have 3 SSD's in my possession. All 3 are identified in windows one way or another but the Evo 840 refuses to boot up without the 2100 error.

 

wrote:

wrote:

Error 2100 seem's common and especially with SSD drives in the thinkpads.


I don't agree with that, I've lost count which of all my Thinkpads had SSDs, must be around 30 or so. Never had an issue, even with 2nd hand battered models.

 

As posted by goretsky above, make sure the SSD is properly attached to the caddy and rails and that the drive is well connected to the motherboard connector.s 


 

I am not concerned with how many drives you've had. This is not a hardware installation issue as my old x120e ran the HDD just perfectly fine.

This can be closed.

This was unsolved and I've moved over to the Samsung 850 Pro drive which the FW and the Bios work fine together.

The Evo 840 is now for sale as I have no use for 3 SSD's

0 person found this solution to be helpful.

This helped me too

Reply
Options

1 Posts

05-29-2015

England

1 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎05-29-2015
  • Location: England
  • Views: 5
  • Message 5 of 6

Re: Samsung 840 evo with x220 gives me the common 2100 error

2015-05-29, 20:39 PM

FWIW, I get exactly the same error on a X220 with a Samsung 850EVO. I can boot to a Windows 7 install disk & it sees the drive but after the first restart it just sits there with error 2100. I've confirmed that the SSD works in another machine & the X220 works with a spinning disk & a 250GB BX100 so there's definitely something going wrong between the X220 & EVO drives.

I'm not after any help - I have the machine up and running with the BX100, but I just wanted to post to let people know that this is still happening with newer EVO drives as this is the first result on Google for X220 Samsung EVO.

Reply
Options

12832 Posts

06-06-2011

RU

17795 Signins

177085 Page Views

  • Posts: 12832
  • Registered: ‎06-06-2011
  • Location: RU
  • Views: 177085
  • Message 6 of 6

Re: Samsung 840 evo with x220 gives me the common 2100 error

2015-05-30, 9:46 AM
MehItsMe,

is the Intel Rapid Storage Technology Driver (IRST) installed on the x220 with Samsung EVO drive? As well as the Intel chipset driver?

Did you check the drive fw update on the Lenovo site (the link is below) or on the Samsund site?
http://support.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-x-series-laptops/thinkpad-x220/downloads/DS013805



x220 • Gobi 2000 3g | hdd, msata ssd, wwan, wifi, gps -- unique hand-made config
ThinkPad 25 Special Anniversary Edition. #Retro. Signed by D.Hill
T470p | X1 Carbon Gen3 | Miix 2 10" | Yoga Tablet 2-1050F (Android) + BT Keyboard
ThinkPad Stack • 2.4/5 Wireless Router, HDD 1 TB, BT Speaker, Power Bank, Mobile Projector

Do it well, worse becomes itself

Communities:   English    Deutsche    Español    Portugues    Русскоязычное    Česká    Slovenská    Українська   Moto English

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete