cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
bsullivan1983
Punch Card
Posts: 28
Registered: ‎09-16-2016
Location: US
Views: 625
Message 1 of 3

Slow D/L Speeds on 5Ghz Network

Hey everyone. Computer is an X1 Carbon Gen4 with Win10 Pro. No recent modem/router changes. No software changes. No updates available through TVSU (at least that's what it says.. I use to have updates available every couple of days and it's said there were no packages available for my system for almost a month now)/Lenovo website. Windows updates current. All drivers should be current. For some reason, only on this laptop, I'm getting around 50Mbps down instead of my normal 230Mbps down. Just started within the past couple days. It's not location related, I've eliminated that possibility. I powercycled the modem and router. I did a factory reset on the router. I tried using Google's DNS (I had to do that on my MBP to get the correct speeds out of it on the 5Ghz network) and it didn't change. My upload speeds are normal at 20-23Mbps. Any idea? My iPhone and MacbookPro are getting correct speeds.

bsullivan1983
Punch Card
Posts: 28
Registered: ‎09-16-2016
Location: US
Views: 623
Message 2 of 3

Re: Slow D/L Speeds on 5Ghz Network

Forgot to mention I tried resetting the TCP/IP stack and flushing the DNS and those didn't work either.

bsullivan1983
Punch Card
Posts: 28
Registered: ‎09-16-2016
Location: US
Views: 611
Message 3 of 3

Re: Slow D/L Speeds on 5Ghz Network

Fixed it. Uninstalled Intel ProSet Wireless Software. Hopefully this is helpful to someone else!

Check out current deals!


Shop current deals

Top Kudoed Authors