cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
vincococka
What's DOS?
Posts: 1
Registered: ‎02-20-2013
Location: Slovakia
Views: 8,792
Message 1 of 3

[Solution] x230 realtek audio - no sound

Hi all,

 

I`ve read here that lot of people got audio problems with their ThinkPads.

What helps me in Windows 7 (without reboot) is that you have to set audio output to 44100Hz and 16bit sampling rate.

 

Steps:

 1, Right click on speaker icon located on taskbar near clock

 2, select "Playback  devices"

 3, double click on Speakers

 4, select Advanced

 5, change Default format to "16bit, 44100

 

speakers.jpg

 

 

This trick always helped in my case.

 

 

Regards,

  Jan

jamesfadams
Blue Screen Again
Posts: 18
Registered: ‎01-18-2015
Location: USA
Views: 7,192
Message 2 of 3

Re: [Solution] x230 realtek audio - no sound

My Realtek High Definition Audio worked great for several years and then started failing after I updated the BIOS on my X230 to "LENOVO G2ETA5WW (2.65), 9/17/2015 on my computer running Microsoft Windows 7 Professional version 6.1.7601 Service Pack 1 Buiold 7601.  The Realtek driver is version 6.0.1.7040 dated 9/13/2013.

 

Now every time I boot I must disable, then enable the Realtek HD Sound in Device Manager before any music or video file will play longer than a few seconds.

 

I tried Jan's suggestion and unfortunately it did not work for me.

 

After changing the speakers from “24 bit, 48000 Hz (Studio Quality)” to “16 bit, 44100 Hz (CD Quality)” and selecting “Test”, I get a warning screen saying “Device in Use – The device is being used by another application. If you continue, that application may stop working.  Do you want to continue?” If I select “Yes” then I get an error message saying “Error! Failed to play test tone.”

Instead, if I simply select “OK” after the switch to “16 bit, 44100 Hz (CD Quality)”, I get an error message saying “Error! Formant not supported by the device.”

 

Anyone have any ideas?

 

(I will try also posting this in a new post to get a little more exposure.)

pdaves
Paper Tape
Posts: 2
Registered: ‎03-29-2016
Location: US
Views: 4,353
Message 3 of 3

Re: [Solution] x230 realtek audio - no sound

Mine started acting up last month (March, 2017). I deleted the drivers, downloaded new ones and reinstalled them, and it still didn't work. Eventually I had to disable the RealTek HD Audio driver and delete the files so it wouldn't reinstall. Then in Device Manager I identified new devices and had it automatically install the default HD audio driver and NOT the RealTek one. That one works fine. I haven't found any information about how to fix the RealTek HD audio driver since then.

Check out current deals!


Shop current deals

Top Kudoed Authors