Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
What's DOS?
Posts: 1
Registered: ‎12-03-2011
Location: Caracas
0 Kudos

Sulphured" battery on X220

I bought my laptop only one month ago and kept launching battery not charing messages.


Today I opened it and to my surprise, all battery contacts were covered with green dust, like what you find in your car battery (which has sulphuric acid inside).


Has anyone experienced something similar? This is the first time I hear of this, and I've had many notebooks..



Posts: 20,913
Topics: 128
Kudos: 1,261
Solutions: 1,344
Registered: ‎12-19-2008
Location: Australia, Melbourne
0 Kudos

Re: Sulphured" battery on X220

no i haven't experienced anything like this before. Try to clean the contact and see whether the problem persists, if it does then contact warranty.

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
Posts: 9,020
Registered: ‎12-26-2009
Location: Toronto, Canada
0 Kudos

Re: Sulphured" battery on X220

Never heard of this before. I'd be careful cleaning the contacts though. Don't want to accidentally short some pins.
W520: 2720QM, Q2000M at 1091/1376, 21GB RAM, 500GB + 750GB HDD, FHD screen & MB168B+
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Y3P: 5Y70, 8GB RAM, 256GB SSD, QHD+ screen
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen