cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
luigig
Punch Card
Posts: 90
Registered: ‎05-23-2011
Location: USA
Views: 29,836
Message 1 of 17

The driver WUDFRd failed to load...

I just did a clean install of my X220 with Windows 7 Pro 64-bit using the latest X220 Lenovo drivers.

I have a X220 with the fingerprint reader. Any time the laptop boots up I see this event in the event log:

  • The driver \Driver\WUDFRd failed to load for the device USB\VID_147E.

The device USB\VID_147E corresponds to the fingerprint reader (I checked this in the device manager).

Can someone help with this?

 

Thanks!

 

 

 

denial
Punch Card
Posts: 50
Registered: ‎07-07-2011
Location: ZW
Views: 29,764
Message 2 of 17

Re: The driver WUDFRd failed to load...

i have similar "issue" with my W520:

 

Log Name:      System
Source:        Microsoft-Windows-DriverFrameworks-UserMode
Date:          29. 7. 2011 0:49:19
Event ID:      10114
Task Category: Startup of the UMDF reflector
Level:         Information
Keywords:      (2)
User:          SYSTEM
Computer:      ThinkPad
Description:
The UMDF reflector was unable to complete startup because the WUDFPf service was not found.  This service may be started later during boot, at which point Windows will attempt to start the device again.

 

 

 

 

Log Name:      System
Source:        Microsoft-Windows-Kernel-PnP
Date:          29. 7. 2011 0:49:19
Event ID:      219
Task Category: (212)
Level:         Warning
Keywords:     
User:          SYSTEM
Computer:      ThinkPad
Description:
The driver \Driver\WUDFRd failed to load for the device USB\VID_147E&PID_2016\6&2e78673a&0&3.

 

 

in my case it is related to external USB hard drive, which is displayed with exclamacation ! mark in device manager and not recognized. also rescan in device manage does not help and i need to disconnect it and reconnect to be able to work with it ... i have connected it to esata/usb combo port

 

 

D:\>sc query WUDFPf

SERVICE_NAME: WUDFPf
        TYPE               : 1  KERNEL_DRIVER
        STATE              : 4  RUNNING
                                (STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
        WIN32_EXIT_CODE    : 0  (0x0)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0

D:\>sc qc WUDFPf
[SC] QueryServiceConfig SUCCESS

SERVICE_NAME: WUDFPf
        TYPE               : 1  KERNEL_DRIVER
        START_TYPE         : 3   DEMAND_START
        ERROR_CONTROL      : 1   NORMAL
        BINARY_PATH_NAME   : system32\drivers\WudfPf.sys
        LOAD_ORDER_GROUP   : base
        TAG                : 0
        DISPLAY_NAME       : User Mode Driver Frameworks Platform Driver
        DEPENDENCIES       :
        SERVICE_START_NAME :

 

christopherlang
802.11n
Posts: 501
Registered: ‎03-10-2009
Location: Chicago, IL
Views: 28,910
Message 3 of 17

Re: The driver WUDFRd failed to load...

My 520 does this as well. The drive is using one of the usb 3.0 ports using a sata to usb 3.0 adapter. I have to unplug the drive and plug it in again when this occurs. I think it is a defective sata to usb adapter in my case.

ragonarf
Blue Screen Again
Posts: 49
Registered: ‎04-04-2013
Location: chicago
Views: 20,941
Message 4 of 17

Re: The driver WUDFRd failed to load...

this warning has been driving me nuts for over two years.  event id 219 task cat 212. t60 win 7 sp1 build 7601 fresh install on one t60 exisiting install on the other.  it occurs on every startup or restart. all drivers are updated.  i have tried windows driver foundation on auto and manual.  i have turned win 7 biometrics on/off. lenovo fp sw installed working lenovo fp sw not installed  and a 100 other things.  other than this warning these t60s are running beautiflly...action center system health no problems...device mgr no problems.. here are the details from event viewer

 

- System

  - Provider

   [ Name]  Microsoft-Windows-Kernel-PnP
   [ Guid]  {9C205A39-1250-487D-ABD7-E831C6290539}
 
   EventID 219
 
   Version 0
 
   Level 3
 
   Task 212
 
   Opcode 0
 
   Keywords 0x8000000000000000
 
  - TimeCreated

   [ SystemTime]  2014-07-11T19:11:43.462024500Z
 
   EventRecordID 19093
 
   Correlation
 
  - Execution

   [ ProcessID]  4
   [ ThreadID]  68
 
   Channel System
 
   Computer T60-200784U
 
  - Security

   [ UserID]  S-1-5-18
 

- EventData

  DriverNameLength 36
  DriverName USB\VID_0483&PID_2016\5&2fb3f7a1&0&2
  Status 3221226341
  FailureNameLength 14
  FailureName \Driver\WUDFRd
  Version 0

jwooden
SCSI Port
Posts: 168
Registered: ‎06-13-2008
Location: SE USA
Views: 20,456
Message 5 of 17

Re: The driver WUDFRd failed to load...

Anybody figure it out? I have new T440s with Win 8.1 and get five instances of "The driver \Driver\WUDFRd failed to load for the device ..." on every boot up ... apparently after using some new USB devices earlier in the day, but the error messages come up on every boot even with no USB devices plugged into the machine....
ragonarf
Blue Screen Again
Posts: 49
Registered: ‎04-04-2013
Location: chicago
Views: 20,444
Message 6 of 17

Re: The driver WUDFRd failed to load...

ya...if it is warning 219 task category 212 kernel pnp ( Description:The driver \Driver\WUDFRd failed to load for the device USB\VID_0483&PID_2016\5&2fb3f7a1&0&2) in event viewer win 7 i struggled with it for a couple years.  in my case it had to do with the finger print reader.  it turned out to be the fp sw version.  i tried everything (current lenovo fp sw etc.) until i came across an older version of the fp sw and it cleared the warning on two t60's win 7 immediately up immediately.  anyway i installed IN1FGP08WW1.exe and it fixed the warning for me.  BUT be careful, as i understand it, the sw was taken off the market because if someone gets into your registry they can decifer your windows password.  it was developed by upek which was bought by authentec. there can be other reasons for this type of error or warning such as a smart card.  good luck.

Highlighted
jwooden
SCSI Port
Posts: 168
Registered: ‎06-13-2008
Location: SE USA
Views: 20,433
Message 7 of 17

Re: The driver WUDFRd failed to load...

 

Thanks ragonarf

 

I'm getting the error 5 times/boot:

 

The driver \Driver\WUDFRd failed to load for the device ROOT\SYSTEM\0002

The driver \Driver\WUDFRd failed to load for the device ROOT\SYSTEM\0003

The driver \Driver\WUDFRd failed to load for the device ROOT\SYSTEM\0004

The driver \Driver\WUDFRd failed to load for the device ROOT\SYSTEM\0005

The driver \Driver\WUDFRd failed to load for the device USB\VID_138A&PID_0017\545112873982.

 

It seems that the error messages didn't start until roughly when I programmed the fingerprint reader with my fingers, but I'm not really sure ................

 

If that's the root cause ... it's a shame  Smiley Sad  I'll do a little digging ..........

 

 

 

 

ragonarf
Blue Screen Again
Posts: 49
Registered: ‎04-04-2013
Location: chicago
Views: 20,420
Message 8 of 17

Re: The driver WUDFRd failed to load...

just a suggestion.  i would use find in regedit to make sure the vid being referred is the fp reader.  also since i installed the sw i noticed i have a new service running (upek.exe).  i would be interested to know if you get it fixed.

jwooden
SCSI Port
Posts: 168
Registered: ‎06-13-2008
Location: SE USA
Views: 20,401
Message 9 of 17

Re: The driver WUDFRd failed to load...

Thanks it may take me a few days, but if I find a solution I will post it!
jwooden
SCSI Port
Posts: 168
Registered: ‎06-13-2008
Location: SE USA
Views: 20,327
Message 10 of 17

Re: The driver WUDFRd failed to load...

the last error from USB\VID_138A&PID_0017
is indeed the finger print reader.

The currently installed driver is: V4.5.263.0 From Synaptics and is dated 6/13/14 so very recent....

there is some talk about simiar issues here:
http://answers.microsoft.com/en-us/windows/forum/windows_8-performance/the-driver-driverwudfrd-faile...

I have no errors posted in device manager (yellow bang) or red triangle ...

I'll have to look some more when I have time ... :-/


Check out current deals!


Shop current deals

Top Kudoed Authors