English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

4 Posts

01-03-2015

US

7 Signins

43 Page Views

  • Posts: 4
  • Registered: ‎01-03-2015
  • Location: US
  • Views: 43
  • Message 1 of 5

ThinkPad X1 Carbon 6th Gen X1C6 Blue Screen and SSD Disappears

2019-07-07, 19:39 PM

ThinkPad X1 Carbon 6th Gen

Purchased March 2019 from Costco

BIOS N23ET63W 1.38

Windows 10 Home 64 Bit 1903 (problem occurred before 1903 update)

All drivers and firmware are up to date using Lenovo Vantage

See CrystalDiskInfo below for full SSD details.

I've added a Western Digital (SanDisk) 512GB in the open PCIe slot. I'm using this only to store photos, music, etc and no system data or applications.

 

While using my X1, I'll get random BSoD's. The error messages have varied, but all seem to relate to the kernel or OS not being able to read/write to the disk. This has happened at least a half dozen times now and averages probably once every two to five hours of use. It's gotten to the point where I can pretty much predict I'm about to get a BSoD a minute or two before it happens. Apps stop responding, web pages refuse to load, then ultimately even the mouse cursor stops responding. The BSoD appears and shows 0% gathering info. It never progresses.

 

Eventually, Windows reboots the laptop. However, Windows won't load. When I load the Lenovo BIOS diagnostics utility, it doesn't even show the main SSD! The WD drive does still show. Turning the laptop off then on fixes this issue every time and then Windows boots normally.

 

CHKDSK (including full offline scan), SMART, everything I can think of comes back normal. System runs flawless until it doesn't.

 

Anyone have any suggestions or experienced a similar issue before I deal with Lenovo? My next step is going to be removing the WD SSD and see if the problem persists.

 

Thanks!

 

 

----------------------------------------------------------------------------
CrystalDiskInfo 8.0.0 (C) 2008-2018 hiyohiyo
----------------------------------------------------------------------------
 
OS : Windows 10 [10.0 Build 18362] (x64)
Date : 2019/07/07 14:33:13
 
-- Controller Map ----------------------------------------------------------
- Microsoft Storage Spaces Controller [SCSI]
+ Standard NVM Express Controller [SCSI]
- LENSE30512GMSP34MEAT3TA
 
----------------------------------------------------------------------------
(1) LENSE30512GMSP34MEAT3TA
----------------------------------------------------------------------------
Model : LENSE30512GMSP34MEAT3TA
Firmware : 1.6.0412
Serial Number : FBFB180910K0011560
Disk Size : 512.1 GB
Buffer Size : Unknown
# of Sectors :
Rotation Rate : ---- (SSD)
Interface : NVM Express
Major Version : NVM Express 1.2
Minor Version :
Transfer Mode : PCIe 3.0 x4 | PCIe 3.0 x4
Power On Hours : 26 hours
Power On Count : 177 count
Host Reads : 2168 GB
Host Writes : 734 GB
Temperature : 35 C (95 F)
Health Status : Good (100 %)

 

 

Reply
Options

2 Posts

08-09-2019

IN

4 Signins

19 Page Views

  • Posts: 2
  • Registered: ‎08-09-2019
  • Location: IN
  • Views: 19
  • Message 2 of 5

Re: ThinkPad X1 Carbon 6th Gen X1C6 Blue Screen and SSD Disappears

2019-08-15, 2:58 AM
I have exactly the same issues with T480. All error codes refer to potential SSD issues. While all h/w tests are fine. After BSoD, its unable to create a dump file or reboot. I will have to power it off and then power again. I have the same Lenovo SSD.
Reply
Options

2 Posts

08-19-2019

US

6 Signins

98 Page Views

  • Posts: 2
  • Registered: ‎08-19-2019
  • Location: US
  • Views: 98
  • Message 3 of 5

Re: ThinkPad X1 Carbon 6th Gen X1C6 Blue Screen and SSD Disappears

2019-08-20, 0:06 AM

Exact same issue, exact same laptop (from costco), exact same SSD. My firmware version is also the latest at 1.6.0412, but I am running Linux, so this seems to be an OS-independent issue.

 

My symptoms are the same in that it seems to work perfectly for a few hours, and then hangs. Watching the kernel with dmesg -w spits out lots of "EXT4-fs (dm-2): I/O error while writing superblock" or similar errors (issues with missing inodes, buffer i/o errors, etc) and eventually the system remounts read-only. 

 

Similarly, I don't get any warnings or errors logged via SMART. I think this is an issue with the controller, and not with the actual storage, otherwise some errors would be there. My laptop is roughly 10 months old at this point, but I only started getting these issues within the past few weeks. 

 

Can any Lenovo reps chime in here? Did we get a bad batch of drives? 

 

=== START OF INFORMATION SECTION ===
Model Number: LENSE30512GMSP34MEAT3TA
Serial Number: FBFB180910K0006494
Firmware Version: 1.6.0412
PCI Vendor/Subsystem ID: 0x17aa
IEEE OUI Identifier: 0xa03299
Controller ID: 1
Number of Namespaces: 1
Namespace 1 Size/Capacity: 512,110,190,592 [512 GB]
Namespace 1 Utilization: 0
Namespace 1 Formatted LBA Size: 512
Namespace 1 IEEE EUI-64: a03299 5afe1a1000
Local Time is: Mon Aug 19 19:05:51 2019 CDT
Firmware Updates (0x02): 1 Slot
Optional Admin Commands (0x0017): Security Format Frmw_DL Self_Test
Optional NVM Commands (0x0016): Wr_Unc DS_Mngmt Sav/Sel_Feat
Maximum Data Transfer Size: 32 Pages
Warning Comp. Temp. Threshold: 70 Celsius
Critical Comp. Temp. Threshold: 80 Celsius

 

 

=== START OF SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

SMART/Health Information (NVMe Log 0x02)
Critical Warning: 0x00
Temperature: 54 Celsius
Available Spare: 100%
Available Spare Threshold: 3%
Percentage Used: 16%
Data Units Read: 2,944,435 [1.50 TB]
Data Units Written: 3,845,832 [1.96 TB]
Host Read Commands: 70,152,565
Host Write Commands: 93,545,866
Controller Busy Time: 1,010
Power Cycles: 1,083
Power On Hours: 632
Unsafe Shutdowns: 84
Media and Data Integrity Errors: 0
Error Information Log Entries: 0
Warning Comp. Temperature Time: 0
Critical Comp. Temperature Time: 0
Temperature Sensor 1: 71 Celsius
Temperature Sensor 2: 54 Celsius

Error Information (NVMe Log 0x01, max 4 entries)
No Errors Logged

Reply
Options

2 Posts

08-09-2019

IN

4 Signins

19 Page Views

  • Posts: 2
  • Registered: ‎08-09-2019
  • Location: IN
  • Views: 19
  • Message 4 of 5

Re: ThinkPad X1 Carbon 6th Gen X1C6 Blue Screen and SSD Disappears

2019-08-20, 0:17 AM

Yes, its the problems with the drive and looks like its well documented. Please see the link https://support.lenovo.com/in/en/solutions/ht508405

 

I got the drive replaced by a samsung one yesterday. Hope that will resolve the issue. 

Reply
Options

2 Posts

08-19-2019

US

6 Signins

98 Page Views

  • Posts: 2
  • Registered: ‎08-19-2019
  • Location: US
  • Views: 98
  • Message 5 of 5

Re: ThinkPad X1 Carbon 6th Gen X1C6 Blue Screen and SSD Disappears

2019-08-20, 0:22 AM

Right, I noticed that page, but updating it to the latest firmware has not fixed the issue. Hopefully lenovo support can replace the drive for me since it's under warranty---I just don't want to have to mail the entire laptop back for a user-servicable part. 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete