English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

4 Posts

11-26-2019

HR

5 Signins

88 Page Views

  • Posts: 4
  • Registered: ‎11-26-2019
  • Location: HR
  • Views: 88
  • Message 1 of 6

ThinkPad X1E terrible performance on iGPU

2019-11-26, 9:45 AM

While utilizing hybrid graphics, the system is relatively cool but the performance is abysmal on 4k. Windows 10 animations lag, scrolling in Chrome, Firefox, and Edge is horrible, VS Code is a slog, and YouTube videos stutter and tear.

 

Reducing the resolution to 1080p helps but not completely, not to mention how everything looks blurry.

 

Forcing discreete graphics through BIOS helps but the laptop surface get a bit too hot for comfort. Nothing scalding hot, but definitely way too warm for simply browsing the web and coding with VS Code. It also completely ruins battery life.

 

Running the latest Win 10 update, and the latest drivers for both Intel and nVidia GPUs, updated through Lenovo Vantage (because trying to install via vendor sites results in an error)

 

  • OS: Win 10 Pro 1909 18363.476
  • Intel GPU Driver Version: 26.20.100.6999
  • nVidia GPU Driver Version: 431.94
Solved! See the solution
Reply
Options

459 Posts

05-02-2019

US

322 Signins

7862 Page Views

  • Posts: 459
  • Registered: ‎05-02-2019
  • Location: US
  • Views: 7862
  • Message 2 of 6

Re: ThinkPad X1E terrible performance on iGPU

2019-11-26, 13:42 PM

Hi !

 

Welcome to Lenovo Community Forums.

 

Kindly access safe mode and observe if you'll expirience the same problem. Here's how https://support.lenovo.com/us/en/solutions/ht116905.

 

If still the same, it's possible that issue is likely to be hardware related. We suggest that you reach our phone support team in your region or bring the machine to our authorized service porviders to further diagnose the machine. 

 

Regards,



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Reply
Options

4 Posts

11-26-2019

HR

5 Signins

88 Page Views

  • Posts: 4
  • Registered: ‎11-26-2019
  • Location: HR
  • Views: 88
  • Message 3 of 6

Re: ThinkPad X1E terrible performance on iGPU

2019-11-26, 17:14 PM

Hello @Van_Lenovo, thank you for your reply. I just tested safe mode (with hybrid graphics) and the performance is much worse than a regular boot, to the point where moving the mouse cursor around wasn't smooth.

Reply
Options

459 Posts

05-02-2019

US

322 Signins

7862 Page Views

  • Posts: 459
  • Registered: ‎05-02-2019
  • Location: US
  • Views: 7862
  • Message 4 of 6

Re: ThinkPad X1E terrible performance on iGPU

2019-11-26, 17:30 PM

Thanks for letting us know. It's possible that issue is likely to be hardware related since you're experiencing overheat problems with the graphics card already.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Reply
Options

4 Posts

11-26-2019

HR

5 Signins

88 Page Views

  • Posts: 4
  • Registered: ‎11-26-2019
  • Location: HR
  • Views: 88
  • Message 5 of 6

Re: ThinkPad X1E terrible performance on iGPU

2019-11-28, 14:14 PM

Thanks for the response. You were not helpful but I wanted to say that I got an intel driver update today, and while not perfect by any stretch of the imagination, the performance was vastly improved.

0 person found this solution to be helpful.

This helped me too

Reply
Options

459 Posts

05-02-2019

US

322 Signins

7862 Page Views

  • Posts: 459
  • Registered: ‎05-02-2019
  • Location: US
  • Views: 7862
  • Message 6 of 6

Re: ThinkPad X1E terrible performance on iGPU

2019-11-28, 17:57 PM

We're glad to hear that your issue was fixed somehow by driver updates. Thanks for letting us know and have a great day ahead!

 

Regards,



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete