English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics

3 Posts



14 Signins

255 Page Views

  • Posts: 3
  • Registered: ‎02-16-2018
  • Location: DE
  • Views: 255
  • Message 1 of 2

ThinkPad X240 blank or black screen (no POST) after BIOS upgrade from version 2.39 to 2.40

2018-02-18, 0:53 AM

Dear community of helpful and knowledgeable people,


I need to ask you for advise on this issue as I do not know on how to proceed.


First some data on the device of interest:

    Manufacturer: Lenovo™
    Series: X-Series
    Model: X240
    Type-Model#: 20AMS0SQ04
    BIOS/UEFI™: 2.39(GIET89WW)
    ECP version: 1.17(GIHT32WW)



So here is the story:

  • Context:
    It all started with issues related to WiFi. The integrated Intel™ Wireless-N 7260 had sporadic and difficult to analyse losses of connection since every other WiFi device connected to this access point do not raise any issues at all so far.
    After digging through trouble guides and articles I looked up and tried changing relevant advanced driver settings of the chip. Since this did not fixed the WiFi issue I decided to upgrade the drivers.
  • What happened directly before the black screen occurred:
    In order to upgrade the WiFi drivers I ran Lenovo Vantage™ from the Windows Store™. It showed several upgradable components, e.g. Intel Rapid Storage™ drivers, a critical Intel ME™ upgrade, a BIOS upgrade to version 2.40(GIET90WW) fixing a security issue, Intel Graphics™ driver update, Intel Wireless-N™ drivers.
    I selected every component offered and initiated the upgrade assuming the component installations are ordered correctly and installed separately.
    It first installed the Intel Rapid Storage™ drivers upgrade, then the Intel ME™ upgrade and then the BIOS upgrade to version 2.40(GIET90WW). During this process several installer and command prompt windows appeared and showed warnings or asked for further instructions. I followed every single one of them:
    Battery was over 90% and the device was docked appropriately to the Lenovo™ docking station which was itself appropriately connected to a Lenovo™ AC power adapter. The Windows™ battery task symbol assured the connection and usage of a power supply. No different 3rd-party software was running.
    Everything ran fine. The process informed about and successfully finished initiating a reboot. It shortly turned off and then on again.
  • The symptoms after reboot:
    The (internal) screen is black/blank but powered on (light glow). There are no beeps and no POST.
    The device was definitely powered on: power button LED glowing repeatedly (slowly), red dot LED on the top is on, audible fan noise, heat dissipation.
    I waited 6 hours but nothing changed as I was afraid of damaging the device by powering off during or right after a BIOS update. I let the powered on like this for some 24 hours more. Nothing changed.
    Many different keyboard button presses or combos were tried, but had no effect.
    I decided to push the power button. Nothing but a beep code (2x short, [short pause,] 3x short) happend. I pushed it again for 30s but nothing happened besides the aforementioned beep code.
  • What I did since:
    In the meanwhile I was looking for help in the device manuals and online. I could not find any documentation about these symptoms or this beep code besides [1], [2], [3], [4]. The beep code (2x short, [short pause,] 3x short) is not explicitly mentioned but suggests a POST error (but the screen was blank, so not error codes), a motherboard failure or a DIMM failure.
    I decided to undock and powering off the device. As the power button did not work I used the emergency reset button on the bottom which is documented in the device manual. The machine powered off.
    At this point I thought about unplugging the internal storage drive to be safe from any damages to the data (the device is not my own) but there were backups.
    I also thought about replugging or changing the DIMM. As there were no other DIMM available and reasons primarily constituting of laziness I just pressed the power button again.
    To my surprise the device booted as before like nothing happened. The BIOS was still showing version 2.39 though.
    At this point I was quiet relieved as I already expected to have to go through a BIOS reset, replugging or changing the CMOS battery or DIMMs, a whole BIOS reflash (no equipment available) or a motherboard replacement (no warranty).


As the device is as usable as before I am not in a hurry fix anything. But I really would like to upgrade the BIOS to version 2.40 soon in order to be mitigate a severe security issue. I do not know how to proceed though.
This is why I still got a lot of questions though and I would appreciate any answers:


  1. How to resolve this issue? How to make the BIOS upgrade not fail?
  2. Where is this issue, these symptoms or beep codes documented?
  3. Are the Intel ME™ upgrade directly before the BIOS upgrade interfering with each other as they are both pretty low-level firmware? Why was Lenovo Vantage™ upgrading both at once? Doesn't Lenovo Vantage™ correctly order the component upgrades?
  4. How problematic is it to have the device docked to docking station during the whole BIOS upgrade (or Intel ME™ upgrade) procedure? Is it safer to use the normal AC power adapter? See [16]
  5. How problematic is enabling any BIOS passwords for a BIOS upgrade? There were passwords for booting (cold, unattended and restart) enabled. See [16]
  6. Is it generally safer to do a BIOS upgrade via bootable CD image? I could not find any resilient evidence, only anecdotal recommendations, see [16]. In absence of any optical drive I need to use a USB drive but the provided image is not compatible. Using GRUB4DOS or any other solution I found seems overly complicated. Are there any other ways?
  7. Is it necessary to reset the BIOS to defaults first? Aren't all the UEFI boot entries lost then? How would one recover those? See [16]
  8. Who else had/has this issue? I only have some findings below.




[1] about beep codes

[2] about beep codes

[3] about beep codes

[4] about beep codes

[5] someone asking about the same beep code (2x short, [short pause,] 3x short)

[6] (german) black screen issue resolved by replugging CMOS battery

[7] issue after BIOS upgrade resolved by replugging the CMOS battery

[8] issue after BIOS upgrade resolved by depleting the battery and powering the device on again

[9] as above

[10] as above but cause was a defective DIMM

[11] same as [8]

[12] same as [8] but with 5 short beeps and 2nd BIOS upgrade attempt successful

[13] same as [8] but used emergency reset button on the bottom instead

[14] same as [12]

[15] Lenovo™ community knowledgebase article about fixing the blank screen issue after BIOS upgrade by replugging the CMOS battery

[16] (german) anecdotal recommendations for BIOS upgrades: disabling BIOS passwords, restoring BIOS defaults, unplugging all external hardware except the AC power adapter, battery >80% charged

[17] (german) poll about success/failure of BIOS upgrade methods


I want to thank everyone who read this far. Please excuse my wording and writing. English is not my native language.

Please ask, if there is anything unclear to you.
I also want thank in advance for every answer or help of any kind. I really appreciate it!

Solved! See the solution

3 Posts



14 Signins

255 Page Views

  • Posts: 3
  • Registered: ‎02-16-2018
  • Location: DE
  • Views: 255
  • Message 2 of 2

Betreff: ThinkPad X240 blank or black screen (no POST) after BIOS upgrade from version 2.39 to 2.40

2018-07-16, 21:25 PM

Dear readers,


I just had opportunity to invest some more time into this issue again.


Although I am not completely certain of the precise cause of this issue I am quite confident in claiming it had to do with a prior misconfiguration of the BIOS settings leading to an undefined behaviour during completion of the update, i.e. the following BIOS settings 'Security -> Password -> Supervisor Password' and 'Security -> UEFI BIOS Update Option -> Flash BIOS  Updating by End-Users' need to be aligned with each other as the description of the latter implies.


My fix was to simply switch the setting 'Security -> UEFI BIOS Update Option -> Flash BIOS  Updating by End-Users' to 'Enabled' as no Supervisor Password was set, i.e. the status of 'Security -> Password -> Supervisor Password' was/is 'Disabled'. After the switch the update to the current BIOS version 2.43 (for this device model; see original post above) worked as intended.

I did not try setting a Supervisor Password instead. I would guess it should have fixed the issue just as well.


Anyway, thanks to everyone reading, following, reproducing or helping in any way. Cheers!


Now that this device is patched with mitigations against various security issues emerging this year I am in peace of mind because my significant other may finally use it without gaping security holes. Finally, I am able to sleep tight again :)


I really hate needless technical issues like this with a passion. The misconfiguration inevitably leading the computer to undefined behaviour would have been debugged with ease if there was some kind of error message - preferably even before making the BIOS misconfiguration effective. <- There has to be an easy fix for this. Lenovo, please fix this!


I really hope others are going to save the amount of time I invested into this issue (or more). What an unnecessary time sink that was!


0 person found this solution to be helpful.

This helped me too

Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop