English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

1 Posts

03-28-2019

CH

5 Signins

52 Page Views

  • Posts: 1
  • Registered: ‎03-28-2019
  • Location: CH
  • Views: 52
  • Message 1 of 2

Thinkpad X1 Yoga (3rd gen) Fingerprint not working; USB-C dock problems

2019-12-10, 11:17 AM

I have purchased Thinkpad X1 Yoga 3rd generation and have constantly had Fingerprint device problems. The system often did not recognize the device and eventually the device just diappeared in the system.

Driver updates and BIOS setting tricks did not work and I could not even see the device in the device manager.

So, I searched it on the Lenovo forum and there were several similar cases and apparently simply replacing the Fingerprint device does not always solve the problem.

 

I wrote the problems down when I requested the technical service, and the technician just came with a Fingerprint device. He replaced it but it did not work. And I had to arrange another visit and this time the technician replaced the main board and it fortunately worked, although I had to reinstall all drivers and so on again. I was happy for a while, but the Fingerprinter disappeared again soon.

So I requested again the technical service and the technician came and opened up my laptop to replace it. And he realized that he has a wrong Fingerprint device. He just closed the laptop and left. I thought myself okay this could happen.. and stayed for a while without thinking about the Fingerprint device.

 

Later, I requested the replacement again and they answered they cannot replace it and I have to send it in to them which I cannot do soon. And the reason was that they do not replace a part twice - which is contradictory to the last visit of the technician for a second replacement although he had a wrong Fingerprint device.

So I tried to communicate with them by replying to the email but they did not give me a reply for over than a week. 

I tried the service request portal but I could not make any request through the portal. (I asked about the problems via emails and via the chat service several times but got ignored. Just ignored.)

 

I tried another route via the chat service and they actually read my emails and just did not reply to it. And they said I made a consent to send it in which was an absolute surprise to me because I did not! Anyways, they said I must send it in and must wait for a few days. I need to use my laptop everyday and I have to carry it during the Christmas holidays too. But it seemd there is no alternative. So I just requested them to send the device to me and I will try to replace myself because it seemed fairly easy to do for anybody. I told them I would just give up the Fingerprinter if it does not work after the replacement. And they said OK  they will send me the device with a warranty exception. And a few days later, I got an email saying that "your request for the part has been rejected".

 

I feel tired of just thinking of doing this over and over again there is little hope that my Fingerprinter will come back to me and stay till the end. And to be honest, I was diappointed at them in the regard of how inefficient they provide the technical service. - maybe I am too spoiled and this is how it goes here..

 

In addition, I have my USB-C dock and using the provided cables. But sometimes when I accidently 'touch' the USB-C cable, the connection is lost including the internet and all program windows on the external monitor returns back to my laptop screen. Sometimes I have to reboot my remote sessions again and again. And sometimes my laptop complains that power supply is not sufficient and does not get connected to the dock. Firmware updates yes, did not solve the problem. It works very much well with the Thunderbolt docks which have higher range power adapter but not always with my USB-C dock. I request a replacement of the dock and will see how it goes.

 

 

 

 

Reply
Options

459 Posts

05-02-2019

US

322 Signins

7862 Page Views

  • Posts: 459
  • Registered: ‎05-02-2019
  • Location: US
  • Views: 7862
  • Message 2 of 2

Re: Thinkpad X1 Yoga (3rd gen) Fingerprint not working; USB-C dock problems

2019-12-19, 16:16 PM

Hi !

 

Welcome to Lenovo Community Forums.

 

That's not the kind of experience we want you to have and we apologize for the trouble. Is there any chances that you can visit our authorized service providers near in your place to further diagnose the machine? Since it's possible that issue is likely to be hardware related.

 

You may visit this link to find Authorized Service Providers by filtering the Country.

 

Hence, you may Disable/Enable the Fingerprint Reader in BIOS settings by following the steps below and observe if the fingerprint will work without any replacement.

Open BIOS > Security > I/O Port Access > Fingerprint Reader

 

Regards,



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save