Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

4 Posts

12-05-2018

United States of America

8 Signins

53 Page Views

  • Posts: 4
  • Registered: ‎12-05-2018
  • Location: United States of America
  • Views: 53
  • Message 1 of 3

Thunderbolt 3 Dock update on X1C6

2018-12-05, 16:57 PM

Hello

 

I hope someone might be able to help me.

 

I have been trying to run the Thunderbolt Firmware Update Utility - 10 [64] - V.1.0.12.0-N23TF13W.  When I run the update I get the following error from the Thunderbolt firmware update utility: "Error: 0x224 SDK_NATIVE_MODE_MISMATCH Native/BIOS-Assisted mode mismatch between the controller and the image file".

 

Below is the about from the Thunderbolt Software.

 

 

 

Thanks in advance for your guy's help! 

 

Reply
Options

55 Posts

07-18-2018

United States of America

65 Signins

424 Page Views

  • Posts: 55
  • Registered: ‎07-18-2018
  • Location: United States of America
  • Views: 424
  • Message 2 of 3

Re: Thunderbolt 3 Dock update on X1C6

2019-10-02, 14:27 PM

Did you ever find a solution? We are having this issue on some devices (P52s) as well. 

 

It may have to do with the Thunderbolt BIOS Assist Mode setting in the BIOS. I am going to try to test by enabling it on one of the devices having the problem.

 

Skip

Reply
Options

4 Posts

09-11-2019

United States of America

4 Signins

38 Page Views

  • Posts: 4
  • Registered: ‎09-11-2019
  • Location: United States of America
  • Views: 38
  • Message 3 of 3

Re:Thunderbolt 3 Dock update on X1C6

2021-07-09, 18:46 PM

The error is the result of a UEFI/BIOS setting.  Turn off the "BIOS-Assisted mode" setting under the Thunderbolt section of the UEFI setup utility.  That setting is needed only for older Windows 10 installs and for Linux.

 

I finally managed to catch up on two years for firmware updates after finding that setting.  The update utility could have provided better feedback: as it was, the updater has been failing silently for years.  It was not until I extracted the installer and tried to run it manually that I even got close to a solution.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms