English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

3 Posts

10-02-2019

US

7 Signins

65 Page Views

  • Posts: 3
  • Registered: ‎10-02-2019
  • Location: US
  • Views: 65
  • Message 11 of 14

Re: Thunderbolt 3 Gen 2 Workstation Dock USB issues

2020-02-04, 20:26 PM

So I think I figured it out. It has to do with Credential Guard being active and utilizing the Virtualization setting in the BIOS VT-d. If I disable the VT-d setting the dock works perfectly. We have all current firmware and drivers installed and still were having issues until I disabled that setting. So I would be curious to hear from Lenovo on this issue and see what the solution is so our end users can actually use the docks. 

Reply
Options

7 Posts

01-07-2020

DK

7 Signins

74 Page Views

  • Posts: 7
  • Registered: ‎01-07-2020
  • Location: DK
  • Views: 74
  • Message 12 of 14

Re: Thunderbolt 3 Gen 2 Workstation Dock USB issues

2020-02-09, 14:17 PM

Same issue here on P53 - Intel VT-d features needs to be disabled in BIOS to be able to undock and redock and event then not all USB devices on the port replicator gets back as they should and you have to unplug and replug them.

Reply
Options

6 Posts

12-11-2019

AT

11 Signins

100 Page Views

  • Posts: 6
  • Registered: ‎12-11-2019
  • Location: AT
  • Views: 100
  • Message 13 of 14

Re: Thunderbolt 3 Gen 2 Workstation Dock USB issues

2020-02-10, 10:48 AM

Can confirm this as well. Disabling VT-d makes my TB3 dock work correctly with the X1E2. Unfortunately this is not a solution but merely a temporary workaround.

Reply
Options

3 Posts

10-02-2019

US

7 Signins

65 Page Views

  • Posts: 3
  • Registered: ‎10-02-2019
  • Location: US
  • Views: 65
  • Message 14 of 14

Re: Thunderbolt 3 Gen 2 Workstation Dock USB issues

2020-02-13, 13:41 PM

I agree this is not a solution because we use Crdential Guard and the VT-d is a requirement to use that. I would like to know what Lenovo has to say about this. 

On a side note, Lenovo sent me their image to test with and I could not replicate the issue using their image even with the VT-d setting enabled. Their image is 1903 and we are on 1909 so there is a few differences. 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save