English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

52 Posts

02-15-2019

US

302 Signins

1754 Page Views

  • Posts: 52
  • Registered: ‎02-15-2019
  • Location: US
  • Views: 1754
  • Message 1 of 9

Windows 10 Update downloaded X1E firmware 1.21, which I already manually installed last week ?!?

2019-05-18, 6:28 AM

Windows 10 now wants to restart the laptop to finish the installation. So I restart the system. At the BIOS startup screen the system displays a red horizontal bar (under the red "Lenovo" logo) , makes a few loud beeps (presumably because firmware 1.21 is already installed) and then proceeds to start Windows which in turn wants me to restart again to complete the firmware installation.

How do I get out of this ridiculous loop?

 

Reply
Options

734 Posts

04-23-2019

US

421 Signins

13372 Page Views

  • Posts: 734
  • Registered: ‎04-23-2019
  • Location: US
  • Views: 13372
  • Message 2 of 9

Re:

2019-05-18, 16:20 PM

Hi mircolino, Thanks for writing in. We recommend to not restart the computer when it prompts you to. We recommend reinstalling the Firmware update. Please download the firmware update again from the support website:
https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-x-series-laptops/thinkpad-x1-extreme/downloads?CID=ww:lenovosocial:20x9m6.

 

Let us know if this works out. Thanks.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

52 Posts

02-15-2019

US

302 Signins

1754 Page Views

  • Posts: 52
  • Registered: ‎02-15-2019
  • Location: US
  • Views: 1754
  • Message 3 of 9

Re: Re:

2019-05-18, 18:22 PM

Tried your suggestion but it refuses to install it because it says it's already installed.

 

As a temp workaround I found that if in the Windows 10 Device Manager I uninstall & delete the "ThinkPad P1/X1 Extreme System Firmware 1.21" it reverts back to the usual "System Formware" and I can reboot the system normally. Al least until I run the Windows 10 Update again, in which case it all start over again.

 

Why is this happening all of a suddent? I didn't change anything in my system config.

 

Reply
Options

3 Posts

05-29-2019

AU

2 Signins

17 Page Views

  • Posts: 3
  • Registered: ‎05-29-2019
  • Location: AU
  • Views: 17
  • Message 4 of 9

Re: Re:

2019-05-29, 12:56 PM

This is happening exactly the same to me.

 

Have you found any solution yet?

 

I noticed Lenovo released 1.22 BIOS update the other day but couldn't download as the link was broken, then this update disappeared very soon.

I guess they have been encountering some issues.

 

Maybe it is related to X1E 2 release.

 

Reply
Options

52 Posts

02-15-2019

US

302 Signins

1754 Page Views

  • Posts: 52
  • Registered: ‎02-15-2019
  • Location: US
  • Views: 1754
  • Message 5 of 9

Re: Re:

2019-05-29, 14:03 PM

I installed BIOS 1.22 and the problem went away. But then it was pulled (thank God I didn't have a BIOS password!!!) so I'm not sure what to say. Hopefully 1.23 will be out soon.

Reply
Options

42 Posts

01-07-2019

CN

140 Signins

2083 Page Views

  • Posts: 42
  • Registered: ‎01-07-2019
  • Location: CN
  • Views: 2083
  • Message 6 of 9

Re: Re:

2019-05-29, 18:23 PM

 wrote:

This is happening exactly the same to me.

 

Have you found any solution yet?

 

I noticed Lenovo released 1.22 BIOS update the other day but couldn't download as the link was broken, then this update disappeared very soon.

I guess they have been encountering some issues.

 

Maybe it is related to X1E 2 release.

 


https://forums.lenovo.com/t5/ThinkPad-X-Series-Laptops/X1-EXTREME-G1-BIOS-UPDATE-1-22-SUPERVISOR-PASSWORD-BROKEN/td-p/4435630

Reply
Options

2157 Posts

04-20-2008

US

19178 Signins

108320 Page Views

  • Posts: 2157
  • Registered: ‎04-20-2008
  • Location: US
  • Views: 108320
  • Message 7 of 9

Re: Windows 10 Update downloaded X1E firmware 1.21, which I already manually installed last week ?!?

2019-05-29, 22:54 PM

Right-click on the erroneous FW and uninstall it and specify to delete the driver. Restart the system. The Microsoft FW will then be reinstalled which is correct. I reported this into tech support some weeks ago with no resolution as to why the Lenovo FW was being presented by Windows Update.


P53 XEON 2276 BIOS 1.22 OLED UHD 4K Multi-touch display, 96GB RAM, RTX5000, RAID 1, 1TB x 2 Samsung PM981, 1TB PM981, WWAN
P70 XEON 1505, BIOS 2.32, 4k Display, 64GB, M3000M NVIDIA GPU, RAID1 1TB Samsung PM981 PCIe-NVMe SSD x 2, 2x Samsung 850 Pro 1TB SSD. EM7455 WWAN
P1. BIOS 1.25,Xeon Processor, 4k UHD IPS multi-touch display, 32GB, PM981 1TB x 2, RAID1

I am not an employee nor an agent of Lenovo.
Reply
Options

3 Posts

05-29-2019

AU

2 Signins

17 Page Views

  • Posts: 3
  • Registered: ‎05-29-2019
  • Location: AU
  • Views: 17
  • Message 8 of 9

Re: Re:

2019-05-30, 12:00 PM
Wow! That's why they pulled the 1.22!
Reply
Options

3 Posts

05-29-2019

AU

2 Signins

17 Page Views

  • Posts: 3
  • Registered: ‎05-29-2019
  • Location: AU
  • Views: 17
  • Message 9 of 9

Re: Windows 10 Update downloaded X1E firmware 1.21, which I already manually installed last week ?!?

2019-05-30, 12:01 PM
Thanks a lot for the info.
Just because I saw some drama from other ThinkPad users regarding the BIOS or firmware update, so wanted to make sure what's the right operation.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save