Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
What's DOS?
Posts: 1
Registered: ‎05-20-2012
Location: Gales Ferry, CT
0 Kudos

Windows Installer not installed properly, then boots to safe mode w/no backlight?

[ Edited ]

I have only used my laptop for about 2 weeks.


I tried to download an Adobe Reader update, and I got a message that said "Windows Installer was not installed correctly." 


I retarted my computer, but it would only boot in safe mode. 


I tried  a System Restore, but I got a message that said   "System Restore doesn't appear to be functioning properly."


I tried to do a virus scan (just in case), but my computer will not connect to the internet, so that's not working, either. 


I tried to restart once more,  but as soon as I went to put my password in, the backlight on the laptop would shut off, and then it would only boot in safe mode. 


I put the laptop away for a little while because my life got very busy and I didn't have the time to deal with it. Today, when I turned the laptop on to try and troubleshoot, it booted  normally, and successfully- no safe mode, backlight still on- and then it told me that System Restore had worked. 


What gives? 


Anyone have any ideas what happened / what I did to make this happen / how I can avoid it in the future / if the computer is actually going to function properly or if it needs to be sent back? 



Posts: 955
Topics: 3
Kudos: 80
Solutions: 65
Registered: ‎01-05-2010
Location: INDIA
0 Kudos

Re: Windows Installer not installed properly, then boots to safe mode w/no backlight?

Hello SuperNova and welcome to community,


When you restore the system earlier to back date it did not get complete and also Windows 7 has startup repair option which fixes the common startup bugs.


Best Regards,


Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution".! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!