cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
blahblah_gc
Fanfold Paper
Posts: 14
Registered: ‎05-22-2016
Location: US
Views: 875
Message 1 of 5

X1 Carbon 2016 tap slow response

I noticed since day one that this new computer's trackpad has been acting slowly on taps. I tried to find solutions but can't. Then finally I found out 'disable edge tap filter' resolves the problem. After uncheck this feature, any mouse tap provides immediate response.

Former Employee
Posts: 1,664
Registered: ‎09-16-2014
Location: US
Views: 829
Message 2 of 5

Re: X1 Carbon 2016 tap slow response

Blahblah_gc,

 

Think Engineering reports that the touchpad tap response you described is the X1 Carbon 4th Gen touchpad working as designed.

 

A default touchpad filter function was put in place to avoid unintentional touchpad taps. With the filter in place, the response time is 250 milliseconds in all regions of the touchpad.

 

As you noted, disabling the edge tap filter provides an immediately response but may also result in loss of control for some X1 Carbon 4th Gen customers.

 

Thank you,

blahblah_gc
Fanfold Paper
Posts: 14
Registered: ‎05-22-2016
Location: US
Views: 822
Message 3 of 5

Re: X1 Carbon 2016 tap slow response

Yeah Thanks. However, if you can somehow minimize the lag time with enabled filtering, this would be awesome. Right now, I just have to disable all the filtering and make sure my palms are NOT touching the touchpad while typing. Its really annoying to have lagging tap responses.

Former Employee
Posts: 1,664
Registered: ‎09-16-2014
Location: US
Views: 805
Message 4 of 5

Re: X1 Carbon 2016 tap slow response

Blahblah_gc,

 

While Think Engineering does not support disabling the custom filter due to increased accidental input, both the custom filter and the OS native filter must be removed to minimize lag time for touchpad input.

 

To disable custom filter for typing:

Mouse properties -> ThinkPad tab -> Settings (button) -> Advanced (tab) -> Smart Check (tab) -> Palm Check Threshold [Move slider to leftmost], Edge Tap [Uncheck]

 

To disable OS native filter for typing:

Mouse & Touchpad settings -> “To help prevent the cursor from accidentally…(pull-down menu)” [No Delay]

 

Thank you,

blahblah_gc
Fanfold Paper
Posts: 14
Registered: ‎05-22-2016
Location: US
Views: 800
Message 5 of 5

Re: X1 Carbon 2016 tap slow response

Thanks, 

 

I got the first one but not sure where to get the "Mouse & Touchpad settings". Control panel only has "Mouse". BTW, just do "To disable custom filter for typing:" seems to resolve all the delay.

 

 

Check out current deals!


Shop current deals

Top Kudoed Authors