English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

5 Posts

03-01-2017

GB

5 Signins

84 Page Views

  • Posts: 5
  • Registered: ‎03-01-2017
  • Location: GB
  • Views: 84
  • Message 1 of 12

X1 Carbon 2017 Function keys not working after OS install

2017-03-01, 22:25 PM

Hi,

I re-installed Windows 10 and only some of the function key special functions are now working.  Mute, volume and screen brightness keys are working, the remainder are not.  I've seen similar threads that mention re-installing BIOS and power management software but that's made no difference.  I've been unable to find a "Hotkey" feature that is also mentioned.  Companion software says everything is up to date.  Don't know what to try next.  Any thoughts?

Solved! See the solution
Reply
Options

1811 Posts

12-12-2016

IN

1843 Signins

46611 Page Views

  • Posts: 1811
  • Registered: ‎12-12-2016
  • Location: IN
  • Views: 46611
  • Message 2 of 12

Re: X1 Carbon 2017 Function keys not working after OS install

2017-03-02, 5:08 AM

Hi friend, 

 

Welcome to Lenovo Community! And happy to have you here.

 

As I understand that you are facing issues with function keys which are not working in your X1 Carbon

I'll suggest you to install the drivers using Lenovo System Update it will update all the missing drivers.

Or else use this Hotkey features.

  

Do let us know how it goes!

Please feel free to post in Lenovo Community Forums if you have any further queries!

 
Cheers,

Prabhansh
_______________________________________________
Tap that Kudos button if I helped.
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

____________________________________________________
ThinkPad T440p| Intel® Core™ i5-4300M| 2.6 GHz Dual core| 8GB

0 person found this solution to be helpful.

This helped me too

Reply
Options

3 Posts

10-30-2017

ID

14 Signins

46 Page Views

  • Posts: 3
  • Registered: ‎10-30-2017
  • Location: ID
  • Views: 46
  • Message 3 of 12

Re: X1 Carbon 2017 Function keys not working after OS install

2017-10-30, 2:50 AM

Hi,

 

I have the same issue with the function keys. My X1 Carbon Gen 5 happened to be infected by virus and I had to reset my laptop via Windows reset features. Like the person above, all my hotkey does not work, except the sound mute (light on), volume up, volume down, brightness up and brightness down. Everything else (F4, F7, F8, F9, F10, F11, F12) does not work. I have updated the drivers through system update and hotkey intergration as well, still no luck.

Hotkey driver 9.0.0.6

System update ver 5.07.0065

 

Any help is appreciated.

 

Thank you.

 

Regards,

Adrian

Reply
Options

5 Posts

03-01-2017

GB

5 Signins

84 Page Views

  • Posts: 5
  • Registered: ‎03-01-2017
  • Location: GB
  • Views: 84
  • Message 4 of 12

Re: X1 Carbon 2017 Function keys not working after OS install

2017-10-30, 7:41 AM

Hi,

Apologies for not replying sooner.

The steps recommended fixed the issue for me.  It was bound to be some Lenovo-specific software that was not installed and, if memory serves correct, the Hotkeys software is what's required.  All working now and very happy with my X1 carbon!

Reply
Options

3 Posts

10-30-2017

ID

14 Signins

46 Page Views

  • Posts: 3
  • Registered: ‎10-30-2017
  • Location: ID
  • Views: 46
  • Message 5 of 12

Re: X1 Carbon 2017 Function keys not working after OS install

2017-10-30, 14:51 PM

Hi,

 

I have tried the solution given, but still no luck.. Function key not working (some), installed the hotkey driver again, no luck.. reinstall windows 10, also no luck..

 

Any Lenovo rep can help with this issue?

 

Cheers

Reply
Options

1 Posts

02-01-2018

US

2 Signins

16 Page Views

  • Posts: 1
  • Registered: ‎02-01-2018
  • Location: US
  • Views: 16
  • Message 6 of 12

Re: X1 Carbon 2017 Function keys not working after OS install

2018-02-01, 19:49 PM

CTracy:  thank you very much for posting your "sorry for not having replied sooner, the above worked for me" re. the disappearing function keys including volume, etc.  I was in the same situation, and based on your report I installed all of the Lenovo drivers per the advice.  And...it worked for me too!   :)

Reply
Options

1 Posts

08-24-2018

US

1 Signins

9 Page Views

  • Posts: 1
  • Registered: ‎08-24-2018
  • Location: US
  • Views: 9
  • Message 7 of 12

Re: X1 Carbon 2017 Function keys not working after OS install

2018-08-24, 22:04 PM

Hello All,

 

I have a new think pad X1 carbon 20KH model and few of the hotkeys are working but specific with wireless Fn+F8 is not working.

 

I did tried installing drivers as on Aug 20th 2018 still not working. Any suggestions.

Reply
Options

4860 Posts

04-25-2008

US

39375 Signins

741827 Page Views

  • Posts: 4860
  • Registered: ‎04-25-2008
  • Location: US
  • Views: 741827
  • Message 8 of 12

Re: X1 Carbon 2017 Function keys not working after OS install

2018-08-25, 0:22 AM

Hi DVKrishna, and welcome to the Lenovo User Community!

 

By default, Fn+F8 gives you F8. To toggle wireless, press only the F8 key.

 

This is the default behavior. You can invert this behavior in the BIOS if you wish.

 

Hope this helps!

I don't work for Lenovo. I'm a crazy volunteer!
Using Browser Search To Find Answers in the Lenovo and Moto Communities.
Reply
Options

3 Posts

09-10-2018

SA

14 Signins

142 Page Views

  • Posts: 3
  • Registered: ‎09-10-2018
  • Location: SA
  • Views: 142
  • Message 9 of 12

Re: X1 Carbon 2017 Function keys not working after OS install

2018-09-10, 13:28 PM

i also have X1 carbon 3rd generation win 7 64-bit is installed i am experiencing the same issue Fn+ F8 is not working and unable to disable the wireless from it, i updated the hotkey drivers chipset driver and even reinstall the wireless drivers but not work for me .

is there any other soloution please share

 

Reply
Options

3 Posts

02-24-2010

US

5 Signins

68 Page Views

  • Posts: 3
  • Registered: ‎02-24-2010
  • Location: US
  • Views: 68
  • Message 10 of 12

Re: X1 Carbon 2017 Function keys not working after OS install

2018-09-13, 21:30 PM

Jumping into this conversation because its the closest to my issue.  I have a W540 running Windows 7 where the integrated special FN keys stopped working.  The only updates I'm aware of were recent Windows Critical Updates.  Running Lenovo System Update does not show any drivers needing to be installed except Realtek Audio Driver.  I reinstalled Hotkey Features Integration for Windows 7 8.86.25.  I've checked Advanced Display settngs and ensured Enable On Screen Display is enabled.  If I press the mute and screen brightness +/- keys, they function.  The Wireless FN key does not work (I really need this one), but the screen does not display the keys being pressed.  This goes for CAPS and NUM LOCK as well--the keys function, but does not sho on the screen that they've been pressed.

 

I've tried System Restore, but every Restore Point says that no changes were made. I've looked at the BIOS and the settings there sho that the FN keys are enabled and are not switched.

 

Help please!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save