English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

2 Posts

09-07-2017

AT

2 Signins

31 Page Views

  • Posts: 2
  • Registered: ‎09-07-2017
  • Location: AT
  • Views: 31
  • Message 1 of 11

X1 Carbon 5th Generation problem with Thunderbolt 3 dock

2017-09-07, 13:11 PM

Hello everybody,

 

We have purchased the X1 Carbon 5th Gen Laptop, which by the way is a great piece of hardware, with Thunderbolt 3 dock. 

 

The problem: the laptop does not recognize the dock. other laptop (identical with the problematic one, works perfectly...

 

Any sugestions?

Solved! See the solution
Reply
Options

6272 Posts

10-29-2009

NC

17576 Signins

159825 Page Views

  • Posts: 6272
  • Registered: ‎10-29-2009
  • Location: NC
  • Views: 159825
  • Message 2 of 11

Re: X1 Carbon 5th Generation problem with Thunderbolt 3 dock

2017-09-14, 18:25 PM

There are BIOS settings related to Thunderbolt (in the "Config" menu of BIOS setup), are these settings configured identically on both ThinkPads?  As an experiment, try setting the security level to "No Security" and see if you can get it working that way...

 

Same BIOS version on both ThinkPads?

0 person found this solution to be helpful.

This helped me too

Reply
Options

2 Posts

09-07-2017

AT

2 Signins

31 Page Views

  • Posts: 2
  • Registered: ‎09-07-2017
  • Location: AT
  • Views: 31
  • Message 3 of 11

Re: X1 Carbon 5th Generation problem with Thunderbolt 3 dock

2017-09-18, 10:38 AM

Ok, that did the magic...

 

interesting. when i restarted the laptop, the device was connected and waiting for approval. After approval everything was fine.

 

Thanks!

Reply
Options

1 Posts

11-06-2017

GB

2 Signins

25 Page Views

  • Posts: 1
  • Registered: ‎11-06-2017
  • Location: GB
  • Views: 25
  • Message 4 of 11

Re: X1 Carbon 5th Generation problem with Thunderbolt 3 dock

2017-11-06, 12:15 PM

I was going to start a new thread but I also have an issue with the dock. I actually have it working after changing the security level to "No Security" in the BIOS however in order to do that I had to change the graphics memory from 512MB to 256MB. I need 512MB for applications I use such as Photoshop but also need to use the dock!

 

Without changing the graphics option in the BIOS to 256MB, the system will not let you make changes to the Thunderbolt 3 security level. Can you please tell me how I can use 512MB graphics whilst also using the dock?

 

A bit more info: It is possible to use the dock with 512MB graphics memory set however only the HDMI and displayport work - the USB, headphones and USB ports do not work in that configuration. I have also ran the firmware update for the dock, installed the drivers necessary and ensured that my X1 drivers and firmware are also up-to-date.

 

I look forward to hearing from you.

Reply
Options

4 Posts

11-17-2017

US

7 Signins

33 Page Views

  • Posts: 4
  • Registered: ‎11-17-2017
  • Location: US
  • Views: 33
  • Message 5 of 11

Re: X1 Carbon 5th Generation problem with Thunderbolt 3 dock

2017-11-17, 23:11 PM
Hi Matt! I also have this problem. Moderate graphics use and a lot of lag when set to 256MB video...but to change the setting to 512 MB, my USB devices get disabled. I posted about it separately here: https://forums.lenovo.com/t5/forums/v3_1/forumtopicpage/board-id/tp02_en/thread-id/80697

If you find an answer, can you share it with me?
Reply
Options

24 Posts

11-10-2017

US

41 Signins

300 Page Views

  • Posts: 24
  • Registered: ‎11-10-2017
  • Location: US
  • Views: 300
  • Message 6 of 11

Re: X1 Carbon 5th Generation problem with Thunderbolt 3 dock

2018-01-17, 1:05 AM

Hi Matt, Troy -

 

I just encountered the SAME issue.  Running a Thunderbolt 3 dock with my Carbon X1 5th gen.  Bought the dock to drive Dual UHD monitors (as advertised by the Dock's marketing materials). 

 

Clearly, the more video memory available, the better.

 

Unfortunately, to set the Dedicated Video Memory to 512MB, I need to enable the Thunderbolt Security in the BIOS.  

 

The monitors work great (4k @60HZ), but the dock's USB ports AND Ethernet port are useless.  

 

Have you figured out a solution?  The dock is too expensive to not work perfectly.  

Reply
Options

4 Posts

11-17-2017

US

7 Signins

33 Page Views

  • Posts: 4
  • Registered: ‎11-17-2017
  • Location: US
  • Views: 33
  • Message 7 of 11

Re: X1 Carbon 5th Generation problem with Thunderbolt 3 dock

2018-01-17, 1:30 AM

Hi!

Nope. I called Dell and spent 3 hours being bounced back and forth between their hardware and their software support groups and no one could give me an answer or really own the issue.

I tweeted at them online, got asked to send them a DM, and then they just sent me a link to an article I had already seen that does not solve the problem.

I think the unspoken truth here is it just doesn't work.

You can't do 4K AND use the USB ports...which is ridiculous...that isn't a dock, it's a REALLY fat, REALLY expensive HDMI cable!

I wish someone from Lenovo would just pop in here and say yes it works, here's how, or no it doesn't work.

Left feeling slimy (I've done my homework...I work in IT...) and switching away from a Thinkpad for the first time in 20 years on my next refresh.

Troy

P.S. My Ethernet cont'd to work with the single UHD monitor...just the USB ports that were useless.

Reply
Options

24 Posts

11-10-2017

US

41 Signins

300 Page Views

  • Posts: 24
  • Registered: ‎11-10-2017
  • Location: US
  • Views: 300
  • Message 8 of 11

Re: X1 Carbon 5th Generation problem with Thunderbolt 3 dock

2018-01-17, 1:48 AM

Thanks for the reply.

 

I assume you meant LENOVO in the first part of your response.

 

Absurd.  This "dock" is a big, fat EXPENSIVE dual monitor solution / power adapter.  Really disappointing given the potential.   DO NOT BUY THIS PRODUCT.

 

Reply
Options

4 Posts

11-17-2017

US

7 Signins

33 Page Views

  • Posts: 4
  • Registered: ‎11-17-2017
  • Location: US
  • Views: 33
  • Message 9 of 11

Re: X1 Carbon 5th Generation problem with Thunderbolt 3 dock

2018-01-17, 1:54 AM
Yes, Lenovo...apologies.
Reply
Options

24 Posts

11-10-2017

US

41 Signins

300 Page Views

  • Posts: 24
  • Registered: ‎11-10-2017
  • Location: US
  • Views: 300
  • Message 10 of 11

Re: X1 Carbon 5th Generation problem with Thunderbolt 3 dock

2018-01-17, 2:44 AM

Thank you for the quick reply again!

 

Still can't get over this issue... 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete