Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

1 Posts

09-16-2020

Switzerland

2 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎09-16-2020
  • Location: Switzerland
  • Views: 5
  • Message 31 of 37

Re:X1 Carbon 6th Gen - No active Thunderbolt(TM) controller found in the system

2020-09-16, 21:47 PM

I have the same problem too. :((((((

It's a totally stupid situation with home office and no big screen. 

Lenovo service in my area is a desaster (as I've had to experience with other issues in the past).

Is main board replacement really the only solution?

Any advice is very much appreciated. 

Reply
Options

4 Posts

11-06-2019

United Kingdom of Great Britain and Northern Ireland

5 Signins

30 Page Views

  • Posts: 4
  • Registered: ‎11-06-2019
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 30
  • Message 32 of 37

Re:X1 Carbon 6th Gen - No active Thunderbolt(TM) controller found in the system

2020-09-16, 22:18 PM

Dear all,

Replacing the motherboard did not solve my problem. I wasted days with Lenovo customer service. I kept escalating until I reached a phenomenal agent. She got my faulty laptop replaced with a newer model and extended my warranty. She is the only reason I stuck with Lenovo. 
 

Know your rights. Escalate if you are not happy with the solution. Do not waste your hard earned money and time on a faulty product. 

Reply
Options

4 Posts

08-22-2018

Canada

8 Signins

29 Page Views

  • Posts: 4
  • Registered: ‎08-22-2018
  • Location: Canada
  • Views: 29
  • Message 33 of 37

Re:X1 Carbon 6th Gen - No active Thunderbolt(TM) controller found in the system

2020-09-21, 17:45 PM

A suspected, I get this back from my service request

 

"Unfortunately we are unable to process your case system showing out of warranty End Date: 2019-08-09 , please we can refer you to the BP link for billable repair :https://lenovo.secure.force.com/bplocator/

 

Thanks"

 

I guess I now officially have a brick. Anyone lese have some decent non-Lenovo options for replacement? 

Reply
Options

1 Posts

11-15-2020

United States of America

1 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎11-15-2020
  • Location: United States of America
  • Views: 5
  • Message 34 of 37

Re:X1 Carbon 6th Gen - No active Thunderbolt(TM) controller found in the system

2020-11-15, 21:10 PM

Hello,

 

The Thunderbolt port on my x1 carbon 6th gen stopped working today.  I've tried to resolve by updated the software and firmware listed here: https://pcsupport.lenovo.com/ca/en/solutions/ht508988/?clickid=1qLzLoX-jxyJTlPwUx0Mo3cTUknW6OTPNxaGwc0&irgwc=1&PID=221109&acid=ww%3Aaffiliate%3Abv0as6

 

When that did not work, I tried the steps in this post: https://forums.lenovo.com/t5/ThinkPad-X-Series-Laptops/X1-Carbon-6th-Gen-No-active-Thunderbolt-TM-controller-found-in-the-system/m-p/4561971

 

nothing has worked.  I"ve attached a word doc with my steps.  

 

Please help!  Not having this port working will severely handicap my ability to accomplish things in my personal life and work life.  

Reply
Options

6 Posts

10-12-2012

Russian Federation

15 Signins

88 Page Views

  • Posts: 6
  • Registered: ‎10-12-2012
  • Location: Russian Federation
  • Views: 88
  • Message 35 of 37

Re:X1 Carbon 6th Gen - No active Thunderbolt(TM) controller found in the system

2020-11-22, 12:15 PM

@ JBWH wrote:
 

 

Had what appears to be the same problem today.

 

Over the weekend, Lenovo software notified me that there were updates available, including one for Thunderbolt firmware.  I let them run.  All seemed OK until I came into work, and found that the laptop wouldn't detect my dock or even a monitor plugged into the HDMI port.  No Thunderbolt device showing up in device manager.  The dock was working as a basic USB hub (mouse and keyboard, nothing else) and that's it.  Tried another dock - same thing.

 

One of the earlier posts mentions making sure TB is enabled in BIOS.  It was, but I figured maybe turning it off and back on again would help...

 

It appears to have been fixed by:

Going into BIOS

Security --> I/O

DISABLE Thunderbolt 3

save and exit

system restarts automatically

Go into BIOS

Security -->I/O

re-enable Thunderbolt 3

 

TB device shows up in device manager again.  HDMI and all dock features working again.  TB firmware is showing version 45.

 

Hopefully this will also work for someone else.

 

 

Thanks, working for me. 

Reply
Options

4 Posts

08-22-2018

Canada

8 Signins

29 Page Views

  • Posts: 4
  • Registered: ‎08-22-2018
  • Location: Canada
  • Views: 29
  • Message 36 of 37

Re:X1 Carbon 6th Gen - No active Thunderbolt(TM) controller found in the system

2020-11-23, 1:11 AM

Lucky. Tried this again, and still doesn't work for me. Pretty sure the initial problem caused an error with the motherboard and ports. Nit sure I want to spend good money after bad to get the motherboard and port replaced. 

Reply
Options

1 Posts

01-07-2021

United States of America

1 Signins

10 Page Views

  • Posts: 1
  • Registered: ‎01-07-2021
  • Location: United States of America
  • Views: 10
  • Message 37 of 37

Re:X1 Carbon 6th Gen - No active Thunderbolt(TM) controller found in the system

2021-01-07, 1:20 AM

I'm late to the thread, but dropping a comment after spending hours today to try to solve this problem along with the fact that the native HDMI ports were not working. I found this thread: https://forums.lenovo.com/t5/ThinkPad-X-Series-Laptops/X1-Carbon-6th-gen-HDMI-not-working/m-p/4091511?page=2

 

It directed me to push a small power reset button on the bottom of the machine. Doing this made the thunderbolt controller appear again in the device manager. I then updated the thunderbolt firmware. Hope you can find a solution!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms