English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

36 Posts

07-13-2018

Germany

73 Signins

578 Page Views

  • Posts: 36
  • Registered: ‎07-13-2018
  • Location: Germany
  • Views: 578
  • Message 1 of 3

X1 Carbon 6th Gen Touchpad not working

2019-11-07, 10:41 AM

Hello!

The touchpad of my X1 stopped working again :(.

 

I tried to uninstall the Synaptics device, which makes it work again after the first reboot, but when the Synaptics driver is automatically reinstalled it will stop working again. Strangely gestures like 4 finger swipe works but the cursor doesn't move, and the touchpad driver diagnostics also seems to see finger movements.

 

It seems that the device is detected as as Synaptics TouchPad V9.16 on PS2 Port instead of using the SMBus:

 

Can anyone help with this issue or post screenshots from their working X1 C6 (Thinkpad tab in the mouse properties and press Alt+Shift+i) ?

Reply
Options

5 Posts

11-06-2019

United States of America

29 Signins

280 Page Views

  • Posts: 5
  • Registered: ‎11-06-2019
  • Location: United States of America
  • Views: 280
  • Message 2 of 3

Re: X1 Carbon 6th Gen Touchpad not working

2019-11-07, 14:27 PM

Hi there,

 

I also had this issue on a brand new X1C6 that I received two days ago. I was able to resolve my issue but I had to do 2 fresh installs before I finally got it fixed, and I can't even explain what process finally fixed it. I just know it's fixed because your symptoms sound like mine and I haven't had the issue in over 24 hours now.

 

Reply
Options

2 Posts

06-02-2020

Thailand

2 Signins

10 Page Views

  • Posts: 2
  • Registered: ‎06-02-2020
  • Location: Thailand
  • Views: 10
  • Message 3 of 3

Re:X1 Carbon 6th Gen Touchpad not working

2020-06-03, 12:28 PM

Has anyone tried the reset button (? or hole?) underneath the laptop. 

I did! And it worked!

I got a problem with the second (external) monitor not detected the other day, and came across a thread here that suggested the reset button. That saved me once.

So this time around, I got the touchpad not working problem and couldn't find a simple enough way to fix it.

So I tried the ol'reset button trick again, and it worked miraculously!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms