cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ThinkpadBoi1
SCSI Port
Posts: 33
Registered: ‎07-13-2018
Location: DE
Views: 194
Message 1 of 2

X1 Carbon 6th Gen Touchpad not working

Hello!

The touchpad of my X1 stopped working again Smiley Sad.

 

I tried to uninstall the Synaptics device, which makes it work again after the first reboot, but when the Synaptics driver is automatically reinstalled it will stop working again. Strangely gestures like 4 finger swipe works but the cursor doesn't move, and the touchpad driver diagnostics also seems to see finger movements.

 

It seems that the device is detected as as Synaptics TouchPad V9.16 on PS2 Port instead of using the SMBus:

2019-11-07 11_29_26-TouchPad Driver Diagnostics V19.3.4.222.png2019-11-07 11_29_37-TouchPad Driver Diagnostics V19.3.4.222.png2019-11-07 11_29_44-TouchPad Driver Diagnostics V19.3.4.222.png

 

Can anyone help with this issue or post screenshots from their working X1 C6 (Thinkpad tab in the mouse properties and press Alt+Shift+i) ?

crybabyy
Punch Card
Posts: 3
Registered: ‎11-05-2019
Location: US
Views: 113
Message 2 of 2

Re: X1 Carbon 6th Gen Touchpad not working

Hi there,

 

I also had this issue on a brand new X1C6 that I received two days ago. I was able to resolve my issue but I had to do 2 fresh installs before I finally got it fixed, and I can't even explain what process finally fixed it. I just know it's fixed because your symptoms sound like mine and I haven't had the issue in over 24 hours now.

 EQKw4yg.pngKJHl5KB.pnglNJ8Wih.png

Check out current deals!


Shop current deals

Top Kudoed Authors