cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DanKind
Paper Tape
Posts: 3
Registered: ‎03-15-2019
Location: AU
Views: 209
Message 1 of 4

X1 Carbon 6th Gen with 40AH Dock Fault After Firmware Upgrade (2 Examples)

Hi!

X1 Carbon 6th Gen, connected to two seperate (home/work) 40AH docks running different 4k monitors @ 60hz via DP has recently started to blank / lose sync to the connected external monitors after the recent firmware upgrade available via Lenovo Companion and matched here: https://download.lenovo.com/consumer/options/n20pf03w.exe

 

Prior to this firmware upgrade, both docks and their respective monitors were functioning entirely normally. The firmware has been pinpointed as the ugprade occured at work first (which started exhibiting the fault) whilst home was OK, then when the firmware was applied to home the fault began to occur.

 

There seems to be no reason as to why the screen blanking occurs, the monitors exhibit symptoms of a cable being disconnected for a short period and then reconnected. I can only assume there is an issue with the firmware on the DP component on the docks. The OS does not seem to record any connected hardware change in logs (as if the dock was disconnected via power/data) rather it seems only the output of the dock to the monitors is faulting.

 

All other system upgrades have been applied via Lenovo Companion and/or via the website drivers list.

 

The fault seems to be exhibited during fast video / screen switching within the OS (Windows 10). Although most frequently during large excel documents (lots of horiztonal and vertical scrolling)

 

Seeking assistance and/or the ability to downgrade the DP firmware on the docks to return functionality to normal.

 

Thanks!

Dan

 

DanKind
Paper Tape
Posts: 3
Registered: ‎03-15-2019
Location: AU
Views: 143
Message 2 of 4

Re: X1 Carbon 6th Gen with 40AH Dock Fault After Firmware Upgrade (2 Examples)

Update: Issue only seems to occur at 4k, 59/60hz with single external monitor connected.

DanKind
Paper Tape
Posts: 3
Registered: ‎03-15-2019
Location: AU
Views: 106
Message 3 of 4

Re: X1 Carbon 6th Gen with 40AH Dock Fault After Firmware Upgrade (2 Examples)

Updated: Both monitors support audio input via DisplayPort, the sync issue (drop out) occured only when system sounds played - difficult to troubleshoot as most frequent experience was within excel searching - initially thought to be due to lots of scrolling lines, turns out that if you disable sound output to the monitors the drop out of video disappears. 

Curious - as this didnt occur on the previous firmware, but at least usable in the meantime.

 

Dan

 

happydeadfish
Fanfold Paper
Posts: 18
Registered: ‎06-24-2013
Location: CA
Views: 43
Message 4 of 4

Re: X1 Carbon 6th Gen with 40AH Dock Fault After Firmware Upgrade (2 Examples)

I have the same issue (TB3 monitors blanking) - but both of mine are DP - so should not have audio - I'll double check when back at the office.

 

My device is the lastest X1 yoga.

 

Since the update, I'm also getting my home dock issues.

 

(2 X P24h monitors - 1 connected USB-C, second connected USB3 -DP on the back of the first monitor) 

 

It's now complaining that the USB port has a power surge - a device exceeds power limits. (and I have to run the 2nd monitor off the Laptop's USB3 port)

 

Both setups worked great for months.  They also both still work with my previous Yoga (I still have it as a spare).

 

Interesting thing is, I run 4 monitors at the office.  2 native off the TB3 dock, and 2 DP off a monoprice USB3 to dual DP.  When the flashing is happening, the 2 Monopirce monitors are both fine.   Makes me think it's an MST issue.

 

Makes me wonder what is going on with Lenovo quality ctrl - when something as simple as external monitors is broken by an update.

 

 

 

 

Check out current deals!


Shop current deals

Top Kudoed Authors