English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

2 Posts

09-03-2019

US

6 Signins

110 Page Views

  • Posts: 2
  • Registered: ‎09-03-2019
  • Location: US
  • Views: 110
  • Message 1 of 1

X1 Carbon 7 Gen (20QD) no ethernet w/ 40AS (ThinkPad USB-C dock) | Portable USB-C non-functional

2019-09-05, 13:36 PM

We recently purchased three of these for our team. They do not work with USB-C portable drives or with the Thunderbolt Dock. I first tired these with a 40A9 dock as CDW stated it was compatible. Since that didn't work, we tested with the Gen 2 docks which Lenovo stated were compatible. 

 

I have tried to reimage the machine, reinstall drivers, tried other cables, laptops, and attempting to change settings in the BIOS like Thunderbolt security. Nothing has worked to allow us to use the docks ethernet. It's just not seen by the system. I have gotten it working sans drivers with the 40AJ docking station. I know this docking station is listed as working with Gen 7 so it should work. I can locate plenty of guides on how to configure the BIOS for this dock. 

 

Any help would be appreciated. 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save