Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

1 Posts

12-07-2020

Costa Rica

1 Signins

20 Page Views

  • Posts: 1
  • Registered: ‎12-07-2020
  • Location: Costa Rica
  • Views: 20
  • Message 1 of 2

X1 Carbon 7th (20R1) Preboot Fingerprint Authentication not working after BIOS and FP driver update

2020-12-07, 8:12 AM
Hello,
Recently updated my X1 Carbon 7th (20R1)'s BIOS and fingerprint reader drivers to the following.BIOS: Thinkpad BIOS Update - 10 [64] -1.30
Fingerprint Driver: Synaptics Prometheus MIS Touch Fingerprint Reader Driver (Windows 10 Version 1809 or later) - 10 [64] - 6.0.46.1105

Used to have Preboot (pre-desktop) fingerprint authentication activated.

Once I updated said BIOS and driver, the time between the Lenovo logo appeared and the preboot FP scan request became very long (around 45 seconds or more). Before the update, this took around 1-2 seconds.
Also, even though the a FP scan request appeared on screen, the FP reader did nothing. Instead, I was forced to press ESC and type in my PIN number.
Already tried to roll back the driver and also resetting FP data from BIOS and also from within Windows and then reactivating everything.
In fact, when I tried to setup the preboot FP scan from the BIOS and rebooted, the laptop got stucked in a black screen after it displayed the Lenovo Logo. Nothing worked: no BIOS, no booting sequence, no diagnostics, (F1, F2, F3, ... F#, etc...)
Because of this, I had to open the laptop and physically disconnect the FP reader, thus forcing the system to ask me my PIN and then turning off the predesktop FP authentication.
BTW, fingerprint scanner works fine with Windows 10 Hello.
So far, I've had no luck in making the FP reader work for the preboot (predesktop) authentication.

Any help is highly appreciated!
Reply
Options

1 Posts

12-20-2020

United States of America

1 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎12-20-2020
  • Location: United States of America
  • Views: 0
  • Message 2 of 2

Re:X1 Carbon 7th (20R1) Preboot Fingerprint Authentication not working after BIOS and FP driver update

2020-12-20, 17:56 PM

Same problem here. Would appreciate a solution.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms