cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Lenovo Employee AmyYu
Lenovo Employee
Posts: 50
Registered: ‎09-23-2017
Location: CN
Views: 341
Message 51 of 61

Re: X1 Carbon 7th Gen sound card can't start

I wil feedback to the owner, it need time to know why you cannot capture logs.

Also, I would like to make sure, whether you experiencing “any”(slow boot, error after you see the Lenovo Logo, etc.) at system boot?

Johor
Punch Card
Posts: 39
Registered: ‎07-09-2019
Location: DE
Views: 336
Message 52 of 61

Re: X1 Carbon 7th Gen sound card can't start

 wrote:

I wil feedback to the owner, it need time to know why you cannot capture logs.

Also, I would like to make sure, whether you experiencing “any”(slow boot, error after you see the Lenovo Logo, etc.) at system boot?


I see no error after I see the Lenovo logo when I boot the machine. I find the booting a little slow but have nothing to compare with. I was expecting a faster boot, I come from a 2 years old Surface Pro and it fellt a little faster. Nothing too concrete though.

 

Any idea how to make the command to manually update the MEFW? You can see in the screenshot that it is downloaded, unpackaged. and checking the firmware when run. Then it says it can't find the file, but the file is there...

Firmware error.png

Lenovo Employee AmyYu
Lenovo Employee
Posts: 50
Registered: ‎09-23-2017
Location: CN
Views: 332
Message 53 of 61

Re: X1 Carbon 7th Gen sound card can't start

Please download from below LENOVO SUPPORT webpage and install the .exe file diretly.

https://pcsupport.lenovo.com/jp/en/products/LAPTOPS-AND-NETBOOKS/THINKPAD-X-SERIES-LAPTOPS/THINKPAD-...

Johor
Punch Card
Posts: 39
Registered: ‎07-09-2019
Location: DE
Views: 323
Message 54 of 61

Re: X1 Carbon 7th Gen sound card can't start


@AmyYu wrote:

Please download from below LENOVO SUPPORT webpage and install the .exe file diretly.

https://pcsupport.lenovo.com/jp/en/products/LAPTOPS-AND-NETBOOKS/THINKPAD-X-SERIES-LAPTOPS/THINKPAD-...


That's the same link as before. You were suggesting that I had to install it manually with the command prompt. Is it really the same to install it from the .exe file directly? 

Lenovo Employee AmyYu
Lenovo Employee
Posts: 50
Registered: ‎09-23-2017
Location: CN
Views: 319
Message 55 of 61

Re: X1 Carbon 7th Gen sound card can't start

yes, please have a try. We can install it successfully on our test machine.

Highlighted
Lenovo Employee AmyYu
Lenovo Employee
Posts: 50
Registered: ‎09-23-2017
Location: CN
Views: 318
Message 56 of 61

Re: X1 Carbon 7th Gen sound card can't start

Steps to recover:

    *this assumes that customer’s system is vPro since Intel AMT was shown on the BIOS setup.

Download MEFW package. (link)

Execute/Double-click package(n2hrg20w.exe) and click Next > Next.

Take note of the path to where the MEFW package is extracted:

1.jpg

Click Next > Click “Install”

Untick the checkbox and click “Finish”

3.jpg

Open Powershell with Admin rights(Shortcut Window + X + A).

Navigate to where MEFW package was extracted on Step #3.

Execute command as shown below:

6.jpg

Press “Enter” button and MEFW update should execute normally.

After update. Restart system.

At restart, please check BIOS Menu(F1) and confirm if MEFW version is displayed correctly

Boot to OS, check if YB has disappeared.

 

No need to perform other recovery procedures(ex. Shutdown, G3 and Remove/reattach Coin battery).

Johor
Punch Card
Posts: 39
Registered: ‎07-09-2019
Location: DE
Views: 304
Message 57 of 61

Re: X1 Carbon 7th Gen sound card can't start


@AmyYu wrote:

Steps to recover:

    *this assumes that customer’s system is vPro since Intel AMT was shown on the BIOS setup.

Download MEFW package. (link)

Execute/Double-click package(n2hrg20w.exe) and click Next > Next.

Take note of the path to where the MEFW package is extracted:

1.jpg

Click Next > Click “Install”

Untick the checkbox and click “Finish”

3.jpg

Open Powershell with Admin rights(Shortcut Window + X + A).

Navigate to where MEFW package was extracted on Step #3.

Execute command as shown below:

6.jpg

Press “Enter” button and MEFW update should execute normally.

After update. Restart system.

At restart, please check BIOS Menu(F1) and confirm if MEFW version is displayed correctly

Boot to OS, check if YB has disappeared.

 

No need to perform other recovery procedures(ex. Shutdown, G3 and Remove/reattach Coin battery).


This worked! I followed these instructions, restarted and saw in the BIOS that the ME line had a driver version indicatied. I rebooted, and no YB in the device manager, the microphone array is recognized in the Settings, the Intel Smart Technology is present in the Device Manager under Sounds, video and game controllers and I tested recording audio and playing back in my preferred audio software.

 

Wow, this has been a long ride! I'm very grateful for your consistent willingness to help, I almost lost hope at many corners and felt we were going in circles but feel thankful that I don't have to bring the machine to the Lenovo service center and can now enjoy a fully working system.

 

FYI, the problem appeared as I first got the machine and ran updates. If I remember well, I first went to Lenovo Vantage and trigerred to perform all updates available, then while these updates were either downloaded or installed, I went to Windows updates and did the same.

 

I then realized it wasn't too smart but it was too late. I didn't see any error message or such but the problem started. No amount of Windows re-installing from scratch helped the problem!

 

I indicate all that in case your team would want to try and reproduce the issue. Again:

- On a machine out of the assembly line, open Vantage, select all available updates and start the download/install process

- Directly go to Window Updates and check for updates, let Windows download and install them, without waiting for vantage to be done.

 

It might be only occuring if things happen in a very specific sequence time-wise but may be you can reproduce it.

 

Thanks again a lot!!!!

Lenovo Employee AmyYu
Lenovo Employee
Posts: 50
Registered: ‎09-23-2017
Location: CN
Views: 255
Message 58 of 61

Re: X1 Carbon 7th Gen sound card can't start

I am very happe for your recognization. Really feel happy for you to have a fully working system now.

 

And about your reproduce steps, we will try more times and check how to avoid this problem to disturb the customer's macine.

 

Have a good journey with your new PC, any problems you can contact with us!

 

Thank you~

Forke24x7
Paper Tape
Posts: 2
Registered: ‎08-20-2019
Location: DE
Views: 210
Message 59 of 61

Re: X1 Carbon 7th Gen sound card can't start

Hi,

 

I've got the exact same problems, but with a X1 Carbon G6. Your solution seems to work only for G7, installation of ME 12.0 fails for my G6 with "unsuppported Hardware Platform". 

 

Can you provide ME 12.0 Firmware for X1 Carbon G6 (20KH) to fix my audio? 

Justin111
Fanfold Paper
Posts: 5
Registered: ‎07-24-2019
Location: US
Views: 173
Message 60 of 61

Re: X1 Carbon 7th Gen sound card can't start

Hi Amy, 

 

I have similiar problem. When I tried your fix, I got the following error message:

 

Error 366: Failed to verify signature of OEM or RoT key manifests. For example: Error on update from Prodution to Pre-Production.

 

Your help is greately appreciated. 

 

Check out current deals!


Shop current deals

Top Kudoed Authors