cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jkueng
Paper Tape
Posts: 5
Registered: ‎03-14-2014
Location: Switzerland
Views: 4,616
Message 11 of 21

Re: X1 Carbon - Driver Sierra Wireless EM7345 ?

yes, in the meantime you can download it also from the lenovo page ... but at the time where I created this thread, there was no driver on the lenovo page ...

 

but problem is solved, thread can be closed.

chang_ga
Paper Tape
Posts: 2
Registered: ‎04-07-2014
Location: Germany
Views: 4,541
Message 12 of 21

Re: X1 Carbon - Driver Sierra Wireless EM7345 ?

I have a x240 with the same WWAN card. I have problems with LTE connections on a T-Mobile contract. As long as I only connect to UMTS or EDGE every thing works well. As soon as the Notebook finds a LTE connection, it drops the connect. My OS is Windows 8.1. Newest drivers are installt. I also tested a Vodafone card and it worked very well. Do others have a similar experience or a solution?

Community SeniorMod
Community SeniorMod
Posts: 11,941
Registered: ‎06-06-2011
Location: RU
Views: 4,529
Message 13 of 21

Re: X1 Carbon - Driver Sierra Wireless EM7345 ?

chang_ga,

it seems modem is in Automatic selection network mode. You need to switch this mode in LTE one only or in combined GSM+UMTS+LTE mode. Thanks m$ and Lenovo win8 users are not able to switch network type w/o tweaks, just using an app with friendly GUI.

Unpack driver package and cancel its installation. Look into configuration.ini file. What does it include?

The next steps will be:
- reinstall driver with USB composition that'll enable new dignostic port;
- switch network mode using AT terminal command.



x220 • Gobi 2000 3g | hdd, msata ssd, wwan, wifi, gps -- unique hand-made config
ThinkPad 25 Special Anniversary Edition. #retro. Signed by D.Hill
T470p | X1 Carbon Gen3 | Miix 2 10" | Yoga Tablet 2-1050F (Android) + BT Keyboard
ThinkPad Stack • 2.4/5 Wireless Router, HDD 1 TB, BT Speaker, Power Bank, Mobile Projector

Do it well, worse becomes itself

Communities:   English    Deutsche    Español    Portugues    Русскоязычное    Česká    Slovenská    Українська   Moto English

Xlunatic
Paper Tape
Posts: 4
Registered: ‎04-08-2014
Location: Germany
Views: 4,499
Message 14 of 21

Re: X1 Carbon - Driver Sierra Wireless EM7345 ?

Hi, I have a new x1 carbon with the same WWAN card using Win 8.1. Same problems with LTE using T-Mobile. Newest drivers as recommended are installed as well. What i noticed, there seem to be still some problems with the driver for the EM7345. The connection (LTE or UTMS) will be dropped after a few seconds as well. I checked the IPv4-Settings after the drop and you will notice that the DNS records are set with a defined IP ?!? and the IP-Adress radio button is set to "use defined IP adress" but no ip adress is filled in. I also talked to T-Mobile and this should be the problem. When you change the values back to automatic DNS and IP and reconnect to WWAN, connection is dropped again and setting are switched back as described. This can't be right. Anyone has an idea?

Xlunatic
Paper Tape
Posts: 4
Registered: ‎04-08-2014
Location: Germany
Views: 4,469
Message 15 of 21

Re: X1 Carbon - Driver Sierra Wireless EM7345 ?

Update for Driver EM7345 won't solve the problem....


@Xlunatic wrote:

Hi, I have a new x1 carbon with the same WWAN card using Win 8.1. Same problems with LTE using T-Mobile. Newest drivers as recommended are installed as well. What i noticed, there seem to be still some problems with the driver for the EM7345. The connection (LTE or UTMS) will be dropped after a few seconds as well. I checked the IPv4-Settings after the drop and you will notice that the DNS records are set with a defined IP ?!? and the IP-Adress radio button is set to "use defined IP adress" but no ip adress is filled in. I also talked to T-Mobile and this should be the problem. When you change the values back to automatic DNS and IP and reconnect to WWAN, connection is dropped again and setting are switched back as described. This can't be right. Anyone has an idea?


 

 

Xlunatic
Paper Tape
Posts: 4
Registered: ‎04-08-2014
Location: Germany
Views: 4,467
Message 16 of 21

Re: X1 Carbon - Driver Sierra Wireless EM7345 ?

Did you find a solution for your problem? I have exactly the same problem you mentioned

chang_ga
Paper Tape
Posts: 2
Registered: ‎04-07-2014
Location: Germany
Views: 4,442
Message 17 of 21

Re: X1 Carbon - Driver Sierra Wireless EM7345 ?

Hi Xlunatic!

No, I do not have a solution right now. Today I installed Win 7 on my x240. So far I can connect to T-Mobile via Lenovo Access Software. The details page shows a HSDPA connection and worked quite well. Tomorrow I will check a place where LTE is availabel for sure.

 

@x220forMe: There is no configuration.ini file. Please give more information about installing the driver in USB composition. Everytime whene I try to uninstall the device it'll be reinstalled after device manager recognice it.

Highlighted
technomorph
Paper Tape
Posts: 11
Registered: ‎10-15-2014
Location: Germany
Views: 3,675
Message 18 of 21

Re: X1 Carbon - Driver Sierra Wireless EM7345 ?

I'm about to test what was posted in a German forum: Install Access Connection from Windows 7 on Windows 8.1. Here's the original thread: https://forum.telekom.de/foren/read/service/mobile-nutzung/mobiles-internet/verbindungstrennung-kurz...

Once I know if it works, I'll let you know.

Xlunatic
Paper Tape
Posts: 4
Registered: ‎04-08-2014
Location: Germany
Views: 3,673
Message 19 of 21

Re: X1 Carbon - Driver Sierra Wireless EM7345 ?

it works, using it for a couple of month now..

technomorph
Paper Tape
Posts: 11
Registered: ‎10-15-2014
Location: Germany
Views: 3,671
Message 20 of 21

Re: X1 Carbon - Driver Sierra Wireless EM7345 ?

Hey Lenovo!!! What's your answer on this!

Is that really what you want? Users spoiling their clean Windows 8.1 network stack which is capable of LTE natively with some unneccessary, crappy 3rd party software that isn't designed for the OS?

Thanks,

Jürgen

Check out current deals!


Shop current deals

Top Kudoed Authors