cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
B_Banner
Fanfold Paper
Posts: 26
Registered: ‎05-10-2016
Location: US
Views: 9,772
Message 1 of 58

X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

Sometimes when I connect the Onelink connector from the Onelink+ dock, the ethernet port is not detected.  The monitor shows up and usb ports function but there is no local area connection listed in the netword adapters.  If I disconnect the Onelink connector from the X1 and reconnect it, then suddenly the local area connection shows up and is there until the next time I redock the Onelink+.  

 

Is this a known bug?  Anyone else having this problem?

 

This is on Windows 7 x64 with all the latest drivers installed from the Lenovo website.

B_Banner
Fanfold Paper
Posts: 26
Registered: ‎05-10-2016
Location: US
Views: 9,708
Message 2 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

Anyone else having this problem?  It looks like I'll have to use a USB-to-Ethernet adapter instead when on the dock.

Highlighted
bradhi
Paper Tape
Posts: 9
Registered: ‎05-12-2016
Location: NZ
Views: 9,699
Message 3 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

Yes, we have just received several Carbon Gen 4 laptops and OneLink+ docks.  And the three of us that are currently using them (on Win 8.1 64-bit), we are randomely having the LAN cable stop being detected in the Network port on the dock.

It seems to sometimes work again if you pull every single cable out of the back of the dock (including power), and then plug everything back in again.

 

But I would like to find a permanent fix for this...

B_Banner
Fanfold Paper
Posts: 26
Registered: ‎05-10-2016
Location: US
Views: 9,696
Message 4 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised


@bradhi wrote:

Yes, we have just received several Carbon Gen 4 laptops and OneLink+ docks.  And the three of us that are currently using them (on Win 8.1 64-bit), we are randomely having the LAN cable stop being detected in the Network port on the dock.

It seems to sometimes work again if you pull every single cable out of the back of the dock (including power), and then plug everything back in again.

 

But I would like to find a permanent fix for this...


Glad I'm not alone on this.  I wonder if there's some power options that are causing the port to sleep?

Rg7
Ctrl-Alt-Del
Posts: 10
Registered: ‎07-09-2014
Location: SG
Views: 9,658
Message 5 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

I have the X1 Carbon Gen 3 and the basic OneLink dock. Bios and all drivers up to date except I completely removed the OneLink Dock driver because I got way crazier and unmanageable responses with it. I know there is an updated version but at this point I'm loathe to try it.

 

I've learnt to plug in the dock THEN power on my X1. Even then, sometimes the ports (ethernet and / or USB) aren't working even though the HDMI connected monitor works. I have no option but to restart the X1 (while leaving it plugged into the dock). Then everything works. 

 

 

HTH

bradhi
Paper Tape
Posts: 9
Registered: ‎05-12-2016
Location: NZ
Views: 9,656
Message 6 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

I don't believe it is a sleep issue in my case.  I've been working ok for two days under this scenario:

- Bring laptop in powered off

- Plug in dock and turn on laptop

- Ethernet connectivity through dock appears ok while I stay like this

 

However if we undock during the day with the laptop remaining powered on, then bring it back to dock we get this (verified on two Carbon's):

- Limited to WiFi with Ethernet cable not being detected

- In order to restore LAN connectivity we have to do the following

    - unplug the power and both display port video cables (can leave the laptop on and connected to the dock)

    - Give it 10 secs, then plug the Dock power back in followed by the two display port cables

    - LAN connectivity magically comes back

 

 

ericsc00
Paper Tape
Posts: 1
Registered: ‎06-07-2016
Location: US
Views: 9,537
Message 7 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

Seeing the same thing, 4th gen X1 and OneLink+ - Win7 sp1 32bit

Just deployed 40+ of these, we are able to do as described above to fix - either unplug the power to the dock and plug back in or unplug the dock from the X1 and plug back in 

Hopefully a real fix soon.....

B_Banner
Fanfold Paper
Posts: 26
Registered: ‎05-10-2016
Location: US
Views: 9,534
Message 8 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

Is there an e-mail address we should be reporting this too so we know Lenovo is officially aware of the problem?  This also seems to be affecting Wi-Fi too now.  I just had a user that was getting a yellow exclamation mark over the Wi-Fi taskbar tray icon and to fix it, the laptop had to be disconnected from the dock, disconnected and reconnected to the Wi-Fi, and then reconnected to the dock.  The wired dock ethernet wasn't working at this time either.  Both Wi-Fi and ethernet resolved after redocking.

Whalan
What's DOS?
Posts: 1
Registered: ‎06-07-2016
Location: AU
Views: 9,508
Message 9 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

I have the same problem with my OneLink+ to VGA/RJ45 adapter. VGA works fine, but no matter what I do, I can't get the ethernet port to actually work. I'm on Win10Pro

justinaltman
Fanfold Paper
Posts: 19
Registered: ‎04-24-2016
Location: US
Views: 9,398
Message 10 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

I am having the same issue with a X1 Yoga with OneLink+ Dock.  I am on my second dock with intermittent wired network access.  Have not been able to use network port on dock for weeks now and have been using a dongle.  Tried suggestion about unplugging all cables for 10 seconds, and working now.  Must be a known bug, but no one at Lenovo seems to want to address it.  Even looking at the buyers reviews on this dock, it is getting pounded for these issues.  

 

Where is the support??  I paid $180 for something that I have to jury rig to get to work correctly.

Check out current deals!


Shop current deals

Top Kudoed Authors