cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Former Employee
Posts: 1,664
Registered: ‎09-16-2014
Location: US
Views: 3,931
Message 41 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

In response to customer reports that when X1 Carbon ThinkPads (Type: 20FB and 20FB) running Windows 7 are docked via a OneLink+ Dock, ethernet does not function, Lenovo has released a solution via updated USB 3.0 driver.

 

Version 4.0.6.60

(Fix) Fixed an issue where the USB-Ethernet device in Onelink+ dock was unstable while attaching the dock.

 

The latest USB 3.0 Driver can be downloaded here: http://support.lenovo.com/us/en/downloads/ds111779

 

Thank you,

justinaltman
Fanfold Paper
Posts: 19
Registered: ‎04-24-2016
Location: US
Views: 3,919
Message 42 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

Does this update cover Windows 10 also?  I know it is listed as a Windows 7 driver.

bradhi
Paper Tape
Posts: 9
Registered: ‎05-12-2016
Location: NZ
Views: 3,915
Message 43 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

Hi Amy,

So is Lenovo just ignoring the fact you have multiple other reports for users running Windows 10 and Windows 8.1 that are experiencing the exact same issue?!

 

The fact that you private messaged me to get more info about my Windows 8.1 computers with the issue and then you come back here with a Windows 7 update and mark that as the answer to this thread, seems like you have completely ignored me.

 

I have 6 Lenovo X1 Carbon G4's (Windows 8.1) with this dock that all have this exact same issue.  It is NOT just confined to Windows 7.

justinaltman
Fanfold Paper
Posts: 19
Registered: ‎04-24-2016
Location: US
Views: 3,851
Message 44 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

Please unmark this as solved as it is not. For those of us NOT on Windows 7, we have seen no solution yet.
Community SeniorMod
Community SeniorMod
Posts: 3,976
Registered: ‎01-21-2010
Location: US
Views: 3,824
Message 45 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

The original post in this thread is in regards to Windows 7, that is why this thread was marked solved.

 

If you have the same problem with another operating system, I would suggest that you open a new thread referring to the same problem with your current operating system.

 

A different operating system will most likely require a different solution.

 

Regards,

Dave 


Community GuidelinesSearchPrivate MessagingENDEESPTRUUACZ-SKMoto
PM requests for individual support are not answered. If a post solves your issue, please mark it so.
Highlighted
justinaltman
Fanfold Paper
Posts: 19
Registered: ‎04-24-2016
Location: US
Views: 3,812
Message 46 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

Will do.  Since Amy_Lenovo had private messaged me and posted about the question of whether this was affecting only Windows 7 users back on July 7th and several people have posted and PM her to let her know this is not the case, that Lenovo was aware of the situation with other OS that are affected.  I hate I have been waiting patiently for almost 2 months for a solution to a problem that Lenovo is not aware exists even though if you read the post, it certainly does.  I will create a new post for my machine running Windows 10 Pro.  I guess the users on Windows 8.1 that are experiencing the same issue will need to make their own posts also.

Community SeniorMod
Community SeniorMod
Posts: 3,976
Registered: ‎01-21-2010
Location: US
Views: 3,801
Message 47 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

Thank you,

 

When I see the new thread, I will remove these posts from this thread.  That way, we can keep the issues separate.

 

Dave


Community GuidelinesSearchPrivate MessagingENDEESPTRUUACZ-SKMoto
PM requests for individual support are not answered. If a post solves your issue, please mark it so.
bradhi
Paper Tape
Posts: 9
Registered: ‎05-12-2016
Location: NZ
Views: 3,784
Message 48 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

I'm sorry, but I find that a little bit silly.  This forum is not grouped by OS, nor does the title of this thread indicate a particualar OS Version.  Yes the first person indicated Windows 7.  But then straight away other also added that it affected other version of Windows indicating there is an MAJOR Windows driver issue for this dock (irrelevant of version).

We now have a good thread going with a lot of traction (e.g. views / comments), which could easily become the place to go for others who have a similar issue in the future.  Wouldn't it be great to have a one stop reference that has links to fixes for all OS version that use this dock?!  Now we are being told to seperate out into other "mini" threads that will probably get ignored and end up at the bottom of the forum with hardly any views.

 

I guess I will have to create my own thread for Windows 8.1...but to be left hanging for several months....and now have to start a brand new thread just seems crazy.

I am the decesion maker on hardware for a company residing in both Aus and NZ....and this is starting to affect my thoughts on purchasing Lenovo hardware going foward.

 

David_J_W
802.11n
Posts: 118
Registered: ‎05-22-2016
Location: GB
Views: 3,766
Message 49 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

Your frustration is understandable - and I'm sure I'd be frustrated in your position.

 

I just wanted to observe that there appears to be a complex and somewhat subtle interoperability issue here involving USB, power management and the vast array of Ethernet switches used by customers. Some users have huge problems, whilst others, including me, have none. The supposed fix for Windows 7 involves both new drivers for the Ethernet device in the dock and new USB 3.0 controller drivers. Versions of Windows after Windows 7 use a Microsoft drivers for the USB 3.0 controller, so these later OSes probably should be thought of as having a related but separate issue.

 

The forum software is limited to allowing only one solution per thread. Hopefully, a new thread referenced on the end of this one will provide a place for customers to explore the issues whilst Lenovo keep working on it - as they seem willing to do, irrespective of any further forum posts.

bradhi
Paper Tape
Posts: 9
Registered: ‎05-12-2016
Location: NZ
Views: 3,754
Message 50 of 58

Re: X1 Carbon (Gen 4) + Onelink+ Dock - Ethernet Sometimes not recognised

Yes I understand where you are coming from. 

 

My frustration stems mainly from the fact that "Amy_Lenovo" private messaged me for more info about my computers running Windows 8.1 back on the 11th of July.  I then wait almost two months seeing updates like "updated driver to fix issue being worked on", leading myself (and probably others) to believe that a fix was being looked at for our issues as well....and then a specific Windows 7 driver is posted and nothing else.

 

If I had been told back them I needed to start a new thread to get a Windows 8.1 issue logged....I probably wouldn't be quite so annoyed. 

Check out current deals!


Shop current deals

Top Kudoed Authors