English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

14 Posts

10-19-2011

US

881 Signins

3110 Page Views

  • Posts: 14
  • Registered: ‎10-19-2011
  • Location: US
  • Views: 3110
  • Message 1 of 1

X1 Carbon Gen 7 PXE Boot UEFI Issues

2019-10-23, 17:35 PM

I have several X1 laptops that I am trying to PXE boot via WDS on a Win 2016 server. If I switch them over to legacy boot I can get the whole process to finish and image my new laptops. If I leave the laptops in UEFI then I get stalled out after the "Loading Files" Boot.wim completes with a black screen. I have tried turning off option 067 as seen here:   https://support.microsoft.com/en-ae/help/2012858/black-screen-or-trap-error-when-booting-efi-pxe-cli... but that didn't do anything. I've tried setting up policies to distinguish between x64 and x86 in DHCP and that didn't work.

 

This only affects my lenovo laptops in UEFI. Switching them manually over to legacy BIOS isn't ideal. Any ideas how I can get these devices to PXE boot out of the box withouth having to switch off secure boot? Do I just have to turn off Secure Boot in order to make this work?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save