Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

3 Posts

11-24-2021

Canada

2 Signins

25 Page Views

  • Posts: 3
  • Registered: ‎11-24-2021
  • Location: Canada
  • Views: 25
  • Message 1 of 5

X1 Carbon Gen 9 Windows Hello Issues

2021-11-24, 23:53 PM

Hi there,

 

I've encountered an issue that I'm wondering if anyone can provide a solution to.

 

I've found some strange behaviour with trying to set up Windows Hello Face on my X1 Carbon Gen 9.

 

On my initial Windows 10 install, with completely updated Lenovo drivers (through Commercial Vantage) and Windows Updates, I found that when I was attempting to set up Windows Hello Face, the first part of the setup would work fine - the camera would pop up, the square would show that the IR camera was reading.  However, partway through, the camera image would 'freeze', and then the entire setup would hang.  The "Windows Hello Setup" would remain active, but with no progress.  The process would need to be forcefully ended in order for Windows to allow me to continue using it.

 

I tried uninstalling and re-searching the camera and IR device in device manager with no fix for the issue.  I tried removing the Windows Hello Face Detection Device from the device manager in the hope of trying to reinstall it, but this was a big mistake - it permanently disabled my Windows Hello camera function.

 

At this point, I clean formatted and reinstalled Windows 10.  Interestingly, when setting up Windows fresh, I was able to complete all the steps for Windows Hello Face without any issues.  The camera did not exhibit the 'freezing' behaviour partway through the setup, and the setup itself did not hang, and completed fully.  Note that this was done with the laptop disconnected from the internet, so none of the Windows updates or Lenovo updates had been installed yet.

 

I then installed all of the critical and suggested Lenovo updates through a fresh install of Commercial Vantage.  At this point, I tried to "improve recognition" which starts a new Windows Hello setup process, and subsequently encountered the same initial issues of the camera freezing halfway, and then the entire setup hanging / freezing until forcefully ended through process manager.

 

This leads me to believe that there may be some sort of issue with one of the updates installed by Commercial Vantage.  I am curious as to if anyone else has had this issue, and/or any other suggestions on how to get Windows Hello Face setup working correctly.

 

I've attached the list of installed updates to this post.

 

Thanks in advance!

 

 

Reply
Options

3 Posts

11-24-2021

Canada

2 Signins

25 Page Views

  • Posts: 3
  • Registered: ‎11-24-2021
  • Location: Canada
  • Views: 25
  • Message 2 of 5

Re:X1 Carbon Gen 9 Windows Hello Issues

2021-11-25, 9:29 AM

I've narrowed down the issue - after yet another clean install - to the Intel XE drivers.

 

The default driver version installed with Windows and after Windows Update works fine - 27.20.100.9749 (2021-06-24).

 

However, the newer version installed by Commercial Vantage (30.0.100.9955 - 2021/10/21) as well as the latest DCH driver on the Intel website itself (30.0.101.1069 - 11/11/2021) cause Windows Hello Face setup to hang as described.

 

Is this an issue that could be be reported to the Lenovo team as well as the Intel driver team?

 

Hopefully this information helps others.  I'd be curious to know if anyone else has run into issues with the Windows Hello Face setup with the newer Intel XE drivers installed.

Reply
Options

4182 Posts

01-08-2021

Philippines

326 Signins

20750 Page Views

  • Posts: 4182
  • Registered: ‎01-08-2021
  • Location: Philippines
  • Views: 20750
  • Message 3 of 5

Re:X1 Carbon Gen 9 Windows Hello Issues

2021-11-25, 17:33 PM

Hello Borborygmi,

 


Welcome to Lenovo Community

 

 

I'm sorry to read that you're having Windows Hello issues.
Just to confirm, if you rolled back the Intel XE driver to 27.20.100.9749 (2021-06-24) version and tested the Windows Hello face, it works, right?
When you update the Intel driver to the latest version 30.0.100.9955, did you also update all other available components from the support site?
Update us soon as convenient.

 


Regards, 
Lorenzo_Lenovo



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

3 Posts

11-24-2021

Canada

2 Signins

25 Page Views

  • Posts: 3
  • Registered: ‎11-24-2021
  • Location: Canada
  • Views: 25
  • Message 4 of 5

Re:X1 Carbon Gen 9 Windows Hello Issues

2021-11-25, 19:03 PM

Hi Lorenzo,

 

That is correct - Windows Hello Face setup works correctly on 27.20.100.9749 (2021-06-24)

 

I just double checked and can confirm that all other components are up to date, both by running installers and cross checking the firmware versions.


It appears that sometimes if the process hangs and then you force end on the newer drivers, Windows will still have processed the face information (evidenced by the replacement of "Set up" with "Improve recognition").  There just seems to be some sort of issue between the newer Iris Xe drivers and the Windows Hello Face setup itself.

 

Thanks for your help.

Reply
Options

4182 Posts

01-08-2021

Philippines

326 Signins

20750 Page Views

  • Posts: 4182
  • Registered: ‎01-08-2021
  • Location: Philippines
  • Views: 20750
  • Message 5 of 5

Re:X1 Carbon Gen 9 Windows Hello Issues

2021-11-26, 16:50 PM

Thank you for confirming.
While I further check on this, please do keep us posted for any progress.

 


Regards, 
Lorenzo_Lenovo



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms