English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

2 Posts

09-15-2012

United States

1 Signins

6 Page Views

  • Posts: 2
  • Registered: ‎09-15-2012
  • Location: United States
  • Views: 6
  • Message 1 of 7

X1 Carbon drivers missing for 3 devices

2012-09-15, 18:14 PM

Was doing a clean Win7x64 Pro install on the X1C, everything went reasonably smooth, ThinkVantage System Update is a big help with getting the bulk of the drivers installed, but it left out 3 devices:

 

- Fingerprint reader (not even listed in the driver download section of the support site for X1C, had to grab a drvier from a T430)

- ACPI\INT33A0 (no idea what it is)

PCI\VEN_8086&DEV_1E31&SUBSYS_21F917AA (Listed as USB Controller in the Device Manager)

 

Help?

Reply
Options

5629 Posts

06-27-2008

US

28498 Signins

1628217 Page Views

  • Posts: 5629
  • Registered: ‎06-27-2008
  • Location: US
  • Views: 1628217
  • Message 2 of 7

Re: X1 Carbon drivers missing for 3 devices

2012-09-15, 18:52 PM

'afternoon.

welcome to the community!

 

can't help much with the FPR. i've also noticed that there's no entry for it in the X1C's driver matrix here:

http://support.lenovo.com/en_US/research/hints-or-tips/detail.page?&DocID=HT074689

does the FPR work using the T430 driver/app package?

 

ACPI\INT33A0 should be this: Intel(R) Smart Connect Technology Device

probable driver: http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS030704

not exactly sure what it does.

 

PCI\VEN_8086&DEV_1E31&SUBSYS_21F917AA should be this:

0x1e31        Intel USB 3.0 eXtensible Host Controller    0x8086        Intel Corporation

probable driver: http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS029044

 

hth.


Community GuidelinesSearchPrivate MessagingENDEESPTRUUACZ-SKTRMoto
PM requests for individual support are not answered. If a post solves your issue, please mark it so.

I am not a Lenovo employee

Reply
Options

190 Posts

08-23-2012

US

400 Signins

2801 Page Views

  • Posts: 190
  • Registered: ‎08-23-2012
  • Location: US
  • Views: 2801
  • Message 3 of 7

Just because I'm curious...

2012-09-15, 23:37 PM

Zoltiz, 2 questions:

 

a) Why did you decide to take the time to do a fresh Win 7 install vs keeping the one you received? 

 

My guesses, or reasons why I would do it if I had the courage:

 

1) To get rid of bloatware

2) To know for sure that I don't have malware 

3) To start from a known starting point

4) Because I wanted a different version of Windows than what I ordered

5)      ?

6)      ?

 

 

b) Did the media you used for the installation come from Lenovo?

 

Reply
Options

190 Posts

08-23-2012

US

400 Signins

2801 Page Views

  • Posts: 190
  • Registered: ‎08-23-2012
  • Location: US
  • Views: 2801
  • Message 4 of 7

Because I'm curious, part II

2012-09-15, 23:39 PM

Sarbin, 

 

How did you figure out what you posted, like:

 

"ACPI\INT33A0 should be this: Intel(R) Smart Connect Technology Device"

 

?

Reply
Options

5629 Posts

06-27-2008

US

28498 Signins

1628217 Page Views

  • Posts: 5629
  • Registered: ‎06-27-2008
  • Location: US
  • Views: 1628217
  • Message 5 of 7

Re: Because I'm curious, part II

2012-09-16, 4:33 AM

wrote:

Sarbin, 

 

How did you figure out what you posted, like:

 

"ACPI\INT33A0 should be this: Intel(R) Smart Connect Technology Device"

 

?


awww... you want me to give up secrets? ;)

 

ok...

i googled ACP\INT33A0 :)

 

cheers.

 


Community GuidelinesSearchPrivate MessagingENDEESPTRUUACZ-SKTRMoto
PM requests for individual support are not answered. If a post solves your issue, please mark it so.

I am not a Lenovo employee

Reply
Options

190 Posts

08-23-2012

US

400 Signins

2801 Page Views

  • Posts: 190
  • Registered: ‎08-23-2012
  • Location: US
  • Views: 2801
  • Message 6 of 7

Re: Because I'm curious, part II

2012-09-16, 4:48 AM
Smarty pants! :-)
Reply
Options

5629 Posts

06-27-2008

US

28498 Signins

1628217 Page Views

  • Posts: 5629
  • Registered: ‎06-27-2008
  • Location: US
  • Views: 1628217
  • Message 7 of 7

Re: Because I'm curious, part II

2012-09-16, 4:50 AM

bahaha! :smileylol:

it worked, din't it? ;)


Community GuidelinesSearchPrivate MessagingENDEESPTRUUACZ-SKTRMoto
PM requests for individual support are not answered. If a post solves your issue, please mark it so.

I am not a Lenovo employee

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete