English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

1 Posts

01-17-2017

ZA

9 Signins

67 Page Views

  • Posts: 1
  • Registered: ‎01-17-2017
  • Location: ZA
  • Views: 67
  • Message 1 of 1

X1 Carbon touchpad and trackpad stops working

2017-01-17, 18:21 PM

HI All

 

I am in need of help please i have a X1 Carbon that was Recently purchased for a user at our office.

 

But as you can tell from the subject of this topic the touchpad and trackpad stops working working after a few minutes of working on the machine.

 

 I used Lenovo System Update to update all the drivers to the latest version and this was not successfull, I then tried a reinstall  of windows and the manually downloaded the driver from lenovo website and installed it but still no luck.

 

I have checked and they are not disabled in the Bios and they are not and the Bios is on the latest version

 

I have also tried to let it run on the windows driver that downloads from windows but also it stops working.

 

from what it looks like the trackpoint and touchpad disable cause when i go into the mouse properties the option to enable them both is greyed out i then log on as the local admin to see if it is a permission thing but it is also greyed out.

 

This happens regardless if the machine is on battery or plugged in

This user travels  alot and needs them both to be working.

 

 I came across the below forum but i dont see much of a response from lenovo.

https://forums.lenovo.com/t5/ThinkPad-X-Series-Laptops/X1-Carbon-touchpad-and-trackpad-stops-working/m-p/1485084#M54827

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete