cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
tmj
Blue Screen Again
Posts: 8
Registered: ‎02-02-2017
Location: NO
Views: 2,536
Message 1 of 5

X1 Carbon won't boot when connected to network via OneLink+ dock/ethernet

The problem at hand is well described by another user: http://www.geekzone.co.nz/forums.asp?forumid=66&topicid=181294

 

Problem applies to a brand-new (Jan 2017) ThinkPad X1 Carbon (type 20FB) hooked up to a OneLink+ Dock (part # 40A40090EU). Running Win10 Pro/64. I've got two OneLink+ units, both yield the same result.

 

The laptop will boot just fine when it is not connected to the dock, but when docked, it will not boot past the screen which says "press enter to access BIOS (...)" when the network cable is plugged into the docking station.  It boots just fine when the network cable is not plugged into the rear of the docking station. There's nothing special with the network or cable (works well with a myriad of other laptops) and the ThinkPad in question has the latest & greatest drivers installed.

 

If a docked boot has already taken place, plugging the ethernet cable into the dock works just fine.

 

In essence, the problem exists only when the ethernet cable is plugged in during boot.

 

Does anyone know of a fix?

JDGillis
Bit Torrent
Posts: 3,331
Registered: ‎12-11-2015
Location: US
Views: 2,489
Message 2 of 5

Re: X1 Carbon won't boot when connected to network via OneLink+ dock/ethernet

This appears to have been resolved with a BIOS update for your model that was released 11/16/2016 of this year (See excerpt from readme.txt below), so I would suggest that you update your system's BIOS to the latest, which is now v1.21  and see if the problem goes away.     I would also make sure, if you have not already, that you have the latest driver for the OneLink Dock installed as well, as they may work together to provide the fix.

 

BIOS Update Utility for Windows 10 (64-bit), 8.1 (64-bit), 7 (64-bit, 32-bit) - ThinkPad X1 Carbon (Type 20FB, 20FC), X1 Yoga (Types 20FQ, 20FR)
http://support.lenovo.com/us/en/products/Laptops-and-netbooks/ThinkPad-X-Series-laptops/ThinkPad-X1-...

 

From v.1.21 BIOS Update readme.txt 

  • <1.19> UEFI: 1.19 / ECP: 1.13 - (Fix) Fixed an issue where user might not connect the Ethernet network through ThinkPad OneLink+ Dock.

A forthcoming fix from Lenovo was also mentioned on the last page of the Geekzone post that you cited, so this is probably the fix that was mentioned.

 

Good Luck,

tmj
Blue Screen Again
Posts: 8
Registered: ‎02-02-2017
Location: NO
Views: 2,484
Message 3 of 5

Re: X1 Carbon won't boot when connected to network via OneLink+ dock/ethernet

Thanks, but that won't help.

My system came with BIOS v. 1.21 installed. The update utility available from Lenovo won't even start the installation process as the same version is already installed.

I'll correct my statement from above and rephrase it as "the ThinkPad in question has the latest & greatest BIOS and drivers installed".

 

Please also note that it is not connecting to the network per se which is the problem at hand. The problem is that the boot process halts if the system is switched on or restarted with the ethernet cable plugged into the OneLink+ Dock.

Highlighted
JDGillis
Bit Torrent
Posts: 3,331
Registered: ‎12-11-2015
Location: US
Views: 2,479
Message 4 of 5

Re: X1 Carbon won't boot when connected to network via OneLink+ dock/ethernet

Bummer,

 

It does appear from the readme that Lenovo knew of the problem that you are experiencing, but has yet to properly fix it, so hopefully someone from Lenovo engineering will chime in to your post, as I doubt Lenovo support itself will support will be able to provide much help unless they can escalate the matter up the food chain..

 

The only workaround, which was mentioned in the Geekzone post you cited, was to disable secure boot, which in my opinion is not a good workaround since it entails disabling an important security feature.

 

Good luck,

tmj
Blue Screen Again
Posts: 8
Registered: ‎02-02-2017
Location: NO
Views: 2,472
Message 5 of 5

Re: X1 Carbon won't boot when connected to network via OneLink+ dock/ethernet

Thanks again.

 

I totally agree with you - disabling this security feature may be a workaround, but not a proper solution.

 

I've got three of these OneLink+ Docks around (home, office, office) as they're supposed to offer a trouble-free docking solution. In one of the office locations I'm stuck with cabled/ethernet network connectivity and I find it rather annoying to pull out the ethernet cable before booting the system. I'm puzzled to find this problem in a Lenovo system.

 

And we're back...

Move delayed but still coming

Learn More

Check out current deals!


Shop current deals

Top Kudoed Authors