English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

1 Posts

08-31-2020

US

1 Signins

40 Page Views

  • Posts: 1
  • Registered: ‎08-31-2020
  • Location: US
  • Views: 40
  • Message 1 of 27

X1 Extreme Gen 2 Vantage device disconnect sound

2020-08-31, 15:52 PM

Hello, recently got a x1 extreme gen 2. When using Lenovo Vantage to check for updates, it will usually hang at 95% for a few seconds and a device disconnect sound plays. It then goes on to complete the update check but the disconnect sound will repeat itself every ~20 seconds or so. When looking at device manager, it will refresh after the ~20 seconds. The only way to stop this is by restarting the computer. It only happens after running check updates in Lenovo Vantage. I tried using the Nirsoft usb tool to watch for activity and didn't see anything pop up. My windows install is up to date and I believe all of my Lenovo drivers/firmware are up to date as well based on the vantage app. 

 

Has anyone else had this happen or is it possible something hardware related is messed up? I've also tried doing a windows reset and reinstalling Lenovo Vantage with no fixes occurring.

 

 ""EDIT""

 

I tried using my external monitors and the sound nor device manager refresh happens if one of the USB-C ports are used for video out. If I just have one external monitor connected with the HDMI port and none with  USB-C, the issue still occurs. But then if I connect a monitor using a USB-C port while the repeat sound/refresh is occurring, it will stop. Very strange.

Reply
Options

8 Posts

06-07-2020

US

6 Signins

30 Page Views

  • Posts: 8
  • Registered: ‎06-07-2020
  • Location: US
  • Views: 30
  • Message 2 of 27

Re:X1 Extreme Gen 2 Vantage device disconnect sound

2020-09-01, 3:43 AM

happens to me too, started happening yesterday only

 

if i'm watching a video while i open the vantage tool the sound goes all weird for a couple of seconds while the entire system hangs

Reply
Options

854 Posts

03-11-2008

CN

1718 Signins

15264 Page Views

  • Posts: 854
  • Registered: ‎03-11-2008
  • Location: CN
  • Views: 15264
  • Message 3 of 27

Re:X1 Extreme Gen 2 Vantage device disconnect sound

2020-09-02, 5:59 AM
@oldermodel, What is your machine type? Do you run system update?
Reply
Options

6 Posts

09-02-2020

US

6 Signins

30 Page Views

  • Posts: 6
  • Registered: ‎09-02-2020
  • Location: US
  • Views: 30
  • Message 4 of 27

Re:X1 Extreme Gen 2 Vantage device disconnect sound

2020-09-02, 7:20 AM

Thought i'd chime in here and let everyone know my Thinkpad P1 does it also. Only happens when I run Lenovo Vantage or Lenovo System Update. Hoping Lenovo makes a fix for this, as I like to ensure my system is always running the latest drivers/bios I go on to Vantage quite often. 

 

Mirroring the original sentiment stated by the author, when this disconnect sound begins after running Vantage, my computer begins to hang and PC gets hot... maybe its running something in the background that ends up on a never ending spiral? 

 

Keep us posted for a fix!

 

Machine info: Thinkpad P1 (Machine Type: 20QTCTO1WW)   P1 Gen 2 (Type 20QT, 20QU) Laptop (ThinkPad) - Type 20QT

 

Thanks

Thinkpad P1 g2 - Xenon E-2276M 2.80GHz, 64GB ECC, 4TB EVO 980pro, Nvidia Quadro T1000, 15.6" FHD (1920 x 1080)
Reply
Options

854 Posts

03-11-2008

CN

1718 Signins

15264 Page Views

  • Posts: 854
  • Registered: ‎03-11-2008
  • Location: CN
  • Views: 15264
  • Message 5 of 27

Re:X1 Extreme Gen 2 Vantage device disconnect sound

2020-09-03, 2:51 AM

If you disconnect any external device, and run system update again.

Do you still see this issue?

We could not recreate this issue.

 

@adlen79,

Could you share the logs from below locations when this issue happened?

C:ProgramData\Lenovo\ImController\SystemPluginData\LenovoSystemUpdatePlugin\logs

And if you run the system update, do you still see this issue?

System update could be downloaded from here:

https://support.lenovo.com/us/en/downloads/ds012808

Reply
Options

9 Posts

08-10-2020

CA

9 Signins

60 Page Views

  • Posts: 9
  • Registered: ‎08-10-2020
  • Location: CA
  • Views: 60
  • Message 6 of 27

Re:X1 Extreme Gen 2 Vantage device disconnect sound

2020-09-03, 16:37 PM

I have complained to Lenovo several times about this issue, and I haven't been able to determine the trigger, but now I see that the Vantage program does trigger this. I actually have a tech coming to my house this afternoon because Lenovo thought that the motherboard was faulty. 

Reply
Options

6 Posts

09-02-2020

US

6 Signins

30 Page Views

  • Posts: 6
  • Registered: ‎09-02-2020
  • Location: US
  • Views: 30
  • Message 7 of 27

Re:X1 Extreme Gen 2 Vantage device disconnect sound

2020-09-03, 19:32 PM

Hi there - 

While Alden79 prepares his log file, I figured I'd share with you mine for review during the interim. Oldmachine, Alden79 and I are all experiencing the same issue. The only variance is that I have a P1 TP and theirs are X1. 

 

Also no peripherals or I/Os were plugged into the machine. I was running on battery at the time. HOWEVER this happens when PC is plugged in and when system is plugged into the Thinkpad port replicator. (P/N: 40AN0230US / ThinkPad Thunderbolt 3 Workstation Dock Gen 2)

 

[Lenovo System Update build: 2020-06-03 2.0.0.1] 9/2/2020 7:34:49 AM

 

Info 2020-09-02 , 07:34:49.034

at Tvsu.Engine.UpateTaskListDataBase.get_Instance()

Message: InitUpdateTaskListDataBase from file: C:\ProgramData\Lenovo\ImController\SystemPluginData\LenovoSystemUpdatePlugin\session\UpdateTaskList.xml

 

Info 2020-09-02 , 07:34:49.412

at Lenovo.Modern.Plugins.SystemUpdatePlugin.RequestResponder.UpdateADPolicySettings()

Message: ScheduleFile is exist , ScheduleTask is exist ,Use ScheduleTask  create ScheduleFile

 

Info 2020-09-02 , 07:34:49.415

at Lenovo.Modern.Plugins.SystemUpdatePlugin.SystemUpdateAgent.CreateSchedule()

Message: Task ScheduleInfo info: DayOfWeekSch Monday, DayOfMonthSch , UTCTimeToCheck 09:18:06, SchedulerAbility ON

 

Info 2020-09-02 , 07:34:49.430

at Lenovo.Modern.Plugins.SystemUpdatePlugin.SystemUpdateAgent.CreateSchedule()

Message: Settings in UpdateSchedule.xml is same with task, not need to update

 

Info 2020-09-02 , 07:34:49.438

at Lenovo.Modern.Plugins.SystemUpdatePlugin.RequestResponder..ctor()

Message: Request ScheduleInfo info: Frequency , PackageType , DayOfWeek , DayOfMonth , UTCTimeToCheck , SchedulerAbility , RecommendedAutoUpdates , Notify  

 

Info 2020-09-02 , 07:34:49.439

at Lenovo.Modern.Plugins.SystemUpdatePlugin.RequestResponder..ctor()

Message: UpdateSchedule.xml ScheduleInfo info: Frequency Weekly, PackageType Critical, DayOfWeek Monday, DayOfMonth , UTCTimeToCheck 09:18:06, SchedulerAbility ON, RecommendedAutoUpdatesON, Notify DownloadAndInstallIfNoReboot

 

Info 2020-09-02 , 07:34:49.439

at Lenovo.Modern.Plugins.SystemUpdatePlugin.RequestResponder..ctor()

Message: Combine ScheduleInfo info: Frequency Weekly, PackageType Critical, DayOfWeek Monday, DayOfMonth , UTCTimeToCheck 09:18:06, SchedulerAbility ON, RecommendedAutoUpdates ON, Notify DownloadAndInstallIfNoReboot

 

Info 2020-09-02 , 07:34:49.686

at Lenovo.Modern.Plugins.SystemUpdatePlugin.RequestResponder.<OnUserLoginEventAsync>d__40.MoveNext()

Message: Unable to get metrics setting

 

Info 2020-09-02 , 07:34:49.689

at Tvsu.Environment.EnvironmentManager..ctor()

Message: Starting Environment Manager...

 

Info 2020-09-02 , 07:34:49.747

at Lenovo.Modern.Plugins.SystemUpdatePlugin.RequestResponder.<OnUserLoginEventAsync>d__40.MoveNext()

Message: MetricsEnabled is NO

 

Info 2020-09-02 , 07:34:49.749

at Lenovo.Modern.Plugins.SystemUpdatePlugin.RequestResponder.<OnUserLoginEventAsync>d__40.MoveNext()

Message: ScheduleFile is exist , ScheduleTask is exist ,Use ScheduleTask  create ScheduleFile

 

Info 2020-09-02 , 07:34:49.750

at Lenovo.Modern.Plugins.SystemUpdatePlugin.SystemUpdateAgent.CreateSchedule()

Message: Task ScheduleInfo info: DayOfWeekSch Monday, DayOfMonthSch , UTCTimeToCheck 09:18:06, SchedulerAbility ON

 

Info 2020-09-02 , 07:34:49.750

at Lenovo.Modern.Plugins.SystemUpdatePlugin.SystemUpdateAgent.CreateSchedule()

Message: Settings in UpdateSchedule.xml is same with task, not need to update

 

Info 2020-09-02 , 07:34:50.610

at System.Runtime.CompilerServices.AsyncTaskMethodBuilder.Start[TStateMachine](TStateMachine& stateMachine)

Message: CheckUpdateTasklist get stage is idle

 

Info 2020-09-02 , 07:34:50.630

at Lenovo.Modern.Plugins.SystemUpdatePlugin.SystemUpdateAgent.<OnUserLoginEvent>d__99.MoveNext()

Message: Unload SystemUpdatePlugin

 

Info 2020-09-02 , 07:34:50.630

at Lenovo.Modern.Plugins.SystemUpdatePlugin.SystemUpdateAgent.<OnUserLoginEvent>d__99.MoveNext()

Message: CheckThirdRequestRunning: False

 

 

Thinkpad P1 g2 - Xenon E-2276M 2.80GHz, 64GB ECC, 4TB EVO 980pro, Nvidia Quadro T1000, 15.6" FHD (1920 x 1080)
Reply
Options

854 Posts

03-11-2008

CN

1718 Signins

15264 Page Views

  • Posts: 854
  • Registered: ‎03-11-2008
  • Location: CN
  • Views: 15264
  • Message 8 of 27

Re:X1 Extreme Gen 2 Vantage device disconnect sound

2020-09-04, 1:35 AM

We will try to test with  AC and Thunderbolt dock connected.

 

Reply
Options

6 Posts

09-02-2020

US

6 Signins

30 Page Views

  • Posts: 6
  • Registered: ‎09-02-2020
  • Location: US
  • Views: 30
  • Message 9 of 27

Re:X1 Extreme Gen 2 Vantage device disconnect sound

2020-09-04, 1:49 AM
Just confirmed this issue occurs ANYTIME system update or Vantage is run. Doesn't matter if its plugged into anything or not. The moment these programs run, the computer goes into a frenzy.
Thinkpad P1 g2 - Xenon E-2276M 2.80GHz, 64GB ECC, 4TB EVO 980pro, Nvidia Quadro T1000, 15.6" FHD (1920 x 1080)
Reply
Options

854 Posts

03-11-2008

CN

1718 Signins

15264 Page Views

  • Posts: 854
  • Registered: ‎03-11-2008
  • Location: CN
  • Views: 15264
  • Message 10 of 27

Re:X1 Extreme Gen 2 Vantage device disconnect sound

2020-09-04, 1:56 AM

@Frey01,Could you find  crash or error information in the event log at the same time system was hang?

From logs, it seems that you did not click the Check For Update button.

Does this issue happen when is not in check for update process?

 

If so, if you rename the following, does this issue still happen?

rename 

C:\ProgramData\Lenovo\ImController\Plugins\LenovoHardwareScanPlugin\x64\LSCDiags\LenovoDiagnostics.exe

 to 

LenovoDiagnostics_backup.exe

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete