Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

12 Posts

01-07-2020

Finland

20 Signins

199 Page Views

  • Posts: 12
  • Registered: ‎01-07-2020
  • Location: Finland
  • Views: 199
  • Message 401 of 926

Re: X1 Extreme Gen 2 missing keystrokes

2020-02-06, 9:22 AM

I think they border the same issue, but you are right, Lenovo should comment on this. It shouldn't be upto us to keep trying and failing to find out the cause. Typing this I get lag on keystrokes and also keep missing some keys (had to re-read to correct the errors).

Reply
Options

23 Posts

04-01-2016

Belgium

33 Signins

364 Page Views

  • Posts: 23
  • Registered: ‎04-01-2016
  • Location: Belgium
  • Views: 364
  • Message 402 of 926

Re: X1 Extreme Gen 2 missing keystrokes

2020-02-06, 9:59 AM

 wrote:

I don't know if anyone posted anything regarding this, but here it goes. I contacted Lenovo support and Vantage is not giving this firmware update at all. It helped a little on my end (not enough, but little :D), would wish to hear other thoughts too:

 

https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-x-series-laptops/thinkpad-x1-extreme-gen-2/downloads/driver-list/component?name=Mouse,%20Pen%20and%20Keyboard

 

TrackPoint Firmware Update Utility for Windows 10 (64-bit) - ThinkPad

https://download.lenovo.com/pccbbs/mobiles/n20g905w.exe



Where can I find the current version of the Trackpoint Firmware?

Reply
Options

23 Posts

04-01-2016

Belgium

33 Signins

364 Page Views

  • Posts: 23
  • Registered: ‎04-01-2016
  • Location: Belgium
  • Views: 364
  • Message 403 of 926

Re: X1 Extreme Gen 2 missing keystrokes

2020-02-06, 10:01 AM

I have the exact same thing with Citrix connections. 

 


 wrote:

As the issue is completely identical with P1 2nd gen model, gonna post this here for more eyes.

 

This issue can be reproduced easily when joining Teams meeting. (Not completely related, as this happens when no Teams on the machine, but seems to cause extra issues regarding this)

 

I tested with my old T470s with 100% same setup regarding external devices etc. No lag with typing/keyboard/external keyboard.

 

With P1 2nd gen same setup and test. 3-4 second lag between keys typed. Could reproduce this issue on all Teams meetings. Normally the lag between keystrokes is 0,5-1s but when Teams meeting is open it jumps to 3-4 seconds.

 

Edit: Actually can pinpoint the huge increase in keystroke lag to bluetooth devices. But can't completely erase the issue.


 

Reply
Options

11 Posts

09-19-2019

Australia

30 Signins

187 Page Views

  • Posts: 11
  • Registered: ‎09-19-2019
  • Location: Australia
  • Views: 187
  • Message 404 of 926

Re: X1 Extreme Gen 2 missing keystrokes

2020-02-06, 11:03 AM

 wrote:

As the issue is completely identical with P1 2nd gen model, gonna post this here for more eyes.

 

This issue can be reproduced easily when joining Teams meeting. (Not completely related, as this happens when no Teams on the machine, but seems to cause extra issues regarding this)

 

 


Try disabling GPU accceleration in Teams settings

Reply
Options

12 Posts

01-07-2020

Finland

20 Signins

199 Page Views

  • Posts: 12
  • Registered: ‎01-07-2020
  • Location: Finland
  • Views: 199
  • Message 405 of 926

Re: X1 Extreme Gen 2 missing keystrokes

2020-02-06, 11:34 AM

Tried, still glitchy 3-4s keystrokes/missing keys.

Reply
Options

11 Posts

09-19-2019

Australia

30 Signins

187 Page Views

  • Posts: 11
  • Registered: ‎09-19-2019
  • Location: Australia
  • Views: 187
  • Message 406 of 926

Re: X1 Extreme Gen 2 missing keystrokes

2020-02-06, 11:51 AM

 wrote:

Tried, still glitchy 3-4s keystrokes/missing keys.


My P1 Gen2 misses keystrokes on occasion, but has no observable  lag with Teams  or Citrix Workspace with the built-in keyboard

Reply
Options

12 Posts

01-07-2020

Finland

20 Signins

199 Page Views

  • Posts: 12
  • Registered: ‎01-07-2020
  • Location: Finland
  • Views: 199
  • Message 407 of 926

Re: X1 Extreme Gen 2 missing keystrokes

2020-02-06, 12:04 PM

Thats the funny thing. No idea what is causing it. I have tried the onboard keyboard, virtual keyboard and external keyboard, they all behave same way when a Teams meeting/call is on the way. When the meeting/call ends, it goes back to beeing "normal" 0,5-1s lag/missing keys when typing. This lag is not related per se to Teams/O365, as the behaviour with 0,5-1s lag/missing keys is repeatable on a machine with no O365/Teams installation.

Reply
Options

Re: X1 Extreme Gen 2 missing keystrokes

2020-02-06, 13:44 PM

Can you try deactivating the wifi and bluetooth modules?

Reply
Options

12 Posts

01-07-2020

Finland

20 Signins

199 Page Views

  • Posts: 12
  • Registered: ‎01-07-2020
  • Location: Finland
  • Views: 199
  • Message 409 of 926

Re: X1 Extreme Gen 2 missing keystrokes

2020-02-06, 13:53 PM

Tried that too, no change on the "normal" behaviour.

Reply
Options

8 Posts

12-08-2019

United States of America

35 Signins

160 Page Views

  • Posts: 8
  • Registered: ‎12-08-2019
  • Location: United States of America
  • Views: 160
  • Message 410 of 926

Re: X1 Extreme Gen 2 missing keystrokes

2020-02-06, 14:03 PM

It is strange. I also noticed 99% Intel GPU load under 0 load, just windows idle.

It might not be related, but it's weird...

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All