English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

7 Posts

07-08-2019

AU

11 Signins

65 Page Views

  • Posts: 7
  • Registered: ‎07-08-2019
  • Location: AU
  • Views: 65
  • Message 731 of 877

Re:X1 Extreme Gen 2 missing keystrokes

2020-04-10, 1:11 AM

 @joloriquelme  I was not expecting the response....I really appreciate your reply... thanks a lot bud. I'll go through this today... Though I'm always Lenovo/Windows fan and never used any Macbook. But the trust level MBP has created wrt to their hardware stability. I would say no one can neglect that fact... and seen many switched from windows to Mac with no regrets. Also, I totally agree with you, all the famous vlogger's reviews totally seem to be paid promotion. No one really fully tests and compares the specs, utilization and actual stats that we all need most... That's why I usually rely on communities like Reddit with lot of real people like you giving an honest opinion. Cheers Mate

Reply
Options

42 Posts

01-18-2019

US

80 Signins

750 Page Views

  • Posts: 42
  • Registered: ‎01-18-2019
  • Location: US
  • Views: 750
  • Message 732 of 877

Re:X1 Extreme Gen 2 missing keystrokes

2020-04-12, 16:04 PM

After installing BIOS v. 1.30 the missing keystrokes disappeared for me (third day in so far). Thanks for this and as someone said, better late than ever.

 

Interesting thing is that I occasionally still hear BIOS beeps when I type.

 

And thanks for the notebook check review link. They are indeed one of the most objective, if not the most objective, review portals remaining these days.

Reply
Options

6 Posts

09-27-2010

CH

74 Signins

351 Page Views

  • Posts: 6
  • Registered: ‎09-27-2010
  • Location: CH
  • Views: 351
  • Message 733 of 877

Re:X1 Extreme Gen 2 missing keystrokes

2020-04-13, 5:13 AM
I use both platforms every day, I have a X1 Extreme Gen. 2 and at the moment a 2018 MacBook Pro 13“ - with a long history of MacBook Pro‘s back to the PowerBooks. If still anyone thinks Apple is better or more reliable you might still live in some Apple marketing bubble.... Apple is - at least in the past 10 years as bad or even worse then their competitors. At least the others admit they made an error and try better next time. The honest and most hurtful (as a prior Apple fanboy) report you can find is from Louis Rossmann. https://youtu.be/AUaJ8pDlxi8
Reply
Options

34 Posts

06-11-2018

US

45 Signins

444 Page Views

  • Posts: 34
  • Registered: ‎06-11-2018
  • Location: US
  • Views: 444
  • Message 734 of 877

Re:X1 Extreme Gen 2 missing keystrokes

2020-04-13, 18:39 PM

I've been following this thread since Nov or Dec. Kind of annoyed it took lenovo this long to fix the issue but still happy it's finally addressed.

I installed the 1.30 bios and I'm not having any missing keystrokes in windows or linux. It appears to be fixed.

 

However the laptop does seem the have the periodic stutter that comes every minute or so. Disappointing considering mine has an i9.

 

Anyways, thanks to everyone who voiced their issues.

Reply
Options

159 Posts

12-01-2019

CL

171 Signins

1429 Page Views

  • Posts: 159
  • Registered: ‎12-01-2019
  • Location: CL
  • Views: 1429
  • Message 735 of 877

Re:X1 Extreme Gen 2 missing keystrokes

2020-04-13, 20:31 PM

@nicholasq I think you have the same problem: the Optimus one-sec freeze.

 

Try this little App. It can resolve your issue.

 

https://github.com/jobeid/TrayPwrD3

Reply
Options

4 Posts

03-02-2020

CH

8 Signins

30 Page Views

  • Posts: 4
  • Registered: ‎03-02-2020
  • Location: CH
  • Views: 30
  • Message 736 of 877

Re:X1 Extreme Gen 2 missing keystrokes

2020-04-13, 22:50 PM
1.30 fixes the acpi.sys problem 2... Finally I have really low latency with x1 extreme 2ndgen. Latency monitor: peak with 760 us after 5 Minutes, far enough for my fl Studio (tested with rme babyface usb 2.0 & uad Apollo x6 TB3). Well done Lenovo... Better late than never.
Reply
Options

29 Posts

10-11-2017

SG

83 Signins

387 Page Views

  • Posts: 29
  • Registered: ‎10-11-2017
  • Location: SG
  • Views: 387
  • Message 737 of 877

Re:X1 Extreme Gen 2 missing keystrokes

2020-04-14, 8:08 AM

It's glad to know the new bios solved problems for all (although I think my key-missing problems were solved in 1.29 patch).

 

I have never encountered any freezing problem. I notice someone said it might be the problem of activating discrete graphics card (which will cause the system to hang for 0.5 seconds or something), whenever you do some actions (such as right click -> display settings, battery icon, chrome and firefox tabs, PowerPoint slideshow etc). 

 

I am not sure why this isn't happening for my laptop, my discrete graphics will generally be in disabled mode, the integrated graphics card works perfectly, unless some applications such as games are on.

 

I also disabled turbo boost (I forgot why I did it, I just remember I followed from someone else's post. Was it possible that turbo boost might be related to periodic freezing?)

 

I disabled turbo boost by setting both minimum processor state and maximum processor state to 99% in "Plugged in" mode. I am not sure whether this will help the periodic hang too.

 

I actually also set the minimum processor state to 5% and maximum processor state to 80% in battery mode, which will greatly increase the battery life time.

 

I roughly tested, after setting this maximum processor state and turning display brightness to one level above the dimmest level, my x1e (4k display but no touch screen) will last as long as 7 hours when just doing some text editing and occasional surfing.

 

 

 

 

 

Reply
Options

1 Posts

04-18-2020

UA

1 Signins

35 Page Views

  • Posts: 1
  • Registered: ‎04-18-2020
  • Location: UA
  • Views: 35
  • Message 738 of 877

Re:X1 Extreme Gen 2 missing keystrokes

2020-04-18, 20:29 PM
I am just trying to update BIOS on same laptop. And after few minutes i had black screen and laptop still working 😫. What I need to do, please help
Reply
Options

7 Posts

03-23-2020

PL

14 Signins

70 Page Views

  • Posts: 7
  • Registered: ‎03-23-2020
  • Location: PL
  • Views: 70
  • Message 739 of 877

Re:X1 Extreme Gen 2 missing keystrokes

2020-04-26, 14:40 PM

Why did Lenovo remove 1.30 BIOS from the support site?

 

BIOS 1.29 is the latest version available again for some time.

 

 

Reply
Options

92 Posts

07-28-2017

DE

130 Signins

1420 Page Views

  • Posts: 92
  • Registered: ‎07-28-2017
  • Location: DE
  • Views: 1420
  • Message 740 of 877

Re:X1 Extreme Gen 2 missing keystrokes

2020-04-26, 20:22 PM

I noticed too that Lenovo removed Bios 1.30. What is the reason for this? Please give us an update in this.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete