cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
zzxjoanw
Paper Tape
Posts: 1
Registered: ‎12-15-2018
Location: US
Views: 803
Message 1 of 4

X1 Extreme bricked after setting boot mode to UEFI only with CSM disabled

Because I was trying to get Linux to boot on my new ThinkPad X1 Extreme, I disabled Secure Boot and set graphics to Discrete only. I wasn't able to boot Linux, but at least the machine was still working. I'm aware that some people's machines were bricked by the Discrete Only setting, but for me, that doesn't appear to be what caused it.

 

While troubleshooting the issue with Linux, I went into the BIOS to set it to boot using UEFI Only, and disabled CSM support, because I  wanted to force it to use UEFI. After I saved the settings and restarted the machine, however, it appears that the machine has been bricked. Now, every time I power it on, I see a cursor in the upper-left corner for a few seconds; it then disappears and leaves the screen completely black, then fan turns on for a few minutes, then the fan turns off. The Lenovo logo never appears, and I can't enter setup anymore.

 

I assume the only solution is to have the CMOS flashed, but I'm wondering whether Lenovo is aware of this issue?

Lenovo Employee Rydeen
Lenovo Employee
Posts: 376
Registered: ‎03-03-2017
Location: JP
Views: 660
Message 2 of 4

Re: X1 Extreme bricked after setting boot mode to UEFI only with CSM disabled

Dear customers,

regarding to the POST hang issue when switching Grphics mode from Hybrid to Discrete, development team identified the root cause and preparing the solution by BIOS #35(v1.17). It will be available by next Monday.

However, I'm sorry we couldn't find the way to recover the system by customers so that customers still need to contact Lenovo service to repair the planar.

Users who want to use discrete graphics, please update this BIOS #35(v1.17) first, then switched to discrete.

j1k2
Punch Card
Posts: 32
Registered: ‎12-22-2018
Location: US
Views: 615
Message 3 of 4

Re: X1 Extreme bricked after setting boot mode to UEFI only with CSM disabled

Rydeen, thank you for your attention to this serious matter.

 

As long as you are addressing BIOS bricking by changing from hybrid to discrete graphics, could you also address reports of bricking by other settings, such as:

 

- Switching to UEFI only?

- Disabling Secure Boot?

- BIOS support for Thunderbolt?

 

There should be NO circumstance in which ANY BIOS setting bricks the machine. I realize that it's impossible to test every single combination of settings, it would be great if you could fix the ones that have been reported.

 

I just bought a X1E 4K as an upgrade from my W520. I want to run Ubuntu on it, but reports of bricking are making me apprehensive. Windows is NOT an option. In the summer I bought a P52 and inadvertently bricked it by an incorrect BIOS setting. I got this X1E with hopes that in the intervening months the bricking problem would be solved (please make that  be true!)

 

As for the "BIOS support for Thunderbolt" problem, this message has good clue: https://www.notebookcheck.net/Some-recent-ThinkPads-can-be-bricked-by-changing-a-UEFI-BIOS-setting.3...

 

Thanks!

Jim

PeteD_805
Blue Screen Again
Posts: 3
Registered: ‎12-22-2018
Location: US
Views: 597
Message 4 of 4

Re: X1 Extreme bricked after setting boot mode to UEFI only with CSM disabled

I'm guessing you also tried the hard reset botton on the bottom?

 

I attempted to install Mint 19 as a second boot option and the system hangs after the KDE desktop comes up. I thought is was a vid card driver issue [which is common] as Linux is aways playing catch up. 

I have to look into the bios settings and hold until Lenovo comes up with a fix.

Good luck...

Check out current deals!


Shop current deals

Top Kudoed Authors