cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Pirate_captain
Paper Tape
Posts: 2
Registered: ‎12-18-2017
Location: US
Views: 1,858
Message 1 of 4

X1 Yoga 2nd Gen Thunderbolt dock USBs and ethernet not working.

Received Thunderbolt 3 dock for my X1 Yoga 2nd Gen.

It's charging the Yoga, the two displays are working.

ALL the USB and ethernet ports are not.

Did the updates, restart, repower of dock and Yoga.

I know the ethernet is good because I have been using an USB to ethernet directly connected to the yoga.

Yes I disconected the USB to ethernet adapter when trying the ethernet port on the dock.

 

tomaszd
Paper Tape
Posts: 2
Registered: ‎02-09-2018
Location: PL
Views: 1,641
Message 2 of 4

Re: X1 Yoga 2nd Gen Thunderbolt dock USBs and ethernet not working.

I have identical problem. Laptop is X1 Yoga 2nd Gen and Lenovo Thunderbold 3 Docking Station.
Display working, all other ports eg. USB and Ethernet just suppose to work. USBs gives just power to device, on Ethernet leds blink. But there is no communication to the laptop from them.
Any solution?
Wazza1
What's DOS?
Posts: 1
Registered: ‎03-12-2018
Location: AU
Views: 1,424
Message 3 of 4

Re: X1 Yoga 2nd Gen Thunderbolt dock USBs and ethernet not working.

Did you ever find a solution around this? I'm having a similar issue with a thunderbolt 3 hub. everything works except for the ethernet port even though it's active with lights blinking, laptop does not register ethernet adapter.

 

Anybody from lenovo got some insight around this?

Pirate_captain
Paper Tape
Posts: 2
Registered: ‎12-18-2017
Location: US
Views: 1,414
Message 4 of 4

Re: X1 Yoga 2nd Gen Thunderbolt dock USBs and ethernet not working.

I actually had to unplug the dock and remove the device drivers for Enet, USB and dock. Shutdown the Yoga, connect the dock and boot the Yoga. The Yoga identified the new devices Enet, USB and dock, it loaded the the device drivers (as they were still on the machine). And sure enough all the ports worked.

It appears that the first installation of the dock messes with the USB host process (can't find it's interface ID). Because on the re boot the dock installs first then Enet and UBS.

Check out current deals!


Shop current deals

Top Kudoed Authors