English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

11 Posts

12-09-2018

US

15 Signins

131 Page Views

  • Posts: 11
  • Registered: ‎12-09-2018
  • Location: US
  • Views: 131
  • Message 1 of 65

X1 Yoga 3rd Gen Crash on LTE (Fibocom L850-GL) during high speed download/heavy use

2018-12-16, 20:09 PM
I have a X1 Yoga 3rd Gen equipped with the Fibocom L850-GL LTE modem, using a Verizon LTE sim.
 
I ran into this issue whenever I'm using the LTE connection at high speed, Windows 10 has a high chance of crashing (BSOD).
 
This can be easily reproduced by running a speed test on speedtest.net. I'm in an area with good LTE signal, and my speed on the Verizon sim can reach around 200 mbps. When running the speed test, whenever it goes past around 130mbps, it has a pretty high chance of crashing. It's almost as if the module cannot handle that speed (maybe heat/power related).
 
I'm on a clean installation of Windows 10 1809 with the latest Lenovo drivers (including the Fibocom modem) installed.
 
Anyone else is having this issue?
Solved! See the solution
Reply
Options

15 Posts

05-01-2018

CH

38 Signins

374 Page Views

  • Posts: 15
  • Registered: ‎05-01-2018
  • Location: CH
  • Views: 374
  • Message 2 of 65

Re: X1 Yoga 3rd Gen Crash on LTE (Fibocom L850-GL) during high speed download/heavy use

2018-12-22, 13:12 PM

I can confirm I have the same issue.

 

Same setup as you, just finished installing the Fibocom card and during my first tests I ran into exactly the same issue as you: Win 10 bluescreens 100% when I run an internet speedtest via LTE. Last thing I can see is download speed running past 100Mbps, and then boom, bluescreen.

 

Latest updates, firmware, drivers, etc.

 

Speedtests on ethernet or wifi are no problem.

 

This is really not good.

Reply
Options

7 Posts

09-10-2018

JP

9 Signins

83 Page Views

  • Posts: 7
  • Registered: ‎09-10-2018
  • Location: JP
  • Views: 83
  • Message 3 of 65

Re: X1 Yoga 3rd Gen Crash on LTE (Fibocom L850-GL) during high speed download/heavy use

2018-12-22, 20:23 PM

I have excatlly same issue on my X1 Yoga Gen3, after upgrading RS5, October update 2018.

I already update to new driver v2.0.1.44, but still same problems...

Reply
Options

11 Posts

12-09-2018

US

15 Signins

131 Page Views

  • Posts: 11
  • Registered: ‎12-09-2018
  • Location: US
  • Views: 131
  • Message 4 of 65

Re: X1 Yoga 3rd Gen Crash on LTE (Fibocom L850-GL) during high speed download/heavy use

2018-12-22, 20:59 PM

Good to know I'm not the only one. So chances are this is not my particular unit/card being defective, and hopefully it's not a hard design issue, rather a driver/firmware issue that can be fixed by a later release. However, I would not bet on Lenovo fixing this super quickly. Some users on Reddit mentioned that it took Lenovo a year to release a working firmware on a previous model Sierra LTE modem. Yikes.

 

I do wonder if this is related to W10 1809. I wiped and clean installed right away upon receiving my laptop so I did not have a chance to do any tests while on 1803. Really don't have the time to go back and forth just to diagnose this issue.

  


I have excatlly same issue on my X1 Yoga Gen3, after upgrading RS5, October update 2018.

I already update to new driver v2.0.1.44, but still same problems...?

By any chance you can be certain that prior to the RS5 upgrade, the laptop did not exibit this issue? If we can be sure that it's just a matter of 1809, I won't mind just installing 1803 and stay on it till the issue is fixed.

 

 

Reply
Options

76 Posts

07-15-2018

US

185 Signins

1336 Page Views

  • Posts: 76
  • Registered: ‎07-15-2018
  • Location: US
  • Views: 1336
  • Message 5 of 65

Re: X1 Yoga 3rd Gen Crash on LTE (Fibocom L850-GL) during high speed download/heavy use

2018-12-22, 23:43 PM

As you said in another post, you installed wwan card and antenna by yourself?

 

So did you properly plug the tunable antenna connector into the camera module?

 

Because for LTE, a single channel download/upload speed is limited, to achieve high speed download/upload,  the wwan card must turn on Carrier Aggregation, which might need some operations on the antenna side. This might crash the OS if tunable antenna is not accessable.

Reply
Options

11 Posts

12-09-2018

US

15 Signins

131 Page Views

  • Posts: 11
  • Registered: ‎12-09-2018
  • Location: US
  • Views: 131
  • Message 6 of 65

Re: X1 Yoga 3rd Gen Crash on LTE (Fibocom L850-GL) during high speed download/heavy use

2018-12-23, 0:17 AM

I bought mine off ebay which comes with LTE already installed. I assumed it's from factory, as I thought it'd be unlikely for the seller to install this module. Is it possible to check for sure?

 

My machine type model is 20LES27P00. I just checked under my warranty -> Machine Info, the WWAN card appears to be unmentioned, 

 

Processor: 1x Intel Core i5-8350U Processor(Core i5-8350U)
Memory: 1x 16GBLPDDR3-2133
Operating System: Windows 10 Pro 64(EN:English)
Hard Drive: 1x 512PCIeNVMeOPAL
Wireless Network: 1x Bluetooth Version 4.1
Ports: 1x RJ-45
Camera: 1x 720p HD Camera with MIC
Graphics: 1x
Monitor: Multitouch
Included Warranty: 3YR Onsite NBD
Included Service: Premier Support
 
Edit: However, I just checked https://support.lenovo.com/us/en/partslookup
I entered my serial number, and under "Parts - > As-Built", it does list the WWAN card model and "Installed 1". So I assume the card is factory installed?
 
Reply
Options

11 Posts

12-09-2018

US

15 Signins

131 Page Views

  • Posts: 11
  • Registered: ‎12-09-2018
  • Location: US
  • Views: 131
  • Message 7 of 65

Re: X1 Yoga 3rd Gen Crash on LTE (Fibocom L850-GL) during high speed download/heavy use

2018-12-23, 4:13 AM

I ran some further tests today and interestingly, I couldn't reproduce the problem with Chrome browser. It crashes constantly with Edge browser, which is what I generally use on Laptops for better battery life, and on which I first noticed the problem.

 

Are those of you who're experencing the same issue happen to be using Edge? If so, can you try speedtest on Chrome?

Reply
Options

15 Posts

05-01-2018

CH

38 Signins

374 Page Views

  • Posts: 15
  • Registered: ‎05-01-2018
  • Location: CH
  • Views: 374
  • Message 8 of 65

Re: X1 Yoga 3rd Gen Crash on LTE (Fibocom L850-GL) during high speed download/heavy use

2018-12-23, 9:09 AM
Yes, the antenna camera connector cable is installed. Actually the antenna was installed by an official service technician. But I had to redo some of the antenna cable routing when my card arrived and it turned out the antenna cables were too short because of improper routing.
Reply
Options

15 Posts

05-01-2018

CH

38 Signins

374 Page Views

  • Posts: 15
  • Registered: ‎05-01-2018
  • Location: CH
  • Views: 374
  • Message 9 of 65

Re: X1 Yoga 3rd Gen Crash on LTE (Fibocom L850-GL) during high speed download/heavy use

2018-12-23, 9:09 AM
For me it crashes with any browser: Edge, Firefox, Chrome
Reply
Options

7 Posts

09-10-2018

JP

9 Signins

83 Page Views

  • Posts: 7
  • Registered: ‎09-10-2018
  • Location: JP
  • Views: 83
  • Message 10 of 65

Re: X1 Yoga 3rd Gen Crash on LTE (Fibocom L850-GL) during high speed download/heavy use

2018-12-28, 10:55 AM

me too. It dosen't depend on any kind of web browser. Edge, Chrome, Firefox, everything. It is caused by highly big date transfer.....

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete