cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Gee-Man521
Blue Screen Again
Posts: 2
Registered: ‎11-29-2018
Location: US
Views: 280
Message 1 of 1

X1 Yoga 3rd Gen - eGPU issues

Brand new X1 Yoga 3rd Gen with i7 8650 and Win 10 Pro - "Known good" Aorus 1070 eGPU box (and factory TB3 cable that might be 18" long.

 

I have been using the Aorus1070 with my Dell XPS 15 but the 2 lanes of PCIe on my XPS warranted an upgrade. I really like the X1 Yoga and want to jump ship from Dell to Lenovo but not if the eGPU issues cant be fixed.

(I haven't owned/used an IBM laptop since back in 2000 when it was still IBM)

 

Issue 1 - eGPU won't power on.

Issue 2 - Computer freezes (with or without BSOD)

Issue 3 - False charging (not the common issue)

Issue 4 - Mouse freeze

 

Smiley Sad

 

Issue 1 - The Aorus box has no power switch and should automatically turn on when the computer turns on. The Aorus box will only power on around 1 out of 5 restarts/power-ons. When the laptop is up and running I can try unplugging and plugging in the TB3 cable and maybe 1 in 10 attemps prompts the Aorus box to power on. Most of the attempts to plug in the Aorus box while the laptop is powered on results in an instant Smiley Sad BSOD.

 

Issue 2 - Whenever the 1 in 20 attemps to power on the Aorus box is successful and I can use the eGPU I can sometimes get anywhere from 2-4 hours of gameplay out of it before freezes - Sometimes there will be a Smiley Sad BSOD but other times the image is just frozen and the last 0.5 second of audio re-re-re-re-re-re-re-peats until I hard kill the laptop.

 

Issue 3- The charging issue is not the one that google loves to show me when I search for it. It's not the "plugged in, not charging" issue. The small light next to the TB3 port changes colors based on charging, charged, or if no cable is plugged in. The Aorus box can supply 100W of power to charge which is more than enough. The issue is that sometimes the laptop thinks it's plugged in when it's not. If I hover my mouse over the icon it will say "plugged in, charging" AND the light by the TB3 port will be either orange/white but there's no charger plugged in. I only found this issue because of the repeating USB disconnect sound every 1-2 seconds.

(After multiple restarts - Reinstalling windows - Manually removing and reinstalling drivers - The only way I got this to stop was to open up the laptop and disconnect the battery)

 

Issue 4 - I have 2 mice connected to the laptop. A wired Logitech G502 and a wireless Logitech (insert cheap model number.) The Wired G502 freezes every 5-10 seconds and stays frozen for 2-5 seconds. If I move the wireless mouse or touch the screen or touchpad the cursor will move - This has worked consistently. I eventually unplugged and threw my G502 at the wall which is a duct-tape fix for this, but I would stil like to be able to use my gaming mouse again.

 

Attempts I've made:

Used the "Reset Windows" option that deletes the most stuff. Updated all Lenovo drivers, windows drivers, flashed the BIOS, flashed the TB3, flashed the Aorus box Firmware, tried older version of TB3 software. I thought throwing my mouse would help but I guess not. I am currently downloading a fresh copy of Win 10 to install it without all of the Lenovo bloat.

Check out current deals!


Shop current deals

Top Kudoed Authors