cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
zlice
Punch Card
Posts: 12
Registered: ‎05-01-2018
Location: US
Views: 649
Message 1 of 4

X1 carbon 6th 2018 HDMI doesn't work with all monitors (can't update BIOS)

So I've messed around with this my whole afternoon.

What I've found out is that the X1C I just got will not notice my monitor (samsung px2370), however, it will notice my TV just fine.

Figured I would try a BIOS update...well I already have Linux installed and the BIOS update options are "Windows" or "CD"...why...there is a CD/DVD option...in 2018...on a model that does not have a direct CD/DVD drive - is beyond me.
I've tried copying the iso image with 'dd' and booting from it but that doesn't work.

Suggestions?

zlice
Punch Card
Posts: 12
Registered: ‎05-01-2018
Location: US
Views: 580
Message 2 of 4

Re: X1 carbon 6th 2018 HDMI doesn't work with all monitors (can't update BIOS)

ended up extracting (7z) from the iso and dd-ing that image to a usb

didn't help anything, still not able to connect the x1 to this monitor (that i'm typing on, right now. that has worked work a dozen devices)

Expatmark
Punch Card
Posts: 47
Registered: ‎05-04-2018
Location: US
Views: 564
Message 3 of 4

Re: X1 carbon 6th 2018 HDMI doesn't work with all monitors (can't update BIOS)

I am getting an error on monitor to use cables that came with system. The ones that came with system were the ones that came with LG Monitor and both USB  and HDMI give same error.

 

The erros says  "(Caution) Make sure to use supplied input cables" I am using the supplied input cables from LG.

There is a pop up window that says "Do not display this message again" with close next to it and ok below it. I can not click on anything until it goes away.

zlice
Punch Card
Posts: 12
Registered: ‎05-01-2018
Location: US
Views: 529
Message 4 of 4

Re: X1 carbon 6th 2018 HDMI doesn't work with all monitors (can't update BIOS)

looks like the monitor is not responding to the intel driver trying to find EDID


[  633.450773] [drm:drm_helper_probe_single_connector_modes [drm_kms_helper]] [CONNECTOR:71:HDMI-A-1] disconnected
[  633.450806] [drm:drm_helper_probe_single_connector_modes [drm_kms_helper]] [CONNECTOR:74:DP-2]
[  633.450840] [drm:intel_dp_detect [i915]] [CONNECTOR:74:DP-2]
[  633.450868] [drm:intel_power_well_enable [i915]] enabling power well 2
[  633.450912] [drm:intel_power_well_disable [i915]] disabling power well 2
[  633.450946] [drm:drm_helper_probe_single_connector_modes [drm_kms_helper]] [CONNECTOR:74:DP-2] disconnected
[  633.450963] [drm:drm_helper_probe_single_connector_modes [drm_kms_helper]] [CONNECTOR:78:HDMI-A-2]
[  633.450996] [drm:intel_hdmi_detect [i915]] [CONNECTOR:78:HDMI-A-2]
[  633.503931] [drm:gmbus_xfer [i915]] GMBUS [i915 gmbus dpc] timed out, falling back to bit banging on pin 4
[  633.506697] [drm:drm_do_probe_ddc_edid [drm]] drm: skipping non-existent adapter i915 gmbus dpc
[  633.506740] [drm:intel_hdmi_set_edid [i915]] HDMI GMBUS EDID read failed, retry using GPIO bit-banging
[  633.506779] [drm:intel_gmbus_force_bit [i915]] enabling bit-banging on i915 gmbus dpc. force bit now 1
[  633.509493] [drm:drm_do_probe_ddc_edid [drm]] drm: skipping non-existent adapter i915 gmbus dpc
[  633.509533] [drm:intel_gmbus_force_bit [i915]] disabling bit-banging on i915 gmbus dpc. force bit now 0
[  633.562736] [drm:gmbus_xfer [i915]] GMBUS [i915 gmbus dpc] timed out, falling back to bit banging on pin 4
[  633.565494] [drm:drm_dp_dual_mode_detect [drm_kms_helper]] DP dual mode HDMI ID:  (err -6)
[  633.565508] [drm:drm_helper_probe_single_connector_modes [drm_kms_helper]] [CONNECTOR:78:HDMI-A-2] disconnected
[  636.448133] [drm:edp_panel_vdd_off_sync [i915]] Turning eDP port A VDD off
[  636.448208] [drm:edp_panel_vdd_off_sync [i915]] PP_STATUS: 0x80000008 PP_CONTROL: 0x00000007 

 

after trying to use "read-edid / get-edid" on my machine where this monitor works

Reading next EDID block

VBE/DDC service about to be called
	Read EDID

	Performing real mode VBE call
	Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
	Function supported
	Call successful

  ÿÿÿÿÿÿL-WW02Z0	x*TL&PT©@@³:q8-@X,E ZrQÐ n(U Zý2<
      üSyncMaster
EDID claims 1 more blocks left
EDID blocks left is wrong.
Your EDID is probably invalid.
  Looks like VBE was successful. Have a good day.



so i'm guessing i have a problem with my monitor. and my laptop is responding "fine" because it's not getting something it should

 

Check out current deals!


Shop current deals

Top Kudoed Authors